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Chapter 1

1. Introduction

The ImageVision™ tools are a suite of applications that let you view, enhance, arrange,
and obtain information on images, which can then be printed or used in other Silicon
Graphics® applications. The ImageVision application tools are ImageView, ImageCopy,
ImageInfo, ImageFormats, Image Works, and ImageTcl.

Here are some of the ways you can use the ImageVision tools with other Silicon Graphics
applications:

• Use the Capture tool to take a picture of an image, and then use the Image Works
and Image View tools to enhance the image and arrange it with other images.

• Customize an image using the ImageVision tools, then use the image in the Movie
Maker application to make your own movies.

• Add a voice-over to an image using the Sound Editor application.

• Print your image to use in hard-copy presentations.

This book contains the following additional chapters:

Chapter 2, “ImageView,” describes how to view images, save images to different file
formats, manipulate and compare images, arrange multiple images, and obtain
information on images.

Chapter 3, “ImageCopy, ImageInfo, and ImageFormats,” describes command-line
utilities available to you. These tools let you copy and change the format of image files,
obtain information about image files, and see a list of supported file formats.

Chapter 4, “Image Works,” describes how to manipulate images—blur, sharpen, stretch,
scale, and flip images—and save them to a file. Many of these image manipulations are
also available in the ImageView tool described in Chapter 4.

Chapter 5, “ImageTcl,” describes how to write your own scripts or programs,
incorporating the image-processing operations available in the ImageVision Library®

(IL).
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Chapter 1: Introduction

The icons for the ImageVision tools are located on the MediaTools page of the Icon
Catalog. To open the MediaTools page of the Icon Catalog, choose Media Tools from the
Find menu of the desktop toolchest.

Conventions

This guide uses the following conventions:

• References to other documents are in italics.

• References to other chapters and sections within this guide are in quotation marks.

• Names of buttons found in dialog boxes and panels are in italics.

• “Clicking” refers to pressing and releasing the left mouse button, unless otherwise
specified.

• “Dragging” refers to pressing and holding the left mouse button while moving the
mouse in the desired direction, unless otherwise specified.

• The “+” character is used to indicate a sequence of keyboard keys to be pressed (for
example, Ctrl+A). While holding down the indicated command key, press the
indicated letter key.

Step-by-step instructions used to perform a task are shown as numbered sentences.
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Chapter 2

2. ImageView

This chapter contains these sections:

• “About ImageView”

• “Using ImageView”

• “Arranging Views in the Window”

• “Comparing Images”

• “Changing the Part of the Image Displayed in a View”

• “Options for Screen Display: RGB Mode and Double Buffer”

• “Obtaining Information on Images”

• “Enhancing the Image Appearance”

• “Manipulating Geometric Aspects of an Image”

• “Selecting a Component, Sub-Image, or Frame”

• “Data on the Distribution of Component Values”

The imgview icon is on the MediaTools page of the Icon Catalog. To open ImageView,
choose Media Tools from the Find menu of the desktop toolchest, and double-click the
imgview icon. You can also enter imgview  in a shell window.

About ImageView

ImageView lets you view images and manipulate the appearance of images. Multiple
images can be imported into the same window, allowing for comparison between images
or for the creation of image collages. ImageView also allows you to obtain various kinds
of information and technical data on images.
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Chapter 2: ImageView

The ImageView window is shown in Figure 2-1.

Figure 2-1 The ImageView Window

The ImageView window contains three main menus and a help menu:

File Allows you to open images and to import multiple images into one
window; to print images and to save images, into a different file format
if desired; and to close image files and quit ImageView.

View Allows you to arrange, compare, and delete images, to select all images,
and to resize the window.

Options Allows you to obtain various kinds of information on images; to
manipulate the appearance of images; to choose how images are
displayed on the screen; and to select specific components, sub-images,
or frames of images.

The balance of the ImageView window is the image area. As you open and import
images, they appear in the image area.
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Using ImageView

These sections describe basic operations in ImageView:

• “Opening Images”

• “Importing Additional Images into a Window”

• “Understanding Images and Views”

• “Selecting and Deselecting Views”

• “Deleting Images”

• “Printing an Image, View, or Window”

• “Saving an Image, View, or Window Under the Current Name”

• “Saving an Image, View, or Window Under a New Name or Format”

• “Sizing the Window”

• “Closing a Window or Quitting ImageView”

• “Customizing”

The imgview icon is on the Media Tools page of the Icon Catalog. To open ImageView,
choose Media Tools from the Find menu of the desktop toolchest, and double-click the
imgview icon. You can also type imgview  in a shell window.

Opening Images

Choose the Open command from the File menu to open an image file. To open additional
files in separate ImageView windows, continue to use the Open command.

If you wish to view multiple images in the same window, you must open the first image,
then import the additional images. See “Importing Additional Images into a Window”
for more information.



6

Chapter 2: ImageView

Opening a Specific Sub-Image

In certain file formats, such as PhotoCD, an image file can contain multiple sub-images.
You can specify which sub-image you wish to open by typing the filename followed by
a colon and the number of the sub-image (for example, Sunrise:3 ). Use the ImageInfo
tool to get a list of the sub-images in an image file. See “Getting Information About an
Image” and the imginfo(1) reference page for more information on that tool.

Importing Additional Images into a Window

Once you have opened an image file in an ImageView window, choose the Import
command from the File menu to import additional images into the same window.

Importing a Specific Sub-Image

In certain file formats, such as PhotoCD, an image file can contain multiple sub-images.
You can specify which sub-image you wish to import by typing the filename followed by
a colon and the number of the sub-image (for example, Sunrise:3 ). Use the ImageInfo
tool to get a list of the sub-images in an image file. See “Getting Information About an
Image” and the imginfo(1) reference page for more information on that tool.

Overlapping of Multiple Images in a Window

When multiple images are present in one window, images may overlap, with higher
images partially or completely obscuring lower images until they have been rearranged.
See “Arranging Views in the Window” for information on how to rearrange images.

Understanding Images and Views

At times only a part of an image will be displayed in the window. That is, the image
appears to be cropped. The entire image is still present in the window, although only a
portion of the image is visible on the screen. The portion of the image displayed in the
window is considered a “view”—it is your current view of the image.

You might think of the view as a movable and adjustable framed window placed on the
image. The portions of the image falling outside the frame are not visible on the screen.
However, you can move the frame over the image, or change the size of the frame, to
obtain a different view of the image.
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The relationship of the “view” to the “image” in ImageView is shown in Figure 2-2.

Figure 2-2 View of an Image

Note that selecting a view—that is, selecting the visible part of the image—also selects
the entire image (see “Selecting and Deselecting Views”). Similarly, moving a view
within the window also moves the image, except when you are specifically moving the
frame of the view relative to the image itself, in order to display a different part of the
image (see “Arranging Views in the Window” and “Changing the Part of the Image
Displayed in a View”).

Selecting and Deselecting Views

Click inside a view to select it. To select each additional view, press the Shift key and click
inside the view. To select all the views, choose Select All from the View menu.

When a view is selected, yellow dots appear at points around its perimeter.

To deselect a view that has been selected, click outside the view in a non-selected area of
the window, or press the Shift key and click inside the view.

Deleting Images

To delete an image, select it and then choose Delete from the View menu. Alternatively,
you can press the Delete key after selecting the image.
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Chapter 2: ImageView

Printing an Image, View, or Window

When you choose the Print command from the File menu, the Print Image window
opens, offering you a number of printing options. To print a specific image or view when
you are working with multiple images in one window, you must select the view prior to
choosing the Print command.

Choosing the Area to be Printed

In the Area field of the Print Image window, choose the area of the window you wish to
print, from the three options offered:

• Click the Full Window box to print the entire image area of the window, consisting
of all the views exactly as they appear in the window and any visible window
background.

• Click the Full Image box to print the entire selected image, even if only a cropped
portion of it is displayed in the view on the screen.

• Click the Cropped Image box to print the selected view—that is, to print only the
part of the image that is being displayed on the screen.

For more information on the difference between an image and a view (a “cropped
image”), see “Understanding Images and Views.”

Saving an Image, View, or Window Under the Current Name

Choose the Save command from the File menu to save your work under the current
filename. To save a specific image or view when you are working with multiple images
in one window, you must select the view prior to choosing the Save command.

When you choose the Save command, the Save window opens with a message asking
whether you are sure you want to overwrite the file. If you do not wish to do so, click the
Cancel button. Otherwise, choose the area of the window you wish to save and click the
OK button.
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Choosing the Area to be Saved

In the Area field of the Save window, choose the area of the window you wish to save
under the current filename, from the three options offered:

• Click the Full Window box to save the entire image area of the window, consisting
of all the views exactly as they appear in the window and any visible window
background. Note that this collage of views and background is then saved as one
new image.

• Click the Full Image box to save the entire selected image, even if only a cropped
portion of it is displayed in the view on the screen.

• Click the Cropped Image box to save the selected view—that is, to save only the
part of the image that is being displayed on the screen. Note that this cropped view
is then saved as the entire new image.

For more information on the difference between an image and a view (a “cropped
image”), see “Understanding Images and Views.”

Saving an Image, View, or Window Under a New Name or Format

Choose the Save As command from the File menu to save your work under a different
filename, thus not overwriting the opened file. You can also use the Save As command
to save your work to a different file format, under the original filename or another
filename.

If you are working with multiple images in one window and are using the Save As
command to save a specific image or view, you must select the view prior to choosing the
command from the File menu.

Note that after you have finished saving a file using the Save As command, you are still
in the originally opened file.

When you choose the Save As command, the Save As window opens, with a number of
options.
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Choosing the Area to be Saved

From the three options offered in the Area field of the Save As window, choose the area
of the window you wish to save:

• Click the Full Window box to save the entire image area of the window, consisting
of all the views exactly as they appear in the window and any visible window
background. Note that this collage of views and background is then saved as one
new image.

• Click the Full Image box to save the entire selected image, even if only a cropped
portion of it is displayed in the view on the screen.

• Click the Cropped Image box to save the selected view—that is, to save only the
part of the image that is being displayed on the screen. Note that this cropped view
is then saved as the entire new image.

For more information on the difference between an image and a view (a “cropped
image”), see “Understanding Images and Views.”

Choosing a File Format

The Format field of the Save As dialog box allows you to save in a number of different
file formats, including IL TCL Script Image, FIT, SGI, JFIF/JPEG, Raw Image, TIFF, PNG,
PPM, and GIF. Any additional file formats that are available on your system will also
appear as options in the Format field.

• SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase™.

• TIFF format is the most common and useful file format.

• FIT format is not a standard, but is supported by the ImageVision Library (IL).

• GIF, JFIF/JPEG, and PNG formats are useful for World Wide Web documents. GIF
does not have the color capability necessary for publishing or technical uses.
JFIF/JPEG format uses very little disk space at the expense of some picture detail.

If you have the IRIS Development Option, you can refer to the Image Format Library
(IFL) manual pages for additional information on the various file formats. If you have
access to the World Wide Web, you can refer to these IFL manual pages by visiting the
following site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html
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Choosing the Attributes

In order to set the attributes of the material you are saving, click on Set in the Attributes
field of the Save As dialog box. The Set Attributes panel opens, with fields for page size,
data type, dimension order, color model, orientation, and compression. Default settings
are based on the current format of the file and the file format to which you are saving.

If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages—IFL(3)—for additional information on the file attributes. You can also view these
IFL manual pages if you have access to the World Wide Web, by visiting the following
site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html

Sizing the Window

Using the Resize Window Command

Choosing the Resize Window command under the View menu resizes the window so
that the image area of the window is as long as the longest image and as wide as the
widest image in the window. In addition, using the Resize command resizes each view
to display the full image and returns each image to its original position in the window.

Using the Window Manager to Size the Window

You can use the window manager to change the size of the window by clicking the box
in the upper left corner of the window and choosing the Size command, or by placing
your cursor on an edge or corner of the window. Drag the window border to change the
size of the window.

When the Auto Recenter command in the Options menu is turned on, the images in the
window shift position as you drag the window border, so that they remain in
approximately the same position relative to each other and the window. If the Auto
Recenter option is turned off, the views in the window do not shift as you drag the
window border.

Click the Auto Recenter command to toggle it on and off. A checkmark indicates that the
option is turned on.
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Closing a Window or Quitting ImageView

Choose the Close command from the File menu to close an ImageView window. To quit
ImageView, choose Quit from the File menu.

Customizing

Several options are available to you for customizing aspects of your ImageView window,
such as its location, size, and appearance. For information on these options, see the
imgview(1) reference page.

Arranging Views in the Window

These sections describe how to rearrange views:

• “Moving a View”

• “Raising or Lowering a View”

• “Centering a View”

Moving a View

To move a view to a new position in the window, first place the cursor completely inside
the view. The cursor takes the shape of crossed arrows. Then click with the left mouse
button (selecting the view) and drag the cursor to move the view.

Auto-Move

If you hold down the Ctrl key and begin to drag the view in a certain direction, the view
will continue to move in that direction automatically. It stops if you release either the left
mouse button or the Ctrl key. (You can choose the Center command from the View menu
to retrieve the image if it moves beyond the window borders. If the image has become
deselected, first choose the Select All command from the View menu.)
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Raising or Lowering a View

To raise or lower a view, thus switching the stacking order of the views, select the view
and choose the Raise or Lower command from the View menu. You can also use the up
and down arrow keys on your keyboard to raise or lower a selected view.

Centering a View

After selecting a view, choose the Center command from the View menu to move that
view to the center of the window. Using this command also resizes the view so that the
entire image is displayed.

Comparing Images

ImageView allows you to compare multiple images using commands that produce views
of each image and arrange the views in the window for easy comparison. For example,
you can compare the left half of one image with the left half of another image or you can
compare the left half of one image with the right half of another image.

These sections describe how to use ImageView commands to compare images:

• “Using the Compare Commands”

• “Comparing the Same Area of Multiple Images”

• “Comparing Different Areas of Multiple Images”

Using the Compare Commands

The commands described in this section are most useful when you are comparing similar
images, of the same size. For example, the functions described here are useful when
comparing two images that were initially identical but have had their color aspects
modified (see “Enhancing the Image Appearance”).

Note that all images present in the window—not only the selected images—are included
in the compare procedures when you use these commands.
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The compare commands are most convenient to use when the window is the same size
as the images to be compared. To make the window the exact size of the full image,
choose the Resize Window command from the View menu.

Comparing the Same Area of Multiple Images

To compare the same area of multiple images—for example, the left half of one image and
the left half of another image—choose the Same command from the Compare sub-menu
of the View menu.

ImageView produces a view of the left section of each image. To the extent possible, the
views produced are the same size and display the same section of the image. The views
are arranged in the window in as square a formation as possible. See Figure 2-3 for an
illustration of the Same command used in a window containing two initially identical
images, one of which has been modified.

Figure 2-3 Using the “Same” Command in a Window with Two Images

To shift the boundary between any two views, see “Adjusting the Boundary Between
Views.”
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Comparing Different Areas of Multiple Images

To compare adjacent areas of multiple images—for example, the left half of one image
and the right half of another image—choose the Aligned command from the Compare
sub-menu of the View menu.

ImageView produces a view of each image. To the extent possible, the views produced
are the same size and each view displays an adjacent section (area). ImageView arranges
these views so that adjacent views are placed next to each other, and all views are aligned
to the same origin. Views are arranged in as square a formation as possible.

See Figure 2-4 for an illustration of the Aligned command used in a window containing
two initially identical images, one of which has been modified.

Figure 2-4 Using the “Aligned” Command in a Window with Two Images

To shift the boundary between any two views, see “Adjusting the Boundary Between
Views.”
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Changing the Part of the Image Displayed in a View

These sections describe how to change what part of the image is displayed in the view,
by altering the size and shape of the view or by roaming through the image:

• “Changing the Size and Shape of Views”

• “Adjusting the Boundary Between Views”

• “Roaming Through Images”

Changing the Size and Shape of Views

To change what portion of the image will be displayed in a view by altering the view’s
dimensions:

1. Place the cursor on an edge or corner of the view.

The cursor changes shape to indicate its correct placement on the edge or corner.

2. Click with the left mouse button (selecting the view) and drag the cursor to move
the edge or corner and change the dimensions of the view.

If you hold down the Ctrl key while dragging an edge or corner, the opposite edge or
corner of the view will also move, in a mirroring fashion. This resizes the view without
shifting its center.

Note that you cannot move the edges of the view beyond the edges of the image itself.
That is, you cannot drag the cursor beyond the image border.

Adjusting the Boundary Between Views

To move the boundary between adjacent views, both views must be selected. Position the
cursor at the boundary between the views. Hold down the Alt key, click with the left
mouse button, and drag the boundary.

Note that you cannot move the edges of a view beyond the edges of its image.That is, you
cannot drag the cursor beyond the image border.
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Roaming Through Images

To scroll through an image without changing the dimensions or position of the view, click
inside the view with the middle mouse button, and drag the cursor. The view remains
stationary while the image shifts within it.

If you hold down the Ctrl key and begin to drag the image within the view using the
middle mouse button, the image continues to move in that direction automatically. It
stops if you release either the mouse button or the Ctrl key.

To roam through an image by shifting the position of the view, hold down the <Alt> key,
click inside the view with the left mouse button, and drag the view. The image will
remain stationary while the view moves over it.

Options for Screen Display: RGB Mode and Double Buffer

The RGB Mode and Double Buffer commands under the Options menu affect how
images are displayed on the screen. You can toggle the RGB Mode or Double Buffer
option on and off by dragging the cursor to the option name and releasing, or clicking on
the option name. A checkmark indicates that the option has been turned on.

The default settings for these two options depend on the hardware capabilities of your
system. For some systems, changing the RGB Mode or Double Buffer option does not
result in a discernible difference in the image display.

Option for Storing Screen Colors: RGB Mode

If RGB Mode is turned on, screen colors are stored directly in the ImageView window. If
RGB mode is off, colors are instead stored as index numbers, resulting in more efficient
image processing but some loss in color complexity.

Option for Double Buffer Copies of Images

The Double Buffer option controls whether the ImageView window is single-buffered or
double-buffered. If the Double Buffer option is turned on, procedures such as roaming
through an image are smoother. However, in some systems there is a loss in pixel depth.
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Obtaining Information on Images

These sections describe how to obtain certain information in ImageView:

• “Information on Close-Up Views of Images”

• “General Information on Images”

Information on Close-Up Views of Images

To obtain information on a close-up view of the image, place your cursor in the area you
wish to see close up and choose the Detail command from the Options menu. The Image
Detail window opens, with a magnified view of the area and information on the area.
Click the button in the Image Detail window to select the degree of magnification of the
close-up view.

The Image Detail window lists the following information:

• the position of the cursor in the source image

• the coordinates of the origin of the view with respect to the image

• the size of the source view

• the value of each component of the color model at the current cursor position

All location and size information is given in pixels.

As you move the location of the cursor in the source image, the area being magnified and
described in the Image Detail window changes.

General Information on Images

To obtain general information on an image, select the image and then choose Info from
the Options menu. The Info window opens.

If the selected image has not been altered, the Info window includes filename, file format,
and file size. If the image has been altered (for example, magnified), the Info window
instead lists the file description, class name, and size.
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The Info window also lists file attributes such as image size, page size, data type,
dimension order, color model, orientation, statistical range, and display range.

If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages—IFL(3)—for additional information on file attributes. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html

Enhancing the Image Appearance

These sections describe how to enhance the appearance of an image:

• “General Instructions for Enhancing the Image Appearance”

• “Adjusting Image Sharpness”

• “Adjusting Image Brightness, Haze, Contrast, and Saturation”

• “Performing Histogram-Based Scaling to Enhance an Image”

• “Converting an Image to Its Photographic Negative”

General Instructions for Enhancing the Image Appearance

To enhance the appearance of an image, select the image and choose the Process
command from the Options menu. The Process window appears, with three tabbed
subpanels: Enhance, Geom, and Options. To access each subpanel, click on the displayed
tab name or choose the subpanel name from the Edit menu of the Process window.

You use primarily the Enhance subpanel and secondarily the Options subpanel to
enhance the appearance of the image.

Adjusting Settings in the Enhance and Options Subpanels

Adjust settings that involve a pictured dial by placing the cursor on the pictured dial,
then dragging to “move” the dial higher or lower. You can also adjust each setting by
clicking the up and down arrows pictured, or by typing a setting amount into the setting
box and then pressing the Enter key. To return to the original setting, click the small box
to the right of each dial.
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Undo and Redo Commands

Choose Undo from the Edit menu of the Process window to undo the last change made
in any subpanel of the Process window. Choose Redo from the Edit menu to reverse the
last undo.

To return all the settings and option boxes in all three subpanels to their original
positions, choose Reset All from the Edit menu of the Process window.

Adjusting Image Sharpness

Adjust the sharpness of the image using the Enhance subpanel of the Enhance command.
Sharpness refers to how crisp or blurred the image appears.

Changing the Kernel Radius

You can further alter the sharpness of the image by changing the radius of the kernel,
using the Options subpanel of the Process window. The “kernel” is the group or
neighborhood of pixels used in calculations to sharpen or blur an image. Generally, the
larger the kernel radius, the more pronounced the effect of either sharpening or blurring
the image using the Enhance subpanel. However, using a larger kernel radius also results
in a more time-consuming process.

Setting the Kernel Status

You can also choose whether the kernel is “separable” or not, using the Separable box
above the kernel radius dial in the Options subpanel. If the kernel is separable, the
sharpening process is less accurate but more efficient and faster.

Click the Separable box to toggle it on and off. A checkmark indicates that it is turned on.

The kernel is always “separable” when blurring an image, so the Separable option is
relevant only when making images sharper.

Adjusting Image Brightness, Haze, Contrast, and Saturation

You can adjust the brightness, haze, contrast, and saturation of the image using the
Enhance subpanel. Saturation refers to the vividness or purity of each color.
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Performing Histogram-Based Scaling to Enhance an Image

To enhance the selected image using histogram-based scaling, choose the Histogram
Scale command from the Operator menu of the Process window. The Histogram Scale
command changes the brightness and haze settings of the image to enhance the image
appearance. The setting boxes for Brightness and Haze change to display the new
settings.

When you choose the Histogram Scale command, ImageView removes the 5% of pixels
with the highest component intensities and the 5% of pixels with the lowest component
intensities. The component intensities of the remaining pixels are then linearly scaled to
cover the full range of component intensities.

Converting an Image to Its Photographic Negative

To change an image into its photographic negative, choose Negate from the Operator
menu of the Process window. The Negate command inverts the component values for
each pixel of the image.

You can toggle the Negate option on and off by dragging the cursor to the option name
and releasing, or clicking on the option name. A checkmark indicates that the option has
been turned on.

Manipulating Geometric Aspects of an Image

These sections describe how to change the appearance of an image by manipulating
geometric aspects of the image:

• “General Instructions for Manipulating Geometric Aspects of an Image”

• “Rotating the Image”

• “Reflecting the Image”

• “Increasing or Decreasing Magnification”
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General Instructions for Manipulating Geometric Aspects of an
Image

To manipulate geometric aspects of an image, first select the image and choose the
Process command from the Options menu. The Process window appears, with three
tabbed subpanels: Enhance, Geom, and Options. To access each subpanel, click on the
displayed tab name or choose the subpanel name from the Edit menu of the Process
window.

You use primarily the Geom subpanel and secondarily the Options subpanel to change
geometric aspects of the image.

Undo and Redo Commands

Choose Undo from the Edit menu of the Process window to undo the last change made
in any subpanel of the Process window. Choose Redo from the Edit menu to reverse the
last undo.

To return all the settings in all three subpanels to their original positions, choose Reset
All from the Edit menu of the Process window.

Choosing the Method for Changing Geometric Aspects of an Image

Using the Options subpanel of the Process window, you can select the resampling
method, determining the procedure used by ImageView to alter the geometric aspects of
an image. Click one of the four resampling methods offered:

• Nearest, standing for Nearest Neighbor, works quickly but produces lower-quality
results.

• Bilinear uses more complex, time-consuming methods than Nearest Neighbor, but
produces higher-quality results.

• Bicubic is more time-consuming than either Nearest Neighbor or Bilinear, but
produces the best results.

If you choose the Bicubic resampling method, you can also choose the specific
Bicubic Family, each of which produces a somewhat different effect: B-Spline, which
is the default option, produces smoother images. Catmul produces more
sharpening. Mitchell results in an effect between that of the other two.

• The Minify method produces the best results if you are reducing the magnification
of an image. Again, however, it is a more time-consuming process.
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Rotating the Image

Use the Geom subpanel of the Process window to rotate the image. You can adjust the
degree of rotation by clicking at any position on the pictured circle. You can also adjust
the rotation by clicking the up and down arrows pictured, or by typing an angle degree
into the setting box and pressing the Enter key. Return the setting to its original position
(no rotation) by clicking the small box above the circle.

Reflecting the Image

Use the Geom subpanel of the Process window to flip the image horizontally, vertically,
or both. Click the Flip Horizontal or Flip Vertical box to toggle the desired option on and
off. A checkmark indicates that the option is turned on.

Increasing or Decreasing Magnification

You can increase or decrease the magnification of the image, using the Zoom section of
the Geom subpanel.

• Adjust the magnification settings by placing the cursor on the pictured dial, then
dragging to “move” the dial higher or lower. You can also click the up and down
arrows pictured, or type a specific amount into the setting boxes and then press the
Enter key. To return to the original setting, click the small box to the right of each
dial.

The Width and Height boxes indicate the size of the image, in pixels. The size of the
image, of course, increases and decreases along with the magnification level. You
can change the size of the image directly by entering specific amounts into the
width and length setting boxes.

• The Independent box allows you to adjust the amount of vertical or horizontal
magnification independently of the other. Click the box to toggle this option on and
off. A checkmark indicates that the option is turned on.
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Selecting a Component, Sub-Image, or Frame

In addition to selecting an image in the ImageView window, you can also select a specific
Frame Number, Component, or Sub-Image of the image. To do so, select the image and
choose the Select Frame command from the Options menu. The Frame window opens,
with pictured controls to select the component, sub-image, and frame number. Which of
these aspects are relevant to the selected image depends on the file format of the image.

These sections describe how to select components, sub-images, or frames of an image:

• “Selecting a Component”

• “Selecting a Sub-Image”

• “Selecting a Frame Number”

Selecting a Component

Use the Component control of the Frame window to select a specific component of the
image. The components of an image are determined by the color model associated with
that image. Generally, although not always, the components of a model are colors.

In order to use the Component control, the Single box that is pictured under the control
must be turned on. This option allows you to select a single component rather than
working with all the components together. Click to toggle it on and off. A checkmark
indicates that it is on.

The settings appearing on the Component control vary depending on the color model of
the selected image. For example, if the image you selected uses the RGB color model, you
can move the control to 0 (red), 1 (green), or 2 (blue).

Selecting a Sub-Image

With some file formats, such as TIFF, JFIF/JPEG, PhotoCD, and GIF, an image file can
contain multiple sub-images. Use the Sub-Image control of the Frame window to select
a specific sub-image.

Use the ImageInfo tool to get a list of the sub-images in an image file. See “Getting
Information About an Image” and the imginfo(1) reference page for more information on
that tool.
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For information on choosing a specific sub-image when you first open or import an
image file, see “Opening Images” and “Importing Additional Images into a Window.”

Selecting a Frame Number

Some file formats include a third or “z” dimension, such as volume or time. With image
files in these formats, you can use the Frame Number control of the Frame window to
select a specific frame number of the image.

Cycling Automatically Along the “Z” Dimension

If the Auto box in the Frame Number area is turned on, ImageView will automatically
cycle along the “z” dimension of the image, starting each cycle at the beginning of the
axis. If both the Auto and the Reverse boxes are turned on, ImageView again will
automatically cycle along the “z” dimension of the image, but will do so by moving
forward and backward along the axis. Click on each box to toggle it on and off. A
checkmark indicates that the option is turned on.

You can use the pictured control below the Auto and Reverse boxes to change the rate of
cycling along the “z” dimension. Drag the control slider to the desired position between
“slow” and “fast.”

Data on the Distribution of Component Values

To see a histogram depicting the distribution of component values in an image, for a
given component, select the image and choose the Histogram command from the
Options menu. The Histogram window opens. The horizontal axis of the histogram
represents component intensities or values, and the vertical axis represents pixel counts.

These sections describe the histogram function:

• “Summary of the Histogram Meaning”

• “Working With the Histogram”
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Summary of the Histogram Meaning

The specific components of an image are determined by the color model associated with
that image. In many models, the components are colors. For example, the components of
the RGB color model are red, green, and blue; an image using the RGB color model is
composed of those three colors. You might think of an image as being made up of many
individual dots, called “pixels,” each of which “consists” of the components. In each
pixel, each component has a certain value or intensity; the combined values of the
components in the pixel determine the appearance of the pixel.

In this Histogram window, you choose which component of the image you want
analyzed. ImageView then counts, for each possible value of that component, how many
pixels in the image have that component value. The horizontal axis of the histogram
represents all the different intensities or values of the component. Along the vertical axis
are pixel counts. Each bar (vertical line) in the histogram indicates the number of pixels
in which the selected component has a certain value. The histogram, then, shows the
distribution of component values in the image.

Working With the Histogram

Using the Component Control

Use the pictured Component control in the Histogram window to choose the component
for which you want a histogram displayed. The settings of the Component control vary
depending on the color model of the selected image. For example, if the image you
selected uses the RGB color model, you can move the control to 0 (red), 1 (green), or 2
(blue).

Obtaining Numerical Data

Click on any bar (vertical line) in the histogram to select it. It turns red, and its
coordinates appear under the horizontal axis of the histogram. The component value
associated with the bar is displayed in front of the colon, and the pixel count is displayed
following the colon. Next to these coordinates, in parentheses, is the percentage of pixels
with this value, out of the total number of pixels in the image.

Click the small box showing a triangular peak to select the highest bar in the histogram.
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Adjusting the Vertical Scaling of the Histogram

Drag the pictured dial up or down to control the vertical scaling of the histogram. Click
the small box immediately above the dial to return the vertical scaling to its original
position, in which the highest peak of the histogram just fits within the window.
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3. ImageCopy, ImageInfo, and ImageFormats

ImageCopy, ImageInfo, and ImageFormats are command-line tools available to you:

• ImageCopy lets you copy and change the format of an image file.

• ImageInfo lets you obtain information about an image.

• ImageFormats displays a list of the file formats that are currently supported by the
ImageVision tools.

Copying an Image

ImageCopy allows you to copy image files and to convert image files into different
formats.

Note that that similar procedures are also available in ImageView. See “Saving an Image,
View, or Window Under a New Name or Format.”

Using the ImageCopy Icon

The imgcopy icon is on the MediaTools page of the Icon Catalog. To open the MediaTools
page, choose Media Tools from the Find menu of the desktop toolchest . To copy an
image file and change the file format, drag and drop the image file icon onto the imgcopy
icon. A dialog box appears from which you can choose one of three formats:

• SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

• TIFF format is the most common and useful file format.

• FIT format is not a standard, but is supported by the ImageVision Library (IL).

When you select a format, ImageCopy copies the image file into a second file, which has
the selected format. The name of this second file is a combination of the original filename
and a new extension, reflecting the new format type.
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If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages for additional information on the various file formats. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html

Using the ImageCopy Command

To copy an image file and change the file format using the ImageCopy command, at the
shell prompt enter

imgcopy <infile> <outfile.format>

where infile is the name of the file to be copied and outfile.format is the name you want
the new file to be given. The outfile name should include an extension that indicates the
desired new format. For example, the name of an outfile that you wish to have in FIT
format might be tree.fit.

A number of file formats are available to you using this command, including FIT, SGI,
JFIF/JPEG, TIFF, PNG, PPM, GIF, and any additional file formats that are available on
your system.

• SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

• TIFF format is the most common and useful file format.

• FIT format is not a standard, but is supported by the ImageVision Library (IL).

• GIF, JFIF/JPEG, and PNG formats are useful for World Wide Web documents. GIF
does not have the color capability necessary for publishing or technical uses.
JFIF/JPEG format uses very little disk space at the expense of some picture detail.

If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages for additional information on the various file formats. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html

You can use the ImageCopy shell command for a number of additional procedures. See
the imgcopy(1) reference page for a list of the ImageCopy command-line options.



Getting Information About an Image

31

Getting Information About an Image

ImageInfo displays information about a file. The imginfo icon is located on the
MediaTools page of the Icon Catalog.

To obtain information on an image file:

3. Choose Media Tools from the Find menu of the desktop toolchest.

The MediaTools page of the Icon Catalog opens.

4. Drag and drop the image file icon onto the imginfo icon.

A dialog box appears.

5. Enter the pathname of the image about which you want information and press OK.

Another window appears describing the image properties.

To instead use the shell to access ImageInfo, at the shell window prompt enter imginfo

<imgfile> .

ImageInfo displays the following information about a file: file format, image size in
pixels, page size, data type, dimension order, color model, minimum and maximum
pixel values, data compression, and image description.

• Information on data compression is only displayed if the file is compressed.

• For those files that contain sub-images, the image description includes a list of the
sub-images in the file.

See the imginfo(1) reference page for a list of the ImageInfo command-line options.

Obtaining a List of Available File Formats

ImageFormats displays a list of the file formats that are currently supported by the
ImageVision tools. More specifically, the list that ImageFormats displays represents all
the formats currently supported by the Image Format Library (IFL) and the tools that use
that library.

To access ImageFormats, at the shell prompt type imgformats and press Enter. A list of
supported formats will be displayed. See imgformats(1) for a list of the ImageFormats
command-line options.
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4. Image Works

This chapter contains these sections:

• “About Image Works”

• “Opening Images in Image Works”

• “Saving an Image in Image Works”

• “Setting Preferences in Image Works”

• “Editing Images in Image Works”

To open Image Works, choose Media Tools from the Find menu of the desktop toolchest.
The MediaTools page of the Icon Catalog opens. Double-click the imgworks icon.

About Image Works

Image Works lets you manipulate images—blur, sharpen, stretch, scale, and flip
images—and save them to a file. Image Works also lets you convert color images to black
and white or make photographic negatives.

Many of the procedures available in Image Works are also available in ImageView, as
described in Chapter 2, “ImageView.”

The Image Works window appears in Figure 4-1.

Figure 4-1 The Image Works Window
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The Image Works window contains six main menus and a help menu:

File Lets you open, save, and print images. You can also set sampling
preferences using the Set Preference menu.

Edit Contains the undo and redo commands, and allows you to copy and
paste.

View Contains commands that let you increase and decrease the size of the
image. Also allows you to see component distribution data displayed in
a histogram.

Transform Contains commands that crop, scale, stretch, flip, or rotate an image.

Enhance Contains commands that let you use effects such as blur and sharpen,
change the contrast and brightness, and change the color balance.

Effects Allows you to turn an image into black and white, apply special effects
like posterize and edges, and turn an image into a photographic
negative.

The balance of the Image Works window is the image area. When you open an image,
this is where it appears.

Opening Images in Image Works

You can open image files of various format types in Image Works. These include SGI,
TIFF, FIT, GIF, JFIF (JPEG compressed images), and PhotoCD.

To open an image in Image Works:

1. Choose Open from the File menu.

2. Click the name of the file you want to open.

3. If you’re opening a PhotoCD file, choose an image size by clicking one of the sizes in
the “Open PhotoCD As” list.

4. Click the Accept button.

The image appears in the Image Works window.
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Opening a Specific Sub-Image

With some file formats, such as PhotoCD, a single file can contain multiple sub-images.
You can open a specific sub-image by typing the filename followed by a colon and the
number of the sub-image (for example, Sunrise:3 ), in the File Name field of the Open
Image dialog box. Use the ImageInfo tool to get a list of sub-images in the image file. See
“Getting Information About an Image” and the imginfo(1) reference page for more
information on using ImageInfo.

Saving an Image in Image Works

Use the Save command in the File menu to save your current work as is.

Use the Save As command in the File menu to save your work under a different filename.
You can also use the Save As command to save your work in a format different from that
of the original image file. When you choose the Save As command under the File menu,
a dialog box opens. Use the File Format field of the dialog box to select the format.
Available file formats are SGI, TIFF, FIT, GIF, and JFIF/JPEG.

• SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

• TIFF format is the most common and useful file format. The FIT format is not a
standard, but is supported by the ImageVision Library (IL).

• JFIF (JPEG compressed) format uses very little disk space at the expense of some
picture detail.

• GIF format is useful for online graphics presentation, such as World Wide Web
documents and multimedia authoring. It does not have the color capability
necessary for publishing or technical uses.

See the IFL manual pages on each of these file formats for additional information.
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TIFF, GIF, and JFIF formats have additional options you can set using the Save As dialog
box. To activate the relevant fields of the Save As dialog box for each file format, you
must first select the format in the File Format field. For information on the options
available, see:

• “Saving an Image in TIFF Format”

• “Saving an Image in GIF Format”

• “Saving an Image in JFIF Format”

Saving an Image in TIFF Format

If you are saving an image in TIFF format, you can turn compression on or off by clicking
the Use Compression button in the Save As dialog box.

Turning compression on significantly reduces the amount of disk space needed to store
the image without reducing the quality of the image. However, if you plan to use these
images in PC or Macintosh® files, you will encounter fewer compatibility problems if
you turn compression off.

Saving an Image in GIF Format

When saving an image in GIF format, the Set GIF Options button in the Save As dialog
box is activated. Click this button to open the GIF Options dialog box. You can also open
the GIF Options dialog box by choosing the Set GIF Options command from the File
menu. The GIF Options dialog box lets you choose certain options before saving the
image in GIF format.

Selecting the Number of Colors to Save

You can increase or decrease the number of colors saved in the image file by using the
Number of Colors to Save field of the GIF Options dialog box. You can choose 16, 64, 128,
or 256 in the Number of Colors field. By default, Image Works uses a maximum of 64
colors when saving a file in GIF format.
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• More colors give you a better quality image.

You may want to choose a high number in the Number of Colors field to accurately
represent photographs or other highly realistic images. However, files containing a
large number of colors take up more disk space.

• Fewer colors help save disk space and network transmission time.

You may want to choose a smaller number of colors for diagrams, line drawings, or
other simple graphics.

If you are creating images for the World Wide Web, remember that your content is
viewable by a worldwide audience. Internet users view images using a wide range of
computer systems and software, with varying color graphics capabilities. To place fewer
demands on the viewer’s Web browsing hardware and software, choose the fewest
colors that will provide acceptable quality for your images. If you place several images
on one page, use fewer colors in each image to help Web browsers faithfully show all the
images.

Turning Dithering On or Off

Click the Use Dithering button of the GIF Options dialog box to turn this option on and
off. A checkmark indicates that the option is turned on.

Dithering changes the pixels in an image to simulate “lost” colors. When using fewer
colors in an image, dithering may help improve the appearance of an image. If you are
saving a simple image, like a line drawing or diagram that uses fewer colors, you may
have better results if you turn dithering off.

By default, Image Works uses dithering when saving to GIF format.

Turning Interlacing On or Off

Click the Use Interlacing button of the GIF Options dialog box to turn this option on and
off. A checkmark indicates that the option is turned on.

An interlaced image displays gradually. It starts out very rough, then progresses and
adds detail as it displays. If an image isn’t interlaced, the image doesn’t appear until the
complete image is ready to display. Both processes take the same amount of time.
Authors of World Wide Web pages use interlaced images to give you visual feedback
instead of a blank screen while you wait for an image to display.
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By default, interlacing is turned on when saving to GIF format.

Choosing a Transparency Color

When saving images to GIF format, you can select a solid color in the image and make it
transparent. This is useful when you want to eliminate the rectangular background of an
image and give the impression that the image is floating on the page.

To choose a transparency color when saving images in GIF format:

1. Click the Choose Transparency Color button in the GIF Options dialog box. The GIF
Transparency window appears.

2. Move your cursor across the image. The image appears magnified in the Pixel View
in the GIF Transparency window. Click when the color you wish to make
transparent appears within the small square in the center of the Pixel View.

The color disappears from the image.

Saving an Image in JFIF Format

When saving images in JFIF format, you can adjust the compression quality of the image
using the JFIF Options control pictured in the Save As dialog box. Drag the slider to the
left or the right to lower or raise the quality setting. By default, the compression is set to
high (100). At this quality setting, all detail is saved. Lowering the quality decreases the
amount of detail and decreases the size of the file.
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Setting Preferences in Image Works

Choose Set Preferences from the File menu to select the resampling method for your
images.

The resampling method determines the procedure Images Works uses when you
manipulate the image in certain ways, such as resizing, stretching, and rotating the
image (see “Editing Images in Image Works”). Nearest Neighbor works quickly, but
produces lower-quality results. Bilinear and Bicubic use more complex, time-consuming
methods, but produce higher-quality results. Bicubic is the most time-consuming of
these methods and produces the highest-quality results.

Editing Images in Image Works

These sections tell you how to use Image Works to do many different things:

• “Blurring an Image”

• “Sharpening an Image”

• “Converting an Image to Black and White”

• “Converting an Image to a Photographic Negative”

• “Cropping an Image”

• “Resizing an Image”

• “Stretching an Image”

• “Flipping an Image”

• “Rotating an Image”

• “Lightening and Darkening Pixels in an Image”

• “Brightening or Darkening an Image”

• “Adjusting the Amount of Contrast in an Image”

• “Reducing the Number of Colors in an Image”

• “Balancing the Color in an Image”

• “Checking Color Distribution”

• “Making Colors More Vivid”



40

Chapter 4: Image Works

• “Highlighting Edges In an Image”

• “Setting Preferences in Image Works”

Many of the procedures described in these sections are also available in ImageView, as
described in Chapter 2, “ImageView.”

Blurring an Image

To blur an image:

1. Choose Blur from the Enhance menu.

2. Drag the slider to change the degree of blur, or type a percentage in the field.

3. Change the kernel size, if you wish to do so.

Generally, a high blur factor and large kernel size produce a very blurred image.

4. Click the Apply button to make your changes take effect. To return to the original
image, choose Undo from the Edit menu.

5. Click Reset to reset the blur scale.

Click Close to close the blur window.

Sharpening an Image

Sharpening an image makes the colors more crisp. To sharpen an image:

1. Choose Sharpen from the Enhance menu.

2. Drag the slider to the right to sharpen the colors in the image, or type a percentage
in the field.

3. Change the kernel size, if you wish to do so.

Generally, a high sharpen factor and large kernel size produce a very sharp image.

4. Click Apply to make your changes take effect. To return to the original image, choose
Undo from the Edit menu.

5. Click Reset to reset the sharpen scale.

Click Close to close the Sharpen window.
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Converting an Image to Black and White

To change a color image to black and white, choose the “Color to Grayscale” command
from the Effects menu. To return to the original image, choose Undo from the Edit menu.

Converting an Image to a Photographic Negative

To turn an image into a photographic negative, choose Negate from the Effects menu. To
return to the original image, choose Undo from the Edit menu.

Cropping an Image

The Crop command lets you cut an image, just as you would cut a picture using scissors.
To crop an image:

1. Choose Crop/Add Margin from the Transform menu.

2. Pull down Add from the Crop button to add a margin to your image.

A selection rectangle appears in the image. Size the image using the rectangle. You
can also fill in the fields with the amount you would like to crop the image, in
pixels.

For example, if you enter 15  in the “pixels left” field, you snip 15 pixels off the left
side of the image.

3. Click the Choose Color button to change the color of the crop area or margin.

4. Click Apply to initiate the changes. Choose Undo from the Edit menu to return to the
original image.

Click Close to close the window.
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Resizing an Image

The Scale command lets you resize an image and maintain the correct proportions
(aspect ratio). To scale an image:

1. Choose Scale from the Transform menu.

2. Type the percentage by which you want to scale the image in the Scale Factor field,
or type the desired size (in pixels).

The program figures out the percentage for you.

You can also resize by moving the handles on the corners of the image.

3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.

4. Click Reset to reset the scale.

Click Close to close the window.

See also “Setting Preferences in Image Works” for information on choosing the procedure
by which Image Works resizes an image.

Stretching an Image

The Stretch command lets you resize an image without maintaining the aspect ratio. To
stretch an image:

1. Choose Stretch from the Transform menu.

2. Type the percentage by which you want to stretch the image horizontally and
vertically in the appropriate fields, or type the desired size (in pixels).

The program figures out the percentage for you.

You can also stretch the handles on the corners of the image.

3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.

4. Click Reset to reset the scale.

Click Close to close the window.
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See also “Setting Preferences in Image Works” for information on choosing the procedure
by which Image Works stretches an image.

Flipping an Image

You can flip an image upside down or sideways using the Flop Horizontal and Flip
Vertical commands in the Transform menu.

Rotating an Image

The Rotate command lets you rotate an image counter-clockwise at any angle. To rotate
an image:

1. Choose Rotate from the Transform menu.

2. In the Rotate Image field, type the degree by which you want to rotate the image.

3. Click the Choose Color button to change the color of the crop area or margin.

4. Click Apply to initiate the changes.

Choose Undo from the Edit menu to return to the original image and remove any
new color.

Click Close to close the window.

Lightening and Darkening Pixels in an Image

The Threshold feature allows you to selectively lighten and darken pixels in your image.
For grayscale images, it forces all of the pixels to be either white or black. For color
images, it forces all of the pixels into primary colors (black, white, red, green, blue,
yellow, cyan, and magenta).

For example, in a black and white image, this means that you pick a gray level as a
threshold. Everything lighter than the threshold gray becomes white. Everything darker
than the threshold gray becomes black. Color images are handled just like black and
white. The difference is that the threshold operation is done three times, once each for
red, green, and blue.
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Use Threshold on scanned line art to make edges crisper and remove background noise,
or on color images for special effects.

To “threshold” an image, follow these steps:

1. Choose Threshold from the Effects menu. A dialog box appears.

2. To change the threshold level, drag the Threshold Level slider.

The threshold level determines how pixels are darkened and lightened in the image.
Generally, pixels darker than the threshold level become black. Pixels lighter than
the threshold level become white.

3. Click Apply to implement the changes.

Choose Undo from the Edit menu to return to the original image.

4. Click Reset to reset the scale.

Click Close to close the window.

Brightening or Darkening an Image

To brighten or darken an image, follow these steps:

1. Choose Brightness from the Enhance menu. A dialog box appears.

2. Drag the slider bar to the left to darken the image and to the right to lighten the
image.

3. Click Apply to implement the changes.

Choose Undo from the Edit menu to return to the original image.

4. Click Reset to reset the scale.

Click Close to close the window.
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Adjusting the Amount of Contrast in an Image

To adjust the amount of contrast in an image:

1. Choose Contrast from the Enhance menu. A dialog box appears.

2. Change the contrast of the dark areas by dragging the Shadows slider to the left,
towards “flatter,” to decrease the contrast, or to the right to darken the contrast.

3. Change the contrast of the light areas by dragging the Highlights slider to the left,
towards “flatter,” to decrease the contrast, or to the right to increase the contrast.

4. Click Apply to implement the changes.

Choose Undo from the Edit menu to return to the original image.

5. Click Reset to reset the scale.

Click Close to close the window.

Reducing the Number of Colors in an Image

The Posterize feature reduces the number of colors in an image. Use this feature to create
special effects. To posterize an image:

1. Choose Posterize from the effects menu. A dialog box appears.

To choose the number of color levels, enter a number between 2 and 256 in the
Posterize Level field. A smaller number produces an image with fewer colors.

2. Click Apply to implement the changes.

Choose Undo from the Edit menu to return to the original image.

3. Click Reset to reset the scale.

Click Close to close the window.
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Balancing the Color in an Image

To adjust the balance of color in an image, follow these steps:

1. Choose Color Balance from the Enhance menu. A dialog box appears.

2. Balance the color.

■ To raise and lower the red, green, and blue colors, drag the appropriate sliders.

■ To decrease the amount of color, drag towards “less.”

■ To increase the amount of color, drag towards “more.”

3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.

4. Click Reset to reset the scale.

Click Close to close the window.

Checking Color Distribution

A histogram graphically depicts the distribution of color in an image. Choose Show
Histogram from the View menu. For a color image, three graphs are displayed,
illustrating the red, green, and blue components of the image. For a grayscale image, one
graph is displayed, illustrating the gray levels of the image.

Very dark images have higher peaks towards the left of the histogram graph. Very light
images have higher peaks towards the right of the histogram graph.

To understand the relationship between an image and its histogram, leave it open while
using the Negate, Color To Grayscale, Brightness, Contrast, Threshold, Posterize,
Equalize, Color Saturation, Find Edges, and Color Balance features. Each time you
change the image, the histogram automatically updates.

When you finish viewing the histogram, click the Close button to close the histogram
view.
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Making Colors More Vivid

Choose Color Saturation from the Enhance menu. Adjust the levels in the dialog box to
make the colors more or less vivid.

Highlighting Edges In an Image

Choose Find Edges from the Effects menu. There are four methods that can be used to
find and enhance edges: Roberts, Sobel, Laplace1, and Laplace2.

These choices perform 2D orthogonal convolutions on the edges of an image to change
the edge effects.
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5. ImageTcl

ImageTcl is a powerful tool that allows you to do the following:

• Write your own scripts or application programs

For example, you may regularly need to convert image files to a particular size.
Using ImageTcl, you can write your own script or program to perform this
conversion.

• Make use of image-processing operations not available to you through the other
ImageVision application tools, such as ImageView

ImageTcl allows you to make use of any of the numerous image-processing
operations available in the ImageVision Library (IL) package. Opening an image,
rotating an image, and changing the color model of an image might all be
considered examples of basic operations on the image.

An application tool such as ImageView makes many of these operations easily
accessible (see Chapter 2, “ImageView”). However, you can use ImageTcl to access
operations that are in the ImageVision package but are not available to you through
application tools such as ImageView.

Using ImageTcl

ImageTcl may be particularly helpful for users who have some programming
background. You can use ImageTcl in two ways:

• You can work interactively in the shell window by invoking ImageTcl and entering
commands (see “Examples of Using ImageTcl Interactively”).

• You can create files containing scripts or programs that are executed using ImageTcl
(see “Examples of ImageTcl Scripts or Programs”).
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The ImageTcl tool is built using Tcl, a publicly available scripting language. Whether you
are typing ImageTcl commands interactively or writing programs to be executed by
ImageTcl, you must use the Tcl language. To obtain more information on Tcl, you may
want to refer to the following book: Ousterhout, John K., Tcl and the Tk Toolkit,
Addison-Wesley Publishing Company, 1994.

Obtaining Information and Command Names for Operations

If you have the IRIS Development Option, see the ImageVision Library/Image Format
Library (IL/IFL) manual pages for information on each of the operations available in the
ImageVision Library package. You can also view these manual pages if you have access
to the World Wide Web, by visiting the following site:

http://www.sgi.com/Technology/ImageVision/man/ILman.html

Each of these manual pages describes an operation and indicates the operation’s
command name, to use in writing scripts or working interactively. For successful
operation of ImageTcl, either type the command name entirely in lower case or type it
exactly as it is shown in the reference page, noting the case of each letter.

Examples of Using ImageTcl Interactively

For demonstration purposes, this section contains instructions on using ImageTcl to
perform some simple operations. In this series of examples, you are working
interactively in the shell window. (A word of caution: a string of letters used frequently
in these commands—“img”—is easily mistaken to be “ing,” leading to errors.)

1. To invoke ImageTcl, enter imgtcl  at the prompt in the shell window.

The imgtcl prompt appears in the shell window.

2. To select an image file for processing, enter

ilfileimgopen file <filename>

where filename is the name of the file you wish to open. The word “file” displays,
and then the imgtcl prompt appears again.
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3. To display the image, at the prompt enter

file

The ImageTcl Viewer window opens, displaying the image.

The ImageTcl Viewer operates similarly to the ImageView window. For information
that will be useful in understanding the ImageTcl Viewer, refer to Chapter 2,
“ImageView.”

4. Close the window by double-clicking the button located to the left of the window
name, or quit the viewer by choosing Quit from the File menu.

The ImageTcl Viewer window closes, and the ImageTcl prompt appears again in the
shell window.

5. To process the file by applying a compass filter to it, enter

ilcompassimg compass file

The word “compass” displays, and then the ImageTcl prompt appears again.

6. To display the filtered image in the ImageTcl Viewer window, enter

compass

The ImageTcl window opens, displaying the filtered image.

7. Close the window by double-clicking the button located to the left of the window
name, or quit the viewer by choosing Quit from the File menu.

The ImageTcl Viewer window closes, and the ImageTcl prompt appears again.

8. To exit the ImageTcl interpreter and return to your usual shell window prompt,
enter

exit
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Examples of ImageTcl Scripts or Programs

This section contains instructions enabling you to see examples of files containing scripts
or programs—sequences of commands—that can be executed using ImageTcl.

1. At the standard prompt in your shell window, enter

cd /usr/share/src/imgtcl

2. To see the three sample files listed in directory, enter

ls

3. To display the contents of any of these files, enter

more <filename>

where filename is the name of the file you wish displayed.

In order to have access to these script file examples, the imagetools.sw.gifts subsystem
must have been installed on your system. If you used the default installation of
ImageVision Tools, Version 3.1, this subsytem is installed on your system.

For Additional Information

For additional information on ImageTcl, see the imgtcl(1) reference page.


