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Chapter 1

1. Authoring with WebMagic

Overview of WebMagic

You use the WebMagic authoring tool to create HTML documents that can be viewed on
the World Wide Web (the Web) by any HTML browser or HTML player.

WebMagic lets you create documents from scratch or from existing document templates.
It is a point and click text editor that also supports:

• paragraph markup for structuring your document

• character tags for formatting and categorizing text elements

• inclusion of inline images

• inclusion of multi-media files by referring to them via a link

• inclusion of forms so your page becomes interactive

• hyper-links from your document to other documents or files

For task-oriented information on using WebMagic, choose a topic from the WebMagic
Help menu. For context-sensitive information on a particular area or item in the
WebMagic editing window, choose “Click for Help” from the Help menu, then click on
the area or item (see also Chapter 2, “WebMagic Reference”).

Creating a New Document

Each time you create a document using WebMagic, you follow most of these steps:

1. If this is the first HTML document you’ve created with WebMagic, set up your work
area; see “Setting Up a Work Area for Easy Publishing” and “About the Home
Page.”

2. If WebMagic is not already running, start it by double-clicking the WebMagic icon
on the shelf of your project root directory.
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3. If you like, use a template; see “Opening an Existing Document as a Template.”

4. Create content.

5. Give the document a title; see “Specifying a Title.”

6. Save the document; see “Saving Changes.”

7. View the document using Netscape so you can test links and formatting; see
“Viewing and Publishing the Document.”

8. If you like, print the document; see “Printing a Document.”

9. Make the document available on the Web; see “Publishing a Document on the Web.”

Setting Up a Work Area for Easy Publishing

All HTML documents that you can view on the Web reside on specially configured
systems called web servers. When you place an HTML document in a specific location
on the web server, your document becomes available for viewing. Placing your
document on the web server in this way is called publishing a document.

If your system is running the Out Box server, publishing Web documents on your server
is easy. Open your home directory and locate the directory named public_html. This is
referred to as your project root directory; it was automatically created for you. Create your
HTML documents in this directory and they are automatically available for viewing on
the Web. For step-by-step instructions, see “Creating and Publishing Files Using the
public_html Directory.”

If you’re authoring the document on your system but need to copy it to another web
server, publishing is a bit more involved. After creating your document, you need to
copy it to a specified location on the web server. To ensure that all of your links work, you
may need to translate the link pathnames (URLs) first. See “Creating and Publishing
Documents For Use on Another Server.”

Creating and Publishing Files Using the public_html Directory

This section describes how to author and publish files easily. The method described
works only if your system is running the Out Box server.

1. Open your home directory and locate the directory public_html; open this directory.

This is the directory in which you’ll author all your HTML documents.
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2. Add a shelf to the open project root directory window by choosing “Shelf” from the
View window.

3. Place the webmagic icon on the shelf.

■ Choose “Web Tools” from the Find toolchest.

■ Drag the webmagic icon from the Web Tools page of the icon catalog onto the
shelf.

4. If you plan to include images and other types of media in your documents, create
subdirectories for each media type.

For example, you might create one subdirectory called images and another called
movies.

5. For each subdirectory you created, create a shelf as you did in the project root
directory, and drag the appropriate media tools onto the shelf.

Choose “Media Tools” from the Find toolchest to see all the available tools. This
step makes it easy for you to create media files and save them in the proper
subdirectory.

6. Create the files you plan to link to or, if they already exist in another location on
your system, move them or place copies of them in the appropriate subdirectories.

For example, copy several GIF or JPEG files into your images directory.

Note: To save on disk space, rather than copying files into the subdirectories, you
can make linked copies of files using the “Make Linked Copy” choice in the Selected
menu on a directory view window. Then drag the linked copies into the
subdirectories and remove “link_to_” from the file name.

7. Start WebMagic from the shelf, either by double-clicking the WebMagic icon, or by
dragging an HTML document icon from the project root directory onto the
WebMagic icon.

8. Create your HTML document in the public_html directory.

The document is automatically available for viewing. Other users can view the
document by specifying the following URL:
http://<machinename>/~<username>/<filename>.

Note: All files and directories in public_html are available for others to view. As such, you
probably don’t want to place confidential files in this directory.
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Creating and Publishing Documents For Use on Another Server

To make publishing on another server easier, you can create your HTML file in one
directory and place all the files it references in the same directory or one of its
subdirectories.

1. Create a project root directory. This is the directory in which you’ll author your
HTML documents.

• If your system is running the Out Box server, you automatically have a
directory named public_html in your home directory. You can author HTML
documents here, then copy them to the other web server. The Out Box server
makes documents placed here automatically available for viewing. If you don’t
want people to view your file while it’s under construction, create a different
project root directory.

• If your system isn’t running the Out Box server, create a project root directory in
your home directory.

2. Open the project root directory, then add a shelf by choosing “Shelf” from the View
window.

3. Finish setting up your work area by following steps 2 through 7 in “Creating and
Publishing Files Using the public_html Directory.”

Once you’ve set up your work area and created your HTML document, you’re ready to
copy it to the web server. See “Publishing a Document on the Web.”

About the Home Page

Every person or organization may have a home page. It’s the main entrance into
information about an entity. By default, if your system is running the Out Box server, you
have a basic home page. It’s stored in your home directory, in a subdirectory called
public_html. The file is named index.html. You can use WebMagic to customize this page.

You can use your home page to share files with other people. Use the Out Box tool to
specify which file icons you’d like to share; these icons appear in the lower portion of
your home page. To open Out Box, click the words OutBox now.
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Opening and Saving a Document

Choose a topic from the list:

• “Opening a Document”

• “Opening an Existing Document as a Template”

• “Saving Changes”

• “Saving Changes Automatically”

Opening a Document

WebMagic can open any HTML document that you have permission to view, and will let
you edit any HTML document that you have permission to change. For more
information, refer to the Desktop User’s Guide, which is one of the Online Books accessible
through the Help menu of the desktop Toolchest.

To open a HTML document, follow these steps:

1. Choose “Open” from the File menu.

The Open Document window appears. The Files area of this window shows all files
and directories that are contained in the directory whose full pathname is shown in
the Open file field.

2. Locate the file that you want to open.

• If you see the file in the scrolling Files area, go to the next step.

• To look in a subdirectory for the file, double-click the directory name (directory
names end in /) in the Files area.

• To look in a completely different area of the filesystem, type a different
pathname in the Open file field, then press <Enter>.

• To restrict your view of files in a particular directory, click the Filter button.

In the Filter window that appears, enter a string and wildcard character (for
example, *.html), then click the Apply or OK button. Only those files that fit
your match criteria appear in the Files area.

3. Open the file using one of these methods:

• Double-click its name in the Files list.
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• Click its name in the Files list, then click the OK button.

• Enter its full pathname in the Open file field, then click the OK button.

Once you open a document, WebMagic automatically saves your changes every two
minutes. To change the interval of time between automatic saves or to turn off this
feature, choose “Preferences” from the File menu, and see “Saving Changes
Automatically.”

Saving Changes

WebMagic automatically saves your changes every 2 minutes (see “Saving Changes
Automatically”). To explicitly save changes, follow these steps:

1. Choose “Save” from File menu.

If you have previously saved the file, you are done. If you have never saved this file
before, you see the Save Document window; go on to the next step.

2. Specify a name for the file that ends in .html and contains no spaces or special
characters.

• To save the file in the same directory whose contents are displayed in the
scrolling Files area, delete the name default.html from the Save to file field, and
enter a new name.

• To save the file in a subdirectory, double-click the directory name (directory
names end in /) in the Files area, then enter the file name at the end of the full
pathname displayed in the Save to file field.

• To save the file in a completely different area of the filesystem, type a different
pathname in the Save to file field, then press <Enter>.

• To restrict your view of files in a particular directory, click the Filter button.

In the Filter window that appears, enter a string and wildcard character (for
example, *.html), then click the Apply or OK button. Only those files that fit
your match criteria appear in the Files area.

3. Save the document in the file, or cancel your request.

• Click the OK button to save the document in the file whose name appears in the
Save to file field.

• Click the Cancel button to discard any information you entered in the window
and to leave the document unsaved.
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To save your document under a different name, choose “Save as” from the File menu,
then follow steps 2 and 3 above.

Saving Changes Automatically

By default, WebMagic automatically saves all changes every two minutes in a checkpoint
file and makes a backup copy of the original file when you save your edits.

• The checkpoint (autosave) files are named basefilename-username-uniqueID.filesuffix.
sav. For example, the checkpoint file for joe’s febproj.html file would be named
febproj-joe-443.html.sav

• The backup file is named filename.bak

You can change your preferences so WebMagic does not create autosave or backup files,
or so WebMagic performs autosaves more or less frequently. Choose “Preferences” from
the File menu to change these preferences, then click the Help button in the Preferences
window for more information.

Opening an Existing Document as a Template

WebMagic provides several template documents that you can open, edit, and save as
your own. In this way you can quickly create standard documents such as a home page
(see also “About the Home Page”). These documents are located in the
/usr/share/WebMagic/templates directory.

You can open a template file in the /usr/share/WebMagic/templates directory by following
these steps:

1. Choose “Open Template” from the File menu.

2. In the Open Template File window, open a file using either of these methods:

• Double-click the file.

• Click the file to select it, then click the OK button.

You can open any HTML file as a template. To do so, enter the pathname of the directory
that contains the file in the Open template field, press <Enter> to see all the files that the
directory contains, then double-click the file. To see the contents of the default template
directory again, click the Default Template Directory button.
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Importing Text, HTML, RTF, and Image Files

WebMagic lets you insert the following types of files:

• other HTML files

• ASCII text files

• Rich Text Format (RTF) files. Many word processing applications let you save the
document in this format.

• image files

When you insert a text or HTML file, you copy the entire contents of the file into your
open WebMagic document. When you insert an image file, you do not copy the image
file into the document; you create an inline image link to the file.

To insert a text, HTML, RTF, or image file, follow these steps:

1. Choose an item from the “Insert” rollover in the File menu.

The Insert window appears. The Files area of this window shows all files and
directories that are contained in the directory whose full pathname is shown in the
Selection field.

2. Locate the file that you want to open.

• If you see the file in the scrolling Files area, go to the next step.

• To look in a subdirectory for the file, double-click the directory name (directory
names end in /) in the Files area.

• To look in a completely different area of the filesystem, type a different
pathname in the Selection field, then press <Enter>.

• To restrict your view of files in a particular directory, click the Filter button.

In the Filter window that appears, enter a string and wildcard character (for
example, *.html), then click the Apply or OK button. Only those files that fit
your match criteria appear in the Files area.

3. Insert the file using one of these methods:

• Double-click its name in the Files list.

• Click its name in the Files list, then click the OK button.

• Enter its full pathname in the Selection field, then click the OK button.
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If you are inserting a text or HTML file, the contents of the file are copied into your
open document and the insertion is complete.

If you are inserting an image file, the Create Link window appears; click the Apply
button in this window to complete the insertion (to create an inline image link). For
more information, see “Inserting Images.”

Entering and Editing Text

This section explains how to place text on the page, copy and paste text, and change its
color.

• “Typing Text”

• “Inserting Text Files”

• “Selecting Text”

• “Inserting Line Breaks”

• “Entering Special (ISO Latin 1) Characters”

• “Cutting Text”

• “Copying Text”

• “Pasting Text”

• “Finding and Changing Text”

• “Converting Text Files into Tables”

Typing Text

To position the insertion cursor:

• move the mouse so its cursor is positioned where you want to enter text or an
image, then click the left mouse button; or

• use the up, down, left, and right arrow keys on the keyboard to move the cursor.
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Once the insertion cursor is positioned, you can enter text in these ways:

• Type on the keyboard to enter text.

• Use the “Insert” choice on the File menu to add an entire text file. See also “Inserting
Text Files.”

Use the <Enter> key to erase characters that appear behind the insertion cursor, and use
<Enter> key to start a new paragraph.

Inserting Text Files

To insert text files, open the File menu, then choose “Text File...” from the Insert rollover
menu. Step-by-step instructions follow.

1. Choose “Text File...” from the “Insert” rollover in the File menu.

The Insert window appears. The Files area of this window shows all files and
directories that are contained in the directory whose full pathname is shown in the
Selection field.

2. Locate the file that you want to open.

• If you see the file in the scrolling Files area, go to the next step.

• To look in a subdirectory for the file, double-click the directory name (directory
names end in /) in the Files area.

• To look in a completely different area of the filesystem, type a different
pathname in the Selection field, then press <Enter>.

• To restrict your view of files in a particular directory, click the Filter button.

In the Filter window that appears, enter a string and wildcard character (for
example, *.html), then click the Apply or OK button. Only those files that fit
your match criteria appear in the Files area.

3. Insert the file using one of these methods:

• Double-click its name in the Files list.

• Click its name in the Files list, then click the OK button.

• Enter its full pathname in the Selection field, then click the OK button.

A dialog box appears.
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4. Use the dialog box that appears to specify how you want to treat line breaks in the
text file.

You can preserve the line breaks, in which case each line will appear as a separate
paragraph, or you can merge the lines and form paragraphs. You can also choose to
convert the text file into a table. See “Converting Text Files into Tables.”

5. Click the Insert button and the text appears in your document.

Selecting Text

You can select text in these ways:

• Position the mouse cursor at one end of the text, press and hold the left mouse
button, and drag the mouse to highlight the string of text.

• Position the insertion cursor at one end of the text using the arrow keys, then press
and hold down the <Shift> key and create the selection range using the arrow
keys.

• Position the cursor over a word, then double click to select the word. Keep pressing
the left mouse button and drag the mouse to select additional words.

• Position the cursor in a line of text, then click the mouse button three times to select
the entire line. Keep pressing the mouse button and drag the cursor to select
additional lines.

• Position the cursor in a paragraph, then click four times to select the entire
paragraph.

Inserting Line Breaks

When text reaches the right edge of the page, it automatically breaks and continues on a
new line. To break the line of text before it reaches the edge, chose “Line Break” from the
Element menu.

If you inserted an image so that text flows on the left or right side of the image, and you
insert a line break, you might also want to use the “Break Clear” command. By default,
if you insert a line break, the new line of text appears directly below the original line.
“Break Clear” lets you start the next line when the specified margin is clear.
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Entering Special (ISO Latin 1) Characters

WebMagic supports all special characters in the ISO Latin 1 character set. This includes
characters such as the copyright and registered trademark symbols.

For a full list of supported characters, see the composetable(5) man page. Some
commonly-used special characters include:

Character: Two-character keyboard combination:

Copyright <c> <o>

Registered Trademark
<R> <O>

Pound <L> <->

Yen <y> <=>

One-half <1> <2>

To enter special characters, follow these steps:

1. Use the Language Controls window to change your keyboard style from US to
en_US.

■ Choose “Language” from the Customize rollover menu in the Desktop
toolchest.

■ In the Language Controls window, click to select en_US in the Keyboards list.

■ Click the Apply button to switch to the new keyboard, then click the Close
button to close the window.

2. Position your cursor in the WebMagic window where you want to insert the special
character.

3. Press and hold down the <Shift> key, press and hold down the right-hand <Alt>

key, then release both keys. This places WebMagic in a special character entry mode.

4. Type the two-letter combination for your special character. After you type the
two-letter combination, WebMagic automatically returns to its regular entry mode.
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Cutting Text

When you cut a section of text, WebMagic removes the text from your document and
saves it in memory until you cut or copy another item. Immediately after you cut the
item, you can paste it into another location of your document (see “Pasting Text”).

To cut text:

1. Select the text (see “Selecting Text”).

You can select a single character or several paragraphs.

2. Choose “Cut” from the Edit menu.

The text disappears from the screen, but is saved by WebMagic until the next time
you cut or copy an item.

3. To place the cut item somewhere else in your document, move the insertion cursor
to the new location, then choose “Paste” from the Edit menu.

Copying Text

When you copy a section of text, WebMagic places a copy of it in memory until you cut
or copy another item. Immediately after you copy the item, you can paste it elsewhere in
the document or paste it in another open document

To copy text:

1. Select the text (see “Selecting Text”).

You can select a single character or several paragraphs of text.

2. Choose “Copy” from the Edit menu.

The text is saved by WebMagic until the next time you cut or copy an item.

3. To place the copied text somewhere else in your document, move the insertion
cursor to the new location, then choose “Paste” from the Edit menu.

Pasting Text

After you cut or copy a section of text, you can place the item in a new location in the
same document or in another HTML document.
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To paste text into the same document from which you cut or copied it, follow these steps:

1. Move the insertion cursor to the new location.

2. Choose “Paste” from the Edit menu.

To paste text into a different document, follow these steps:

1. Open the document into which you want to paste the item using either of these
methods:

2. Move the insertion cursor to the new location (see “Entering and Editing Text”).

3. Choose “Paste” from the Edit menu.

Converting Text Files into Tables

If you’ve created a table in a text file, you can preserve the format when you insert the
text file into WebMagic. For instance, many spreadsheet applications let you save a
spreadsheet as a text file. You can insert this into WebMagic and preserve the formatting.

1. Choose “Text File...” from the “Insert” rollover in the File menu.

The Insert window appears. The Files area of this window shows all files and
directories that are contained in the directory whose full pathname is shown in the
Selection field.

2. Locate the file that you want to open, then insert it by double-clicking its name.

A dialog box appears.

3. Click Convert to Table..., then click the Insert button.

The Insert Table dialog box appears.

4. Choose how you want to format the table.

• In your text file, if you used tabs, spaces, or a particular key to separate table
cells, you want to treat each line as a row. Choose one of the three options. 1)
Click Tabs. 2) Click Spaces, then enter the number of spaces you used to separate
the rows. 3) Or click Other, then enter a key. For instance, you might have used a
comma or colon to separate the rows.

• If each line contains one item, you should treat each item as a cell. Enter the
number of columns you want to use in your table.
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5. Provide additional formatting by completing the Table Attributes settings.

• To place a border around the table and each of its cells, type a number in the
Border Size field. The border size is measured in pixels.

• Type a number in the Cell Padding field to specify how much space appears
between the text and the edge of a cell. By default, WebMagic uses a cell
padding of 2 pixels.

• Type a number in the Cell Spacing field to determine how much blank space
surrounds each cell. By default, WebMagic uses a spacing of 2 pixels.

6. Click the Insert button.

The text appears in your document. You see icons interspersed in the text; these
represent the HTML table tags.

7. To view the table, choose “Preview” from the File menu.

Finding and Changing Text

You can search for words or phrases and replace them. To do so, choose
“Find/Change...” from the Edit menu. Step-by-step instructions follow.

1. Choose “Find/Change...” from the Edit menu.

The Find/Change window appears.

2. In the Find field, type the word or phrase you want to find.

3. Select the options you want by clicking Consider Case, Whole Words, and Find
Backward.

• Click Consider Case if you want WebMagic to find the word only if it’s
capitalized exactly as you typed it. By default, WebMagic finds all instances of
the word, no matter how they’re capitalized.

• Click Whole Words if you want WebMagic to find that word alone and not just a
sequence of characters. For instance, suppose you’re searching for “the.” If you
don’t select Whole Words, WebMagic will also find “the” in “there.”

• By default, WebMagic begins searching at the cursor location. When it reaches
the end of the document, it jumps to the top of the document and continues
searching. Click Find Backward if you want WebMagic to start at the cursor
location and search backward.



16

Chapter 1: Authoring with WebMagic

4. Click the Find button.

If the text string appears in the document, the cursor moves to that location and
WebMagic highlights the string.

5. To continue searching, click Find again or press the <Enter> key.

If you want to replace text strings, do the following:

1. Specify what you want to replace the text with. You have two options:

• Type a replacement word in the Change field. Make sure the menu button is
labeled To.

• Find a string of text in the document, then choose “Copy” from the Edit menu.
In the Find/Change window, choose “By Paste” from the menu button next to
Change.

2. Use the buttons along the bottom of the window to find and replace the text. You
have several options:

• Click Find, then click the Change button. This lets you find each occurrence of
the word and decide if you want to replace it.

• Click Find & Change to find the next instance of the word and automatically
change it.

• Click Change All to automatically replace all instances of that word.

Formatting and Structuring Text

You use the Format menu, the paragraph markup menu button, the character style menu
button, and the indent and outdent icon buttons to format your text and to add different
degrees of structure to your HTML document. Click a topic for more information.

• “Changing Font Styles”

• “Changing Text Color”

• “Changing Justification”

• “Changing Font Sizes”

• “About HTML”

• “Applying Structure to a Paragraph”
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• “Creating Section Headings”

• “Creating and Nesting Lists”

• “Entering Raw HTML Markup”

Changing Font Styles

You can mark a text string in a way that either:

• attaches visual characteristics to the text (such as boldface type), or

• categorizes the text string as an identifiable document element (such as a a
document citation).

Tagging text strings in this way allows HTML viewers to identify the strings and to
display them appropriately.

To apply a character tag to a text string, follow these steps:

1. Select the text you want to change.

2. Choose a tag in one of these ways:

• Open the Format menu, then choose a tag from the Character or Style rollover
menus.

• Use the Character Style menu button. It lists the same items as the Style rollover
menu.

• Click the button for bold, italic, fixed font, underline, or strike. These buttons
appear in the toolbar near the top of the window.

Changing Text Color

By default, the text you type is black. You can change all of the regular text to a different
color.

1. Choose “Background/Text Colors...” from the Element menu.

The Background & Colors window appears.

2. In the middle of the window, you see a list of items whose colors you can change.
Click Text.
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A blue triangle indicates it’s selected.

3. Click in the color wheel to select a new color or adjust the RGB and value sliders. If
the color wheel is black, drag the Value slider to the right.

The color chip changes to show the color you’ve selected.

4. Press the Apply button to apply the color change and leave the Background & Colors
window open; press the OK button to apply the color change and close the window.

All of the text in the document changes.

By default, text that users can click to follow a link is blue. To change the color of these
links, see “Changing the Appearance of Links.”

Changing Font Sizes

You can make selected text smaller or larger by opening the Format menu and choosing
a number from the Size rollover menu. “1” is the smallest front size; “7” is the largest font
size. You can also use the Font Size menu button. It provides the same choices.

Changing Justification

By default, text is aligned with the left edge of the page. You can center text or align it
with the right edge instead.

1. Click to place the insertion cursor within the paragraph.

2. Open the Format menu, then choose an item from the Justify rollover menu.

Optionally, you can click the alignment buttons in the toolbar.

About HTML

A structured document is one that contains identifiable elements, such as body
paragraphs and headings. A document is visually structured when the elements have
different looks (e.g., the headings are in a different weight and type of font than the body
text). A document is truly structured when the different elements have unique names,
and you apply a structure to a string of text to identify it (to ‘mark it up’). Once you’ve
marked up a document, viewers interpret the markup to determine how to display the
document.
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For example, if your document has body paragraphs and headings, a particular viewer
may display all headings in 12-point Helvetica bold font, and all body paragraphs in
10-point regular Times. A different viewer may display the elements completely
differently. However, each viewer will display the elements consistently. That is, in a
given viewer, all level one headings will look identical.

Applying Structure to a Paragraph

If you are not familiar with structured documents, see “About HTML.”

To apply structure to a paragraph, follow these steps:

1. Click to place the insertion cursor within the paragraph.

2. Open the Format menu, then choose an item from the Paragraph rollover menu or
choose an item from the paragraph markup menu button.

The name of the structure that you applied appears in the WebMagic status region
and, in some cases, the font style or formatting of the paragraph changes.

The structure that you apply effects only the paragraph in which the insertion cursor is
currently placed. If the cursor is at the end of the paragraph and you press <Enter> to
start a new paragraph, WebMagic applies the same or a complementary structure to the
new paragraph as shown in the table below.

Table 1-1 Automatically applied paragraph structures

Pressing <Enter> in a paragraph of this type: Creates a new paragraph of this type:

Body Body

any Heading Body

any List the next item in the same type of List; for an ordered
list, the item’s number is incremented by one

Descriptive Title Descriptive Data

Descriptive Data Descriptive Data

Preformatted Preformatted

Block Quote Block Quote

Address Address
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To change the automatically applied structure, leave the insertion cursor in the new
paragraph, and choose a different structure from the paragraph markup menu button.

Creating Section Headings

WebMagic supports six heading levels, which means you can hierarchically structure or
nest sections six levels deep. If you are not familiar with structured documents, see
“About HTML.”

In WebMagic and in most HTML viewers, each heading level is visually distinct. For
example, a Heading 1 paragraph might be displayed in 14-point Helvetica bold, while a
Heading 2 paragraph is displayed in 12-point Helvetica bold and is indented one inch.
When authoring a long document, it’s often useful to first create an outline that consists
of headings of varying levels.

To designate a paragraph as a heading, follow these steps:

1. Click to place the insertion cursor within the paragraph.

2. Choose a heading level from the paragraph markup menu button, or open the Format
menu and choose an item from the Paragraph rollover menu.

The name of the heading level that you applied appears in the WebMagic status
region and the font style and/or formatting of the paragraph changes.

3. Press <Enter> to start a new paragraph.

By default the new paragraph will be a body text paragraph.

Creating and Nesting Lists

WebMagic lets you create four different types of lists:

• Bulleted lists are not ordered, and each item is preceded by a bullet or other single,
non-alphanumeric character (the list you are reading now is a bulleted list).

• Numbered lists are ordered, where each item is preceded by an ordering character
such as an english numeral, roman numeral, or a letter of the alphabet. When you
add an item, the next sequential ordered character automatically precedes it.

• Menu lists are not ordered, and each item appears on its own line.
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• Directory lists are not ordered, and each item must contain 20 characters or less.
Many viewers arrange directory lists in columns.

To create these types of lists, see “Creating a List.” To nest lists of the same or different
types, see “Nesting a List within Another List.”

Creating a List

To create a list, follow these steps:

1. Click to place the insertion cursor within the paragraph that you want for the first
item in the list.

2. Choose a list type from the paragraph markup menu button, or open the Format
menu and choose an item from the Paragraph rollover menu.

3. When you have finished entering the text for the list item, press <Enter> to create a
new paragraph which is automatically designated as the next item in the list.

Nesting a List within Another List

You can nest lists of the same or different types using the indent and outdent icon
buttons. The list below is an example of an ordered list that has a bulleted list nested
within it.

1. Ordered item 1.

2. Ordered item 2.

• Nested bullet item 1.

• Nested bullet item 2.

3. Ordered item 3.

In WebMagic and in many viewers, when you nest lists of the same type, both the
indentation and the character that precedes each list item change to visually reinforce the
nesting. In the example above, the nested list is indented.
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To create a nested list within a list, follow these steps:

1. After typing the list item that will directly precede the nested list, press <Enter> to
create a new list item.

2. While the insertion cursor is positioned in the new list item paragraph, choose a
type for your new nested list from the paragraph markup menu button or from the
Paragraph rollover on the Format menu.

3. To structurally and visually nest the list, click the indent icon button (the icon button
whose arrow points to the right).

Alternatively, you can choose “Indent List” or “Outdent List” from the Format
menu.

4. Type the text for the first nested list item, then press <Enter> to create the next item
in the nested list. Repeat this for each item in the nested list.

5. After typing the final item in the nested list, press <Enter> to create a new
paragraph.

6. While the insertion cursor is in the new paragraph, click the outdent icon button
(the one whose arrow points to the left) and, if the nested list is of a different type
from the original list, choose the original list type from the paragraph markup menu
button. This creates the next sequential list item in the original list.

Entering Raw HTML Markup

If you’re familiar with the raw HTML markup language, you can edit markup directly.

To insert new HTML markup, follow these steps:

1. Choose “Insert Markup” from the Tools menu.

2. In the markup dialog that appears, enter the markup commands.

3. Click the OK button to insert the raw HTML, or click the Cancel button to discard
your entry.



Adding a Horizontal Rule

23

When you insert text from another HTML document, you may see some question mark
icons. These appear when the text contains HTML markup that WebMagic does not
interpret directly. To change such markup, follow these steps:

1. Highlight the question mark icon, then choose “Markup” from the Edit menu.

2. In the markup dialog that appears, enter a new markup command.

3. Click the OK button to insert the raw HTML, or click the Cancel button to discard
your entry.

Adding a Horizontal Rule

To visually distinguish one area of the page from another, you can add a horizontal rule.
To do so:

• Choose “Horizontal Rule” from the Element menu.

• Or click the horizontal rule button in the toolbar. This is the rightmost button in the
toolbar.

Working with Images in an HTML Document

Click a topic for more information:

• “Inserting Images”

• “Selecting Images”

• “Cutting Images”

• “Copying and Pasting Images”

• “Aligning Images on the Page”

• “Aligning Images to Surrounding Text”

• “Resizing Images”

• “Attaching Hypertext Links to Areas of an Image”
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Inserting Images

You can insert images in your HTML document. When you insert an image file, you do
not copy the image file into the document; you create an inline image link to the file.

You can insert an image by dragging and dropping an image file icon or by using the
“Insert” command. For details, see:

• “Inserting Images by Dragging and Dropping Icons”

• “Inserting Images Using the “Insert” Command”

Note: WebMagic knows how to display GIF, JPEG, XBM, and XPM image files. If you
insert another type of image, WebMagic displays a box as a placeholder. Preview the
document to see if your HTML browser display the image properly. If it doesn’t, you can
create an external link to the image file. See “Creating a Link to Other Types of Files.”

Inserting Images by Dragging and Dropping Icons

To insert an image by dragging and dropping its icon:

1. Position the cursor in the document, then click to place the insertion mark.

When you insert the image, it appears to the left of the insertion cursor.

2. Find the desktop icon that represents the image file you want to insert, drag the icon
over the WebMagic page, then release the mouse button.

The image automatically appears on the page.

Inserting Images Using the “Insert” Command

To insert an image using the “Insert” command:

1. Position the cursor in the document, then click to place the insertion mark.

When you insert the image, it appears to the left of the insertion cursor.

2. Open the File menu, then choose “Image File...” from the Insert rollover menu. Use
the file browser that appears to select the image.

The Create Link window appears. It lists the pathname of the image you’re
inserting.

3. Click Top, Middle, or Bottom to specify whether the image should be aligned with the
top, middle, or bottom of the paragraph in which the insertion cursor is placed.
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4. Click Left or Right to specify whether you want the image to appear on the left or
right side of the text.

5. In the Alternate Text field, enter the text that should replace the image on systems
that are able to view HTML documents but are unable to display images.

6. Click the OK button.

The image appears on the page.

Selecting Images

You select images the same way that you select text. Position the mouse cursor on either
side of the image, press and hold the left mouse button, and drag the mouse to highlight
the image. You can also place the cursor over the image, then double-click the left mouse
button to select the image.

A thin yellow line surrounds the image when it’s selected. If you’ve attached a hypertext
link to the image, you see a thin blue line instead.

Cutting Images

When you cut an image, WebMagic removes the image from your document and saves
it in memory until you cut or copy another item. Immediately after you cut the item, you
can paste it into another location of your document.

To cut images:

1. Select the image.

 See “Selecting Images” for instructions.

2. Choose “Cut” from the Edit menu.

The image disappears from the screen, but is saved by WebMagic until the next time
you cut or copy an item.

3. To place the cut image somewhere else in your document, move the insertion cursor
to the new location, then choose “Paste” from the Edit menu.

You can also paste the image into another WebMagic document. Use the “Open”
command to open the file, place the cursor in that document, then choose “Paste.”
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Note: You can also use the <Enter> key to remove an image from the page. You cannot
paste an image you have removed this way.

Copying and Pasting Images

When you copy an image, WebMagic places a copy of it in memory until you cut or copy
another item. Immediately after you copy the image, you can paste it into another
location of your document.

To copy an image:

1. Select the image.

 See “Selecting Images” for instructions.

2. Choose “Copy” from the Edit menu.

The image is saved by WebMagic until the next time you cut or copy an item.

3. To place the copied image somewhere else in your document, move the insertion
cursor to the new location, then choose “Paste” from the Edit menu.

Note: You can paste the image into another WebMagic document. Place the cursor in that
document, then choose “Paste.”

Aligning Images on the Page

By default, when you insert an image it appears at the location of the insertion cursor. If
the insertion cursor is on a blank line, the image is aligned with the left edge of the page.
You can change this by doing one of two things:

• Select the image, then choose “Image Attributes...” from the Element menu. Enter
numbers in the Border, Vertical Space, and Horizontal Space fields, then click the
OK button. This creates a blank area around the image.

• Place the cursor on the line that contains the image, open the Format menu, then
choose “Left,” “Center,” or “Right” from the Justify rollover menu. The image and
any text in the associated paragraph are repositioned.

You can also click the justification buttons that appear near the top of the WebMagic
window.
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Aligning Images to Surrounding Text

When you insert an image, you can specify how you want it to be aligned with the
surrounding text. You can align text with the top, middle, or bottom of the image. And
you can choose whether the image appears to the left or right of the text. To change the
alignment once the image appears on the page:

1. Select the image.

See “Selecting Images” for instructions.

2. Open the Element menu, then choose an item from the Image Alignment rollover
menu.

• Choose “Top” to align the top of the image with the text.

• Click “Middle” to align the middle of the image with the text.

• Click “Bottom” to align the bottom of the image with the text.

• Click “Left” to have the image appear on the left side of the page. The text flows
along the right side. WebMagic won’t move the image from left to right. To see
this change, choose “Preview” from the File menu.

• Click “Right” to have the image appear on the right side of the page. The text
flows along the left side. WebMagic won’t move the image from left to right. To
see this change, choose “Preview” from the File menu.

Resizing Images

By default, images appear at their full size. You can scale them on the page by doing the
following:

1. Select the image you want to resize.

See “Selecting Images” for instructions.

2. Choose “Image Attributes...” from the Element menu.

3. Use the Width and Height fields to specify the new size.

You can specify an exact measurement in pixels or you can specify the percentage of
the page you want the image to occupy. WebMagic preserves the aspect ratio if you
enter a value in only one field, either Height or Width.

Use the menu button to the right of the Height and Width fields to switch between
pixels and percentages.
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4. Click the OK button.

The image on the page is resized.

Note: This technique changes the size of the image as it’s displayed on the page. It does
not modify the original image.

Attaching Hypertext Links to Areas of an Image

Just as you can select a string of text and turn it into a hypertext link, you can select areas
of an image and attach links to them. This combination—an image, its hotspots, and its
links—is called an image map.

• “Creating the Hotspots”

• “Selecting Hotspots”

• “Creating the Default Link for an Image Map”

• “Moving Hotspots”

• “Resizing Rectangular and Circular Hotspots”

• “Reshaping Custom Hotspots”

• “Using Map Files Effectively”

• “Preparing Your Image Map for Publishing”

Creating the Hotspots

To create hotspots:

1. Select the image for which you want to create the links.

See “Selecting Images” for instructions.

2. Choose “Image Map” from the Element menu.

The Image Map window appears. It contains three drawing tools—a rectangle tool,
a circle tool, and a custom polygon tool.
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3. Use the drawing tools to mark off the area of the image you want to associate the
link with. This area is called a hotspot.

• To mark off a rectangular area, click the rectangle tool, place the cursor over the
image, then press the left mouse button and drag the cursor. A rectangle
appears. Release the mouse button when the rectangle is the proper size.

The rectangle must not extend beyond the left or top edge of the image.

• To mark off a circular area, click the circle tool, place the cursor over the image,
then press the left mouse button and drag the cursor. A circle appears. Release
the mouse button when the circle is the proper size.

The center of the circle cannot be placed above or to the left of the image.

• To create a custom shape, click the polygon tool, place the cursor over the
image, then click to place the first point. Move the cursor, then click to place the
second point. To signal that you are finished drawing, click the middle mouse
button.

The polygon must not extend beyond the left or top edge of the image.

4. While the hotspot is still selected, click the Link button in the Image Map window or
choose “Link” from the Element menu.

Small red boxes outline the hotspot when it’s selected. If the hotspot is not selected,
see “Selecting Hotspots.”

5. Set up the link according to the instructions in “Creating and Editing Links.”

The hotspot highlights blue when it has an associated link.

6. When you’re ready to publish your document, you may need to modify the image
map slightly. See “Preparing Your Image Map for Publishing.”

Note: You can test most links by choosing “Preview” from the File menu. This technique
does not work for image maps. You need to open your HTML browser, then open the
document by typing its URL.
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Creating the Default Link for an Image Map

“Creating the Hotspots” explains how you attach links to certain areas of an image. This
section explains how to create a default link for the entire image. In other words, it tells
you how to specify what happens when a user clicks the image but does not click a
hotspot.

1. Select the entire image.

If you aren’t able to select the image, click once on the page background, then try
selecting the image again. Or, in the Image Map window, click the button that
displays a text insertion cursor.

2. Click the link button in the Image Map window or choose “Link” from the Element
menu.

The Create Link window appears.

3. Set up the link according to the instructions in “Creating and Editing Links.”

Selecting Hotspots

You select a hotspot when you want to create or edit its link or move, delete, or resize the
hotspot. To do so:

1. Place the cursor over the hotspot.

If the cursor resembles a cross, move on to the next step. If the cursor resembles a
text cursor, open the Image Map window, then click the button in the upper left
corner. This button displays an arrow pointing to a small blue box.

2. Click the mouse button to select the hotspot.

Small red boxes outline the hotspot when it’s selected.

Moving Hotspots

To move a hotspot, place the cursor over the middle of the hotspot, then press and hold
the left mouse button. Move the cursor and the hotspot moves. Release the mouse button
when the hotspot is placed appropriately.

If the hotspot doesn’t move, check the appearance of the cursor. It should resemble an
arrow. If it resembles a text insertion cursor, open the Image Map window, then click the
button in the upper left corner. This button displays an arrow pointing to a small blue
box.
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Note: If you move a rectangle or polygon beyond the left or top edge of the image,
WebMagic reshapes the hotspot so it fits within the boundaries of the image.

If you move a circle so the center point is beyond the left or top edge of the image,
WebMagic changes the position so the center is within the boundaries of the image.

Resizing Rectangular and Circular Hotspots

You can make a hotspot larger or smaller.

1. Select the hotspot.

See “Selecting Hotspots” for instructions.

2. Place the cursor over one of the red boxes surrounding the hotspot, then press the
left mouse button and drag the cursor.

The hotspot becomes larger or smaller.

Reshaping Custom Hotspots

You can change the shape of a polygon by adding, moving, or deleting points.

1. Select the hotspot.

See “Selecting Hotspots” for instructions.

2. Change the shape by doing either of the following:

• Place the cursor over one of the red boxes surrounding the hotspot, then press
the left mouse button and drag the cursor to move that point.

• Place the cursor over one of the red boxes surrounding the hotspot, then click
the left mouse button to select that point. Press the <Enter> key to delete the
point.

• Place the cursor over the outline of the polygon, then press the left mouse
button and drag the cursor. This lets you add and position a new point.

Using Map Files Effectively

WebMagic keeps track of an image’s hotspots and links using a map file. It automatically
creates this file when you start adding hotspots to an image and saves it when you save
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your HTML document. As a result, you don’t usually need to open, save, or rename map
files. There are a few exceptions:

• You may want to use an existing map file. For example, suppose you use the same
image at the beginning of all your documents. Instead of creating the hotspots and
links repeatedly, you can use the original map file as a template of sorts.

If you want the hotspots and the links to be the same, choose “Use Map File...” from
the File menu on the Image Map window. If you want to edit the hotspots or change
the link behavior, choose “Insert from Map File...” from the File menu. You can
change the hotspots and links without altering the original file.

• WebMagic automatically creates the map file for you and gives it a default name.
The Image Map window displays this name. If you want to change the file name,
use the “Save Map File As...” command.

Preparing Your Image Map for Publishing

After you’ve created the image map and set up the links, you need to prepare the image
map so it can be viewed on the Web server. The procedure you follow varies depending
on the type of server you publish your files on.

• If your Silicon Graphics workstation is configured as an Out Box server or you are
running a NetSite server, you do not need to do anything further. Your image map
will work.

• If your administrator says that you are running an NCSA server that does not need
an imagemap.conf file. See “Using Image Maps on a Server Without an
imagemap.conf File.”

• If your administrator says that the NCSA server requires an imagemap.conf file, see
“Using Image Maps on an NCSA Server With an imagemap.conf File.”

Using Image Maps on a Server Without an imagemap.conf File

If your administrator says that you are running an NCSA server that does not need an
imagemap.conf file, complete the following steps before publishing your file.

1. Place your cursor in the document, then click the mouse button once.

This ensures that you’re in the proper mode when you create the link. If the Image
Map window is open, you can click the text insertion button.
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2. Select the image, then choose “Link” from the Element menu or click the Link
button.

The Link To field displays the name of the map file associated with that image.

3. In the Link To field, type /cgi-bin/imagemap followed by the full pathname of the map
file on the server.

To find the name of the map file, select the image, then open the Image Map tool.
The name of the map file appears in the lower portion of the window.

If you’ve created your document in the public_html directory and you haven’t
moved the map file to a new location, append the file name to this path. For
example, if your map file is named bicycle.map, type:
/cgi-bin/imagemap/bicycle.map.

If you’ve moved the map file to a new location, perhaps a subdirectory named
images, type the following: /cgi-bin/imagemap/images/bicycle.map

Note: Next time you open this document, you will get an error message because
WebMagic will not be able to find this file. If you want to edit the map file, you’ll need to
restore the original link. When it’s time to publish the file, you’ll need to change the link
again.

Using Image Maps on an NCSA Server With an imagemap.conf File

If your administrator says that you are running an NCSA server that requires an
imagemap.conf file, complete the following steps before publishing your file.

1. Ask the server administrator for the pathname to the imagemap program.

2. Place your cursor in the document, then click the mouse button once.

This ensures that you’re in the proper mode when you create the link. If the Image
Map window is open, you can click the text insertion button.

3. Select the image, then choose “Link” from the Element menu or click the Link
button.

The Link To field displays the name of the map file associated with that image.

4. In the Link To field, type the pathname to the imagemap program, followed by a
symbolic name for your file.

For instance, suppose the program path is /cgi-bin/imagemap and you want to use the
symbolic name “bicycle.” Type: /cgi-bin/imagemap/bicycle.
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5. Ask the server administrator to edit the imagemap.conf file and include the symbolic
name followed by the path to your image map file.

For instance, the file might contain an entry like:

bicycle: bicycle.map

Note: Next time you open this document, you will get an error message because
WebMagic will not be able to find this file. If you want to edit the map file, you’ll need to
restore the original link. When it’s time to publish the file, you’ll need to change the link
again.

Creating and Editing Links

Click a topic for more information:

• “About Links and Targets” describes the types of hypertext links you can create
with WebMagic. Read this section if you are unfamiliar with the concepts or terms
of linking to targets.

• “Creating a Link to Other HTML Documents” provides step-by-step instructions
for linking to another document.

• “Creating a Link to Other Types of Files” provides step-by-step instructions for
launching applications and opening other types of files.

• “Creating a Link to Remote HTML Documents” provides step-by-step instructions
for providing links to documents on another system.

• “Creating a Link to a Specific Location within an HTML Document” provides
step-by-step instructions for linking to a particular location within a document.

• “Creating a Link Target” provides step-by-step instructions for designating an
element in your document as a target to which you and other authors can link.

• “Showing and Hiding Link Targets in a Document” explains how to use the View
window to show and hide targets.

• “Changing the Appearance of Links” explains how to change the color of links.

• “Testing Links” explains how to preview your document and try out the links
you’ve created.

See also “Attaching Hypertext Links to Areas of an Image.” It provides a description of
image maps and explains how to create them.
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About Links and Targets

WebMagic lets you add hypertext links to your HTML document. A link is a pointer that
specifies the location of:

• an entire HTML document

• a specific location within an HTML document

• another type of file, such as an image, audio, or movie file

Any item that a link points to is called a destination. When you create a link, you are
storing in the HTML document the location of a specific destination.

You can create two types of links:

• an external link. You must explicitly follow the link (usually by clicking on it) to view
the destination.

For example, at the beginning of your document you create a topic list of the major
sections in your document. You link each item in the list to the actual location
(target) in the document that covers the topic. When a person viewing the
document wants to go to a location (i.e., when he wants the viewer to display this
portion of the document), he clicks on the item in the topic list.

• an inline image link. The image is automatically displayed on an HTML page, even
though the image resides in a separate image file. A person viewing the document
does not have to explicitly follow this link; once an inline image link exists, the
image is always displayed. See “Inserting Images” for details.

When you publish a document on the Web, it is an available destination to which other
authors can link. However, to allow yourself and other authors to link to specific
locations within your HTML document, you need to identify each location of interest as
a target and must create a unique target name for it. See “Creating a Link Target.”

Creating a Link to Other HTML Documents

You can create a link to another HTML document by dragging and dropping the file icon
or by using the “Link...” command.
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This section describes how to link to a document on your local system. For instructions
on linking to a document on a remote system, see “Creating a Link to Remote HTML
Documents.”

1. Specify the location in the document for the link.

• Select the text string or image that the user will click to follow the link.

• Or select the hotspot that the user will click to follow the link. See “Creating the
Hotspots” and “Selecting Hotspots” for details.

2. Make the link by doing either of the following:

• Find the desktop icon for the HTML file you want to link to, then drag it onto
the page. Release the mouse button and the link is complete.

• Choose “Link...” from the Element menu or click the Link button. The Create
Link window appears. In the Link To field, enter the file name of the document
you want to link to. You can type in the name or you can click the Browse button
and use the Link to Document window to choose a file. Click the OK button to
create the link.

Note: If you set up your work area as described in “Setting Up a Work Area for
Easy Publishing,” the filename or pathname that you enter in this field will not
start with /; for more information, see “About URL Translations.”

The selected item turns blue, indicating it has an attached link. If you hadn’t
selected anything, WebMagic inserts the file name you are linking to at the
cursor location.

Creating a Link to Remote HTML Documents

You can create a link to an HTML document that’s on another system. To do so:

1. Specify the location in the document for the link.

• Select the text string or image that the user will click to follow the link.

• Or select the hotspot that the user will click to follow the link. See “Creating the
Hotspots” and “Selecting Hotspots” for details.

2. Choose “Link...” from the Element menu or click the Link button.

 The Create Link window appears.
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3. In the Link To field, enter the URL of the document you want to link to.

If you want to link to a specific location within that document, place a # sign and the
target name after the URL. For instance, the Link To field may contain:

http://skippy/docplan.html#target1

When you follow the link, you open the file docplan.html and you are scrolled to the
paragraph the author marked as target1.

4.  Click the OK button to create the link.

Creating a Link to Other Types of Files

You can create a link to another type of file by dragging and dropping the file icon or by
using the “Link...” command. For these links to work properly in your HTML browser,
you need to name the files according to certain conventions. For instance, the Netscape™

browser recognizes Showcase™ files if they end with .showcase, .slides, .sc, .sho, or .show.
For a complete listing of the file types and extensions that Netscape recognizes, see
/usr/local/lib/netscape/mime.types.

For step-by-step instructions, see “Creating a Link to Other HTML Documents.” The
procedure is the same.

Creating a Link to a Specific Location within an HTML Document

You can create a link to a specific location within an HTML document. When you follow
such a link, the document opens and displays the specified section.

This section describes how to link to a document on your local system. For instructions
on linking to a document on a remote system, see “Creating a Link to Remote HTML
Documents.”

1. Specify the location in the document for the link.

• Select the text string that the user will click to follow the link.

• Or select the hotspot that the user will click to follow the link. See “Creating the
Hotspots” and “Selecting Hotspots” for details.

2. Choose “Link...” from the Element menu or click the Link button.

The Create Link window appears.
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3. If you want to link to a location in another HTML document, open that document
now using the “Open...” command on the File menu.

4. If you want to link to a location in another HTML document, enter the name of the
document in the Link To field. If you want to link to a location in the same
document, skip this step.

You can either type in the name, or you can click the Browse button and use the Link
to Document window to choose a file.

Note: If you set up your work area as described in “Setting Up a Work Area for Easy
Publishing,” the filename or pathname that you enter in this field will not start with
/; for more information, see “About URL Translations.”

5. Use the menu button labeled Document to choose which list of targets to display—
those in the current document or those in the document specified in the Link To
field.

This menu button lists the documents that are currently open. If the menu button
doesn’t list the document you want, check to make sure that the document is open.

6. Along the right edge of the Create Link window, you see a list of elements you can
list. Click to select or deselect items.

• Display Targets if you want to see a list of items the author has marked as
targets for links. These items begin with a #.

• Display Headings if you want to see a list of all the paragraphs the author has
marked as headings. You can link to these even if the author has not designated
them as targets.

7. Click to select an item in the list, then press the OK button.

WebMagic makes the link. If you selected a heading that isn’t already marked as a
target, WebMagic automatically designates the item as a target and gives it a unique
target name. Consequently, when you close that file, you’ll need to save the
changes. If you do not have permission to save changes to the file, you will not be
able to use this technique.

Note: If you’re making a link from a hotspot on an image, you need to enter the
document and target name in the Link To field and separate the two entries with a # sign.
You cannot follow the procedure outlined above. For instance, to create a link to a target
named target1 in a document named file1, you type file1#target1.
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Creating a Link Target

To allow yourself and other authors to link to specific locations within your HTML
document, you need to identify each location of interest as a target and must create a
unique target name for it. There is one exception. You do not need to create target names
for any items you have marked as headings.

To identify a location as a target, follow these steps:

1. Select the text or image that will be a target.

2. Click on the target icon button, or choose “Target (Anchor)...” from the Element
menu.

The Create Link Target window appears.

3. In the Create Link Target window, enter a unique, meaningful name for the target in
the Target Name field.

4. Create the target, or cancel your request.

• Click OK to give the target the name you entered. The text or the outline of the
image that you named as a target turns blue, and a target icon appears in the
left margin.

• Click Cancel to dismiss the Create Link Target without naming the text or image
as a target.

Now you and other authors can create links to your target; see “Creating a Link to a
Specific Location within an HTML Document.” If you need to edit the target, select the
entire item you marked as a target, then choose “Target(Anchor)...” from the Element
menu.

Copying and Pasting Links

You can copy and paste links the same way you copy and paste text and images.

1. Select the item whose link you want to copy.

2. Choose “Copy Link” from the Edit menu.

3. Select the item to which you want to paste the link.

For instance, if you want to paste the link onto a particular word, select the word.
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4. Choose “Paste Link” from the Edit menu.

You’ve just created a link.

Showing and Hiding Link Targets in a Document

By default, WebMagic identifies targets by placing a green marker in the left margin. To
hide these markers while you’re working on a document, choose “Targets” from the
View menu. The red checkmark next to the menu entry disappears and the target
markers are hidden. To display them, choose “Targets” again.

Changing the Appearance of Links

By default, links appear blue. Once a link has been followed, it turns purple. While a link
is being executed, it turns red. You can change these colors.

1. Choose “Background/Text Colors...” from the Element menu.

The Background & Colors window appears.

2. Click on Link, Visited Link, or Activated Link.

A blue triangle indicates which item is selected.

3. Click in the color wheel to select a new color or adjust the RGB and value sliders.

The color chip changes to show the color you’ve selected.

4. Press the Apply button to apply the color change and leave the Background & Colors
window open; press the OK button to apply the color change and close the window.

Testing Links

You can test links in one of several ways.

• While you’re working on a document, choose “Preview” from the File menu.
Netscape appears and displays your document. Click on text or images to test the
links.

• Drag your file’s icon onto the Netscape icon or double-click your file’s icon.
Netscape appears and displays your document. Click on text or images to test the
links.
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Note: These techniques do not work for image maps. You need to open your HTML
browser, then open the document by typing its URL.

Including Forms in a Web Document

Web documents let you deliver information to other people on the Internet. In addition,
you can use a Web document to gather information from other people. You do so using
forms. This section contains:

• “What is a Form?”

• “Building a Form”

• “Editing Forms”

• “Attaching a Script to the Form”

• “Exiting a Form Area”

What is a Form?

You can think of forms as small programs. The user interface appears in the Web
document; the cgi-bin program that determines what is done with the data is stored on
the Web server. You use WebMagic’s form tool to design the interface—the text fields,
option lists, and more.

Typically, you create a form to let people search for information in a database, submit an
online request form, and more. Here are a few specific examples:

• Many businesses place catalogs on the Web. To order merchandise, you fill out an
online order form. Such a form often contains a variety of elements—a list of items
you can order, text fields for entering your name and address, options for choosing
the type of delivery you want, options for specifying a payment method, and a
button for placing your order. After you submit the order, you may receive a
confirmation notice telling you when the item will be shipped to you.

• Some Web pages are designed to help you search for documents that contain key
words or phrases. You may see one text field, into which you type the word of
interest, and one button, which you press to begin the search. After you’ve
performed the search, you’ll be presented with a list of documents to view.
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For information on constructing a form, see “Building a Form.” For information on
writing a cgi-bin program and placing it in the proper place on the Web server, see the
NetSite™ Communications Server Administrator’s Guide.

Building a Form

You can construct a form using WebMagic’s Form tool. To open the tool, choose “Form...”
from the Element menu. This tool lets you add items that are commonly found on forms:
fill-in text fields, lists, options, and more. No matter what type of item you add, you
follow the same basic procedure. The procedure is outlined below; it’s followed by
step-by-step instructions for each component.

1. Open the Form tool by choosing “Form...” from the Element menu.

2. Click a button to select which type of item you want to add to the form.

3. Identify the item by typing a unique name in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field

4. Specify any other attributes, such as the width of the text field, the commands on
the menu, or the label on the button.

5. Click the Insert button.

That element appears on the page. If this is the first item you’ve added, you’ll notice
that a thin line appears along the left edge of the page. This shows you which region
of the page is designated as a form.

Adding Fill-in Text Fields

You use fill-in text fields when you need people to enter information by typing. For
instance, you might use a text field to gather a person’s name or address.

1. Click the button shown in Figure 1-1.

The Form tool changes. It displays the controls you use to set up a text field.

Figure 1-1 Adding a fill-in text field.
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2. Enter a name for this item in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field.

3. Click Password Field if this is a text field into which people will enter passwords or
other confidential information.

When users type into password fields, the text is hidden.

4. If you want the text field to contain some default text, enter that in the Value field.

5. In the Width field, specify how wide you want the field to be.

This is measured in characters. If you want the field to be wide enough to display 10
characters, type 10 in the field.

6. In the Max Length field, enter the number of characters you can type in the field.

For example, you may limit the size of a text field so it fits well on the page. If you
want people to be able to enter text strings that are longer than the field, enter a
larger number in the Max Length field.

7. Click the Insert button to place the text field on the page.

Adding Scrolling Text Regions

You use scrolling text fields when you need people to enter information by typing and
you expect them to enter more than a few words. For instance, you would probably
provide a scrolling text region for people to type the content of an email message.

1. Click the button shown in Figure 1-2.

Figure 1-2 Adding a scrolling text area.

2. Enter a name for this item in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field

3. Enter a number in the Rows field.
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This determines how many lines of text display in the field. For instance, if you type
3, only three lines will display. If the text area contains more than three lines, people
will have to scroll to view them.

4. Enter a number in the Columns field.

This determines the width of the text area. It’s measured in characters. If you want
the field to be wide enough to display 10 characters, type 10 in the field.

5. In the Value field, type the text you’d like to have appear by default.

If you leave this field blank, the scrolling text region will be empty by default.

6. Click the Insert button to place that text area on the page.

Now that the text area is on the page, you can add to and edit it directly.

Presenting Scrolling Selection Lists

If you need to offer people a list of choices, you can place a selection list on your form.
For instance, if you’re promoting restaurants, you might include a list of cities. People
can select the cities for which they’re interested in getting a list of restaurants.

1. Click the button shown in Figure 1-3.

Figure 1-3 Adding a scrolling selection list.

2. Enter a name for this item in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field

3. Click Multiple Selection if you want to let people select more than one item on the
list.

When the checkmark appears, multiple selection is enabled.

4. Enter a number in the Height field.

This number determines how many list items are displayed. For instance, if you
type 3, only three items in the list will display. To see other items in the list, users
will have to scroll up and down.
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5. Begin creating the list:

• In the Label field, type the text that you want to appear on the list.

• Click Checked if you want this list item to be selected by default. A red
checkmark indicates it’s selected.

• Fill in the Value field if you want the data submitted to the server to be different
from the choices presented to the user. For instance, you may ask people to
indicate whether they prefer the color purple or orange. Instead of returning
“purple” or “orange,” you return “p” or “o.” This step is optional.

6. Add items to the list by clicking the Add After or Add Before button.

New Value and Label fields appear. If they’re hidden, use the scroll bar to bring them
into view. Create the list item by following the instructions in step 5.

7. Delete items from the list if necessary.

To delete an item, you need to select it. In the Form tool, place the cursor over the
gray area to the right of the Checked label. Click the left mouse button. A thin yellow
line appears, indicating the entry is selected. Press the Delete button and that item
disappears.

8. Press the Insert button to place that component on the page.

Note: If you specify a height of 1 and do not allow multiple selection, you will create a
menu button instead of a selection list.

Presenting Options Using Menu Buttons

If you want people to select one item from a list of options, you can add a menu button
to your form.

1. Click the button shown in Figure 1-4.

Figure 1-4 Adding a menu button.

2. Enter a name for this item in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field
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3. Begin creating the list of options for the menu button:

• In the Label field, type the text that you want to appear on the list.

• Click Selected if you want this item to be the default selection.

• Fill in the Value field if you want the data submitted to the server to be different
from the choices presented to the user. For instance, you may ask people to
indicate whether they prefer the color purple or orange. Instead of returning
“purple” or “orange,” you return “p” or “o.” This step is optional.

4. Add other items to the list by clicking the Add After or Add Before button.

New Value and Label fields appear. If they’re hidden, use the scroll bar to bring them
into view. Create the list item by following the instructions in step 3.

5. Delete items from the list if necessary.

To delete an item, you need to select it. In the Form tool, place the cursor over the
gray area to the right of the Selected label. Click the left mouse button. A thin yellow
line appears, indicating the entry is selected. Press the Delete button and that item
disappears.

6. Press the Insert button to place the menu button on the page.

Presenting Options Using Radio Buttons and Checkboxes

Radio buttons are similar to menu buttons. Use them when you want users to select one
out of several options. Checkboxes can be used in groups or individually.

1. Click one of the buttons shown in Figure 1-5.

Figure 1-5 Adding radio buttons and checkboxes.

2. Enter a name for this item in the Field Name field.

Usually, you need to specify a unique field name. Radio buttons are the exception to
this rule, however. You need to use the same field name for all the buttons that you
group together.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field
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3. Click Checked if you want this button to be selected by default.

A red checkmark indicates it’s selected.

4. Fill in the Value field if you want the data submitted to the server to be different
from the choices presented to the user.

For instance, you may ask people to indicate whether they prefer the color purple or
orange. Instead of returning “purple” or “orange,” you return “p” or “o.” This step
is optional.

5. Click the Insert button; the radio button or checkbox appears on your page.

6. The button doesn’t have an associated label. You need to type this directly on the
page.

7. Create the other radio buttons or checkboxes by repeating steps 1 through 6.

Adding Buttons

You add a push button to your form to let people submit their form. For instance, after
completing an online order form, a person might press a Send button. You also use
buttons if you want to let people quickly restore the default settings or clear the fields.

1. Click the button shown in Figure 1-6.

Figure 1-6 Adding a push button.

2. Enter a name for this button in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field

3. Choose the behavior you want by clicking Submit Button or Reset Button.

• Click Submit Button if you want users to click this button when they are finished
filling in the form. For instance, they may click a button when they’re ready to
send their online order form. Or they may click a button when they’re ready to
begin searching for a specified word.

• Click Reset Button if you want people to click the button to restore the default
values or clear the fields.
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4. Type the button label in the Value field.

5. Click the Insert button; the button appears on your page.

Using Hidden Fields on a Form

A hidden field is a region of the form that is not displayed to the user. You can use these
fields to store data and transfer it from one form to another. For instance, suppose a user
completes an order form then presses a Send button. You then present the user with a
confirmation notice. If the user clicks OK, you want to automatically send the data to the
server. In this case, the confirmation window may contain a hidden field; in it is stored
the form data.

1. Click the button shown in Figure 1-7.

Figure 1-7 Adding a hidden fields.

2. Enter a name for this button in the Field Name field.

This name does not appear on the form; it’s stored in the HTML file. The cgi-bin
script uses this name to identify the information collected from that field

3. Fill in the Value field if you want to display some default text in this field.

This step is optional. The text is not displayed when the document is viewed using
an HTML browser. It’s displayed only while you’re editing in WebMagic.

4. Click the Insert button.

A text field appears on the page. It represents the hidden field.

Editing Forms

You can change the layout of a form and edit individual pieces.

• To move an item from one place to another, select the item, then use the “Cut,”
“Copy,” and “Paste” commands on the Edit menu. An item is selected when a thin,
yellow line surrounds it.
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• To change the definition of an item, select the item, then choose “Form...” from the
Element menu. The Form tool appears; it displays the values for that item. Make the
changes, then click the Insert button.

• To change the alignment of an item, place the cursor on the line that contains the
item, then click the mouse button. Open the Format menu, then choose “Left,”
“Center,” or “Right” from the Justify rollover menu.

Attaching a Script to the Form

WebMagic lets you build a form quite easily. To make the form functional, you need to
write a program, called a cgi-bin script, and place it in the proper location on the Web
server. This section provides an overview of the steps involved. It does not explain how
to write the script, however.

1. Create the cgi-bin script.

2. Place it in the proper location on the Web server.

The default directory on a system running Out Box is /var/www/cgi-bin. Check with
the server administrator if you’re uncertain about the location.

3. If it isn’t already open, open the Form tool by choosing “Form...” from the Element
menu.

4. Place your cursor inside the form area on the page, then click to make sure that form
is active.

5. Click the Script button on the Form tool.

6. Specify which cgi-bin script to use by typing its pathname in the Form Action field.

If you’re unsure of the pathname, ask the server administrator for the correct
pathname.

7. Click GET or POST to specify how you want to package and send the form data.

Unless you are familiar with these options and have a specific need for GET, use the
default setting (POST).

8. Click the Insert button.
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Exiting a Form Area

By default, when you start creating a form, you see a thin bracket along the left edge of
the page. The bracket identifies that portion of the page as a form area. When you’re
finished creating the form, you can close the form area by pressing the <Enter> key
twice. You create a new, empty paragraph that’s not a part of the form.

Customizing the Page Background

By default, the page background is light gray. You can change the color or place an image
on the background. For details, see:

• “Placing an Image on the Background”

• “Changing the Background Color”

Placing an Image on the Background

To place an image on the page background:

1. Choose “Background/Text Colors...” from the Element menu.

The Background & Colors window appears. At the top of the window, you see a
type-in field labeled “Background Image.”

2. Enter the name of the image you want to use or click the Browse... button. Use the
file browser that appears to select the image.

3. Press the Apply button to change the background and leave the Background &
Colors window open; press the OK button to change the background and close the
window.

The background changes.

Note: The location of the image file is important. It must be in your project root directory
or one of its subdirectories. Otherwise, the background image won’t appear when you
view the file using your HTML browser.
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Changing the Background Color

To change the color of the page background:

1. Choose “Background/Text Colors...” from the Element menu.

The Background & Colors window appears.

2. In the middle of the window, you see a list of items whose colors you can change.
Click Background.

A blue triangle indicates it’s selected.

3. Click in the color wheel to select a new color or adjust the RGB and value sliders.

The color chip changes to show the color you’ve selected.

4. Press the Apply button to apply the color change and leave the Background & Colors
window open; press the OK button to apply the color change and close the window.

The background changes.

Specifying a Title

WebMagic lets you give your document a title that’s different from the name of the
HTML file in which your document is stored. For example, the document stored in a file
named febproj.html could have a title of February Projects.

To give your document a title, place the cursor in the Document Title field, then type a title.
The Document Title field appears near the top of the window. If it’s not visible, choose
“Document Title” from the View menu.

If you do not explicitly title your document using these steps, WebMagic uses the first
level one heading in the document as the title. If your document has no level one
headings, WebMagic titles it “Untitled”.

Note: You should always give your document a meaningful title. Many HTML viewers
efficiently search for titles, and they always display the title prominently while
displaying the HTML page.
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Viewing and Publishing the Document

It’s important to view your document at various times during the authoring process to
test links and to see how your document will appear to your viewing audience.

To view your HTML document using Netscape, use one of these methods:

• Choose “Preview” from WebMagic’s File menu.

• Drag the document’s icon onto the Netscape icon.

For information on publishing, see “Publishing a Document on the Web.”

Publishing a Document on the Web

If your system is running the Out Box server and your HTML file and all files it references
reside in the public_html directory or a subdirectory, you do not need to do anything
further to publish your files. They are automatically available for others to view. The URL
for these files is http://<machinename>/~<username>/filename.

You need to take additional steps under the following circumstances:

• You want to publish the document on another web server and all the local files that
your document references are in a subdirectory of your project root directory. See
“Copying a Document to Another Web Server.”

• You do not want people to view your document until it’s completed. Instead of
creating the document in the public_html directory, you create it in a different
directory. See “Copying a Document to Another Web Server.”

• Your HTML file has links to files that are not in the same directory as your HTML
document. See “Translating URLs Before Publishing a Document.”

Copying a Document to Another Web Server

This section describes how to copy your document to another web server. These
instructions also apply if your system is running the Out Box server but you choose to
author HTML documents in a directory other than public_html.
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1. If you plan to publish your document on another web server, ask the server
administrator for:

• the name of the web server

• a location on the server in which you can place your files

If your system is running the Out Box server and you want to publish the files on
your system, the default location is the public_html directory in your home directory.
See also “Creating and Publishing Files Using the public_html Directory.”

2. Copy your files into your assigned directory on the web server.

Make sure you keep all subdirectories intact when you copy them, otherwise your
HTML document may not be able to follow links.

For example, say your HTML document (mydoc.html) is in your project root directory
and the images to which it links are in the images subdirectory. Your administrator
tells you to put your document in the /usr/netsite-docs/joe directory. You must copy
your files onto the server so that /usr/netsite-docs/joe contains two items: the file
mydoc.html and the directory images.

For more information on copying files and directories across the network, refer to
the Desktop User’s Guide, which is one of the Online Books accessible through the
Help menu of the desktop Toolchest.

Translating URLs Before Publishing a Document

For the links in your Web document to work properly, the browser must be able find the
files to which you’ve linked. It does using “directions.” For instance, it may look for a file
named image1.gif in the /usr/images directory. You need to make sure that these directions
are still valid when you copy the files to the web server.

If you have links to files that are not in the same directory as your HTML document or in
one of its subdirectories (as in the example cited above), you need to translate the
directions (URLs) before publishing the document. To do so, use the “Publish”
command. It is similar to the “Find/Change...” command. Instead of searching and
replacing text in your document, you search for and replace link references.

1. Ask the administrator for:

• the name of the web server

• a location on the server in which you can place your files
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2. Choose “Publish” from the File menu.

A window appears that shows all the files and directories in your current working
directory (project root directory) and shows all the Document URLs to which this
document links.

If WebMagic does not display your project root directory, enter the full pathname of
your project root directory in the Publish to file field, then press <Enter>.

3. If any items in the Document URLs list begin with a /, you need to change their
translations by clicking the Change Translations button. See also “Setting
Publishing Preferences” and “About URL Translations.”

4. Once you change the translations, you can save the HTML file with its new
translations by entering the filename in the text entry field and clicking the OK
button.

5. For each local file whose URL you translated, place a copy of the file in the
appropriate location in your project root directory.

For example, if you translated the URL of the file face.rgb from /usr/images to images,
you must now copy the file face.rgb into the images subdirectory of your project root
directory.

6. Copy your files into your assigned directory on the web server.

Make sure you keep all subdirectories intact when you copy them, otherwise your
HTML document may not be able to follow links.

About Publishing and URLs

Every document and file stored on a web server has a unique location on the Web called
a Universal Resource Locator (URL). People can access a published document either by
following a series of links, or by specifying the document’s URL. The URL consists of
three components:

• the protocol used to retrieve the document, file, or program

• the name of the web server

• the pathname of the document, file, or program on the server
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The sample URL below belongs to a document that is retrieved via the http protocol,
resides on a web server named www.w3.org, and has a pathname of
/hypertext/WWW/MarkUp/MarkUp.html.

http://www.w3.org/hypertext/WWW/MarkUp/MarkUp.html

If you set up a work area as described in “Creating and Publishing Files Using the
public_html Directory,” or “Creating and Publishing Documents For Use on Another
Server,” WebMagic automatically translates the pathname of your project root directory
(and its subdirectories) to keep all links intact.

If you did not set up a standard work area, your HTML document may contain links to
files that are located on your own system, but are not in either the same directory as your
HTML document or a subdirectory of the directory that contains your HTML document.
To publish such a document, you may need to change at least one URL translation; see
“Translating URLs Before Publishing a Document.”

About URL Translations

The ultimate destination of your HTML document is some location on a web server (see
also “About Publishing and URLs”). WebMagic helps you to author your document so
that you can easily transfer it to any location on any web server and still preserve all
links. The mechanism WebMagic uses is called URL Translations.

For example, URL Translations on your project root directory work in this way:

• In the Preferences window, you specify your project root directory.

• WebMagic then strips the pathname of your project root directory from every link
you make, which makes all links relative rather than absolute (none of the links
begin with /).

For example, with a project root directory of /usr/people/job/public_html, when you
create a link from /usr/people/job/public_html/mydoc.html to
/usr/people/joe/public_html/yourdoc.html, the link refers to only the filename
(yourdoc.html), not the full pathname of the file.

• Regardless of the full pathname of the directory on the web server in which your
HTML document resides, your HTML document will always be able to find the
appropriate peer files or subdirectories.



56

Chapter 1: Authoring with WebMagic

When creating links to other files on your system, try to copy or move those files into
subdirectories of your project root directory to keep your document portable and
publishable. See also “Setting Up a Work Area for Easy Publishing.”

If you plan to link to locations on your web server, the Server Root translation in the
Preferences window must be accurate. When you create a link to a location on the web
server, always start the link with / and provide a full pathname that does not include the
path of the server root.

For example, if the server root is /var/www/htdocs and you want to link to the file
/var/www/htdocs/fred/home.html, the link will be to /fred/home.html.

Printing a Document

You can print HTML documents either in formatted PostScript or in raw HTML (so you
can see all the HTML markup). You can also use the “Print” choice on the File menu to
place the document in a file as either formatted PostScript or HTML.

When you print an HTML document, WebMagic prints only the current document and
inline image links; it does not print documents that are referred to via an external link.

To print a file on a printer or to format it for printing then save it in a file, follow these
steps:

1. Choose “Print” from the File menu.

2. In the Print Document window, use the Print file format menu button to choose to
print it as PostScript or HTML.

3. Choose a page size and orientation.

4. To send the formatted output to a file rather than a printer, click in the box labeled
Print to file, then enter a name for the file.

5. Choose a printer from the Available Printers list by clicking on its name.

6. Print the file by clicking the Print button.
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Setting WebMagic Authoring Preferences

WebMagic lets you set two types of preferences; click the type in which you are
interested:

• “Setting General Preferences”

• “Setting Publishing Preferences”

Setting General Preferences

By default, WebMagic saves changes to the open file every 2 minutes, and creates a
backup file each time it is saved (see “Saving Changes Automatically”). It’s also set up to
suppresses all HTML warning and error messages and use Netscape as the HTML
browser. Lastly, when you drag and drop files onto the page, WebMagic automatically
makes a link to the selected text or image.

To change this default behavior, follow these steps:

1. Choose “Preferences” from the File menu.

The Preferences window appears.

2. Choose “General” from the Preference Category menu button.

3. Specify which behavior you want to change.

• To stop WebMagic from making a backup file after every save, click to remove
the checkmark from the box next to Make a backup file when file is saved.

• To stop WebMagic from saving automatically, click to remove the checkmark
from the box next to Make a checkpoint file every 2 minutes while editing.

• To continue to have WebMagic save automatically but to have it do so more or
less frequently, keep the checkmark in the box, and change the value in the
editable field from 2 to a different number of minutes.

• To see all HTML warnings and errors when WebMagic reads an HTML or RTF
file, click to place a checkmark in the box next to Show HTML warnings/errors.

• To use an HTML browser other than Netscape, choose an item from the Preview
menu button.
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• To change what happens when you drag and drop files while text or an image is
selected, choose an item from the menu button labeled File drag-and-drop action.
By default, WebMagic creates a link to the selected item. Instead, you can
replace the selected item or open the Create Link window.

4. If you want to change Publishing Preferences, see “Setting Publishing Preferences.”

5. Save the preference values, or cancel your changes.

• Click OK to save the changes for this file only and to close the window.

• Click Save to save the changes for all WebMagic documents and to keep the
window open. This saves the general and publishing preferences.

• Click Cancel to close the window. If this is the first button you click in this
window, no changes will be made.

Setting Publishing Preferences

If you are unfamiliar with URL translations, see “About URL Translations.” To learn
more about publishing on the Web, see “Publishing a Document on the Web” and “About
Publishing and URLs.”

By default, WebMagic automatically translates URLs when you create links, and it
assumes that the server root is /var/www/htdocs and the project root directory is the
directory from which you started WebMagic.

To change these default behaviors and to add custom URL translations, follow these
steps:

1. Choose “Preferences” from the File menu.

The Preferences window appears.

2. Choose “Publishing” from the Preference Category menu button.

3. Specify which behavior you want to change.

• To stop WebMagic from translating URLs when you create links, click to remove
the checkmark from the box next to Translate URLs when creating links.

• To change the value of the server root path, change the information in the field
next to Server Root. Do not change the field below the Server Root field (i.e., keep
the / as the only item in the field).
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• To change the value of the project root directory, change the information in the
field next to Project Root. Do not change the field below the Project Root field (i.e.,
keep the field empty).

• To add a custom translation, click the Add button, then enter the full pathname
of the directory on your system in the User Defined field, and enter the
pathname that the directory will have on the web server in the --> field.

• To remove a custom translation, click to select it, then click the Delete button.

4. If you want to change General Preferences, see “Setting General Preferences.”

5. Save the preference values now displayed, or cancel your changes.

• Click OK to save the changes for this file only and to close the window.

• Click Save to save the changes for all WebMagic documents and to keep the
window open. This saves the general and publishing preferences.

• Click Cancel to close the window. If this is the first button you click in this
window, no changes will be made.
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2. WebMagic Reference

This chapter describes each element in the WebMagic main window and provides a brief
description of many of its subwindows. Click a topic for more information.

• “Anatomy of the WebMagic Window”

• “About the Menus”

• “About the Menu Buttons in the Toolbar”

• “The Form Tool”

• “The Image Map Tool”

• “The Image Attributes Window”

• “The Background/Text Color Tool”

• “The Insert Text Dialog Box”

• “The Insert Table Dialog Box”

• “The Create Link Window”

• “The Horizontal Rule Attributes Dialog Box”

• “Using the WebMagic File Browser”

• “The Right Mouse Button Pop-up Menu”

Anatomy of the WebMagic Window

The Status Bar

The Status Bar reports status information, and displays links and targets when the cursor
is positioned over these elements.
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The Scroll Bars

Use the horizontal and vertical scroll bars to see different portions of your document.
Drag the elevator box in a scroll bar to interactively scroll the window, or click above or
below the box to move forward or backwards one page in the document.

About the Menus

The WebMagic menu bar contains five menus. Click a menu name below for detailed
information.

• “The File Menu”

• “The Edit Menu”

• “The Element Menu”

• “The View Menu”

• “The Help Menu”

The File Menu

The File menu contains these choices:

• New: Opens a new WebMagic window and presents a blank page.

• Open: Presents a dialog box for opening existing files; see “Opening a Document”
in Chapter 1.

• Open Template: Presents a dialog box for opening a document to be used as a
template; see “Opening an Existing Document as a Template” in Chapter 1.

• Re-open: Reverts to the previously saved version of the file.

• Insert: Presents a rollover menu from which you can choose to insert an image,
HTML, or text document; see “Importing Text, HTML, RTF, and Image Files” in
Chapter 1.

• Save: Saves the document as it’s displayed in the WebMagic window. The first time
you choose Save, a dialog prompts you for a filename; see “Saving Changes” in
Chapter 1.

• Save as: Presents a dialog in which you enter a new filename; see “Saving Changes”
in Chapter 1.
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• Publish: Presents a dialog in which you can change URL translations; see “About
Publishing and URLs” in Chapter 1.

• Preview: Runs the HTML browser and displays the document you are currently
editing. Lets you preview your document and test links you’ve created.

If you’re modifying files that you link to, you may notice that Netscape displays an
outdated version of those file. If this happens, press Netscape’s Reload button.

• Print: Presents a dialog from which you can print the document; see “Printing a
Document” in Chapter 1.

• Preferences: Presents a dialog in which you can save general and publishing
preferences; see “Setting WebMagic Authoring Preferences” in Chapter 1.

• Close: Closes that document but leaves other WebMagic documents open.

• Exit: Stops WebMagic from running and closes all open documents.

The Edit Menu

The Edit menu contains these choices:

• Undo: Lets you undo the changes you make. For example, suppose you change the
appearance of a horizontal rule. Choose “Undo” and the horizontal rule reverts to
its original state.

You can undo multiple actions.

• Redo: Works with the “Undo” command. For example, suppose you make a
horizontal rule thicker. Choose “Undo” and the rule becomes thin again; choose
“Redo” and the rule becomes thicker again.

• Cut: Select an item and choose “Cut” to remove the item from the WebMagic
window and place it in the cut buffer so it is available for future pasting.

• Copy: Select an item and choose “Copy” to place a copy of the item in the buffer so
it is available for future pasting.

• Paste: Position the text entry cursor and choose “Paste” to place the current contents
of the cut buffer at the cursor location.

• Copy Link: Select an item that has an associated link, then choose “Copy Link.” The
link information is copied; use the “Paste Link” command to apply it to another
item, thereby creating a link.

• Paste Link: Works with the “Copy Link” command. Lets you copy link information
and apply it to another item.
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• Delete: Select an item and choose “Delete” to remove the item from the WebMagic
window; this does not place it in the cut buffer.

• Select All: Selects all the items in the currently displayed document.

• Find/Change...: Opens a dialog box you can use to find and replace text strings in
your document. See also “Finding and Changing Text” in Chapter 1.

The Format Menu

The Format menu contains these choices:

• Character: Presents a rollover menu of character tags. These tags attach visual
characteristics to the text. You can make the selected text bold, italic, in a fixed font,
or underlined. You can also place a line (strike) through the selected text and you
can make it blink. To see the text blink, choose “Preview” from the File menu.

• Size: Presents a rollover menu with options for changing the size of selected text.
“1” is the smallest font size; “7” is the largest size. These options are identical to
those offered on the font size menu button.

• Style: Presents a rollover menu that lists preset character styles. You use these styles
to categorize the selected text as an identifiable document element (such as a a
document citation or keyboard input). These options are identical to those offered
on the character style menu button.

• Justify: Lets you align a paragraph with the left or right margin or center it on the
page. Choosing “Left,” “Center,” or “Right” is equivalent to clicking on the
alignment buttons in the toolbar.

• Paragraph: Presents a rollover menu that lists the available paragraph tags. Your
options are:

– Body: A traditional text paragraph.

– Bulleted List: An unordered list; each item is preceded by a bullet or other
character.

– Numbered List: An ordered list; each item is preceded by a numeral which
increases by one with each item.

– Menu List: An unordered list; each item appears on its own line.

– Directory List: An unordered list; each item must contain 20 characters or less.
Many viewers arrange directory lists in columns.
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– Descriptive Title: A title for the paragraphs to follow that are marked as
Descriptive Data.

– Descriptive Data: A paragraph or group of paragraphs preceded by a
Descriptive Title.

– Preformatted: Presents sections in a fixed-width font.

– Block Quote: A body of information that may be displayed in such a way to
indicate that it is a quote. For example, many viewers indent it slightly on both
the right and left sides.

– Address: Information that describes how to contact an individual or
organization.

– Heading 1-6: A heading introduces and titles a new section of information.
WebMagic automatically inserts a line break before and after each heading.

• Indent List: Click in a list item and choose this item to nest the item; see “Creating
and Nesting Lists” in Chapter 1. This is identical to clicking the Indent button.

• Outdent List: Click in a list item and choose this item to undo the nesting of the
item; see “Creating and Nesting Lists” in Chapter 1. This is identical to clicking the
Outdent button.

• Join Paragraphs: Select multiple paragraphs and choose this item to combine them
into one.

The Element Menu

The Element menu contains these choices:

• Line Break: Choose this item to start a new line; this choice is identical to clicking
the Line Break button.

• Break Clear: If you’ve set up an image so that text flows on the left or right side of it,
and you want to insert a line break, you may want to use the “Break Clear”
command also. By default, if you insert a line break, the new line of text appears
directly below the original line. “Break Clear” lets you start the next line when the
specified margin is clear.

To see the effects of this command, choose “Preview” from the File menu.

• Horizontal Rule: Choose this item to insert a line break and a horizontal line; this is
identical to clicking the Horizontal Rule button.
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• Horizontal Rule Attributes...: Opens a dialog box you use to change the appearance
of the selected horizontal rule. You can change the width, height, and shading of the
rule.

• Link...: Select some text, an image, or a hotspot on an image, then choose “Link...”
The Create Link window appears. Use this window to specify the destination of the
link. This is identical to clicking the Link button. See also “Creating and Editing
Links” in Chapter 1.

• Unlink: Select an item that has an associated link, then choose “Unlink.” The link is
removed.

• Target (Anchor)...: Select some text and choose “Target (Anchor)...” to see a window
in which you can name the target; see “Creating a Link Target” in Chapter 1. This is
identical to clicking the Target icon button.

• Image Alignment: Select an image, then choose “Top”, “Middle”, “Bottom,” “Left,”
or “Right” from this menu to specify the alignment of the image to the rest of the
text in that paragraph.

• Image Attributes...: Select an image, then choose “Image Attributes...” to resize an
image, change its alignment, specify alternate text, and more. See also “The Image
Attributes Window.”

• Image Map...: Lets you attach links to areas of an image. See also “Attaching
Hypertext Links to Areas of an Image” in Chapter 1.

• Form...: Lets you create a form in your HTML document. Typically, forms are used
to gather information or submit requests. See also “Including Forms in a Web
Document” in Chapter 1.

• Background/Text Colors...: Lets you change the color of the background, all the text
in the document, and that of links.

• Markup: When a question mark icon appears in the WebMagic window, it’s
indicating that WebMagic does not interpret that markup. Select the question mark
and choose “Markup” to see a window in which you can edit that HTML markup.

You also use this command if you want to use an HTML capability that WebMagic
does not provide. See “Entering Raw HTML Markup” in Chapter 1.
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The View Menu

The View menu contains these choices:

• Symbols: Choose this item to place or remove a checkmark. When the checkmark is
present, WebMagic displays editing symbols.

• Targets: Choose this item to place or remove a checkmark. When the checkmark is
present, WebMagic displays the target icon at the beginning of each line that
contains a target.

• Text Colors: Choose this item to place or remove a checkmark. When the checkmark
is present, WebMagic displays text in the color you have specified. If the checkmark
is absent, the text appears black.

• Backgrounds: Choose this item to place or remove a checkmark. When the
checkmark is present, WebMagic displays background images or colors. Otherwise,
WebMagic displays a gray background.

• Image Maps: Choose this item to place or remove a checkmark. When the
checkmark is present, WebMagic identifies image map hotspots with a dashed line.

• Form Bounds: Choose this item to place or remove a checkmark. When the
checkmark is present, WebMagic identifies a form area by displaying a thin line
along the left margin.

• Document Title: Choose this item to place or remove a checkmark. When the
checkmark is present, WebMagic displays the Document Title field in the upper
portion of the window. When the checkmark is absent, the field is hidden.

• Toolbar: Choose this item to place or remove a checkmark. When the checkmark is
present, WebMagic displays a toolbar in the upper portion of the window. The
toolbar contains buttons for many of the commands on the Format menu. When the
checkmark is absent, the toolbar is hidden.

The Help Menu

The Help menu contains these choices:

• Click for Help: Choose this item to turn your cursor to a question mark, then
position the cursor over any area in the WebMagic window for context-sensitive
help.

• Overview: Choose this item for an overview of WebMagic.

• WebMagic Web Page: Displays a web page with information on WebMagic.



68

Chapter 2: WebMagic Reference

• Task-Oriented Topics: Choose an item for step-by-step information on how to
complete a task.

About the Menu Buttons in the Toolbar

The main WebMagic window includes three unlabeled menu buttons. The upper menu
button is the paragraph markup button; the menu button directly below this is the character
tag button. The remaining menu button is the font size button. Click the name of the menu
button about which you want information.

• “The Paragraph Markup Menu Button”

• “The Character Style Menu Button”

• “The Font Size Menu Button”

The Paragraph Markup Menu Button

The items in this menu button let you apply structure to a paragraph (see also “Applying
Structure to a Paragraph” in Chapter 1). Position your cursor in the paragraph to which
you want to apply a structure, then choose an item from the menu button. For easy access
to the menu choices, choose the dashed horizontal line in this menu button; this places
the entire menu in a separate window.

For more information on lists, see “Creating and Nesting Lists” in Chapter 1.

The paragraph markup menu button contains these structures:

• Body: A traditional text paragraph.

• Bulleted List: An unordered list; each item is preceded by a bullet or other character.

• Numbered List: An ordered list; each item is preceded by a numeral which
increases by one with each item.

• Menu List: An unordered list; each item appears on its own line.

• Directory List: An unordered list; each item must contain 20 characters or less.
Many viewers arrange directory lists in columns.

• Descriptive Title: A title for the paragraphs to follow that are marked as Descriptive
Data.

• Descriptive Data: A paragraph or group of paragraphs preceded by a Descriptive
Title.
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• Preformatted: Presents sections in a fixed-width font.

• Block Quote: A body of information that may be displayed in such a way to indicate
that it is a quote. For example, many viewers indent it slightly on both the right and
left sides.

• Address: Information that describes how to contact an individual or organization.

• Heading 1-6: A heading introduces and titles a new section of information.
WebMagic automatically inserts a line break before and after each heading.

The Character Style Menu Button

The items in this menu button let you apply character tags to text (see also “Changing
Font Styles” in Chapter 1). Select the text that you want to tag, then choose an item from
the menu button. For easy access to the menu choices, choose the dashed horizontal line
in this menu button; this places the entire menu in a separate window.

The character style menu button contains these tags:

• No Style: The font in which all traditional paragraphs (body paragraphs) will be
displayed. A common choice of many viewers is Times or Helvetica.

• Citation: A font that indicates that the tagged characters are a citation to another
source.

• Code: A font (typically fixed-width) that indicates that the tagged characters
represent programming code.

• Define: A font (often italics) that indicates that the tagged characters are a definition
of a word or phrase.

• Emphasis: A font that makes the tagged characters stand out from the default font.

• Keyboard: A font that indicates that the tagged characters are those that a user may
enter at a keyboard.

• Sample: A font that indicates that the tagged characters are a sample (or example) of
a previously described item.

• Strong: This may be a different font family and weight from the default font,
depending on the viewer. The resulting font will stand out from the default font.

• Variable: A font that indicates that the tagged characters are not the literal
characters that a user should enter; rather the characters describe the type of thing a
user should enter (e.g., a common variable is filename).
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The Font Size Menu Button

The items in this menu button let you make selected text smaller or larger. “1” is the
smallest font size; “7” is the largest font size.

About the Icon Buttons in the Toolbar

This window also includes a collection of icon buttons. The upper row contains a cluster
of five buttons and a cluster of four buttons, arranged from left to right in this order:

• “The Left Align Button”

• “The Center Button”

• “The Right Align Button”

• “The Indent Button”

• “The Outdent Button”

• “The Link Button”

• “The Target Button”

• “The Line Break Button”

• “The Horizontal Rule Button”

• “The Bold Button”

• “The Italic Button”

• “The Fixed Font Button”

• “The Underline Button”

• “The Strike Button”

The Left Align Button

Click this button to align the selected paragraph with the left edge of the page. The text
and any forms or images in the paragraph are repositioned.
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The Center Button

Click this button to center the selected paragraph on the page. The text and any forms or
images in the paragraph are repositioned.

The Right Align Button

Click this button to align the selected paragraph with the right edge of the page. The text
and any forms or images in the paragraph are repositioned.

The Indent Button

Click in a list item and click this button to nest the item; see “Creating and Nesting Lists”
in Chapter 1. This is identical to choosing “Indent List” from the Format menu.

The Outdent Button

Click in a list item and click this button to undo the nesting of the item; see “Creating and
Nesting Lists” in Chapter 1. This is identical to choosing “Outdent List” from the Format
menu.

The Link Button

Select some text, an image, or a hotspot on an image and click the Link button to see a
window in which you can create a link from that text to a target; see “Creating and
Editing Links” in Chapter 1. This is identical to choosing “Link...” from the Element
menu.

The Target Button

Select some text and click the Target button to see a window in which you can name the
target; see “Creating a Link Target” in Chapter 1. This is identical to choosing “Target
(Anchor)...” from the Element menu.



72

Chapter 2: WebMagic Reference

The Line Break Button

Click this button to start a new line; this is identical to choosing “Line Break” from the
Element menu

The Horizontal Rule Button

Click this button to insert a line break and a horizontal line; this is identical to choosing
“Horizontal Rule” from the Element menu.

The Bold Button

Click this button to make the selected text bold. This is identical to choosing “Bold” from
the Character rollover on the Format menu.

The Italic Button

Click this button to italicize the selected text. This is identical to choosing “Italic” from
the Character rollover on the Format menu.

The Fixed Font Button

Click this button to use a fixed width font for the selected text. This is identical to
choosing “Typewriter” from the Character rollover on the Format menu.

The Underline Button

Click this button to underline the selected text. This is identical to choosing “Underline”
from the Character rollover on the Format menu.

The Strike Button

Click this button to place a line through the middle of the selected text. This is identical
to choosing “Strike” from the Character rollover on the Format menu.
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The Document Title Area

WebMagic lets you give your document a title that’s different from the name of the
HTML file in which your document is stored. Place the cursor in the Document Title field,
then type a title. If the Document Title field is not visible, choose “Document Title” from
the View menu.

The Form Tool

Web documents let you deliver information to other people on the Internet. In addition,
you can include a form in your Web document to gather information from other people.
This section provides a brief overview of the Form tool. See “Including Forms in a Web
Document” in Chapter 1 for complete instructions.

You begin creating a form by clicking one of the eight buttons along the left edge of the
Form tool. Each button lets you add a particular type of item to the form. You can add:
fill-in text fields, scrolling text areas, radio buttons, checkboxes, scrolling selection lists,
menu buttons, hidden fields, and buttons.

The controls on the right side of the window let you define the characteristics of an item.
For instance, suppose you add a scrolling selection list. Use the controls on the right to
specify the size of the scrolling list and what text appears in the list.

This tool lets you design the form. To make the form functional, you need to write a
program called a cgi-bin script. You cannot create the script using WebMagic. Click the Script
button when you’re ready to attach the script to the form.

The Image Map Tool

Just as you can select a string of text and turn it into a hypertext link, you can select areas
of an image and attach links to them. This combination—an image, its hotspots, and its
links—is called an image map. This section describes the Image Map tool.

The Selection and Insertion Tools

The left edge of the Image Map window contains two buttons. One button depicts an
arrow; the other depicts a text insertion cursor. When the text insertion cursor is selected,
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you’re able to work with the text, forms, and images on the page. When the arrow is
selected, you’re able to select and manipulate hotspots on an image.

The Drawing Tools

The Image Map window provides you with three drawing tools: a rectangle tool, a circle
tool, and a polygon tool. Use these to mark off the region of the image to which you want
to attach a link.

The Link Button

The Link button resembles a lightning bolt. Select a hotspot, then click this button to
establish the link.

The Layer Buttons

If two hotspots overlap, you need to specify which link is followed when the user clicks
in that region. Select one of the hotspots, then pop it to the top or push it to the bottom.
This doesn’t change the display; it determines which link is followed when a user clicks
in the overlapping region.

The File Menu on the Image Map Tool

WebMagic uses a map file to store information about an image and its links. This file
specifies the location and size of the hotspots, as well as the link behavior. By default,
when you start creating hotspots, WebMagic automatically creates a map file. You use
commands on the File menu to open and save these files.

“Use Map File...:”
Lets you apply an existing map file to your image. For example, suppose
you want to use the same image and hotspots in two documents. You
can insert the image, then open the map file. Any hotspots you’ve
already placed on the image are removed.

If you create new hotspots, delete hotspots, or edit existing links, be
aware that you’re altering the original file. The changes you make
appear in all documents that use that map file.
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“Insert from Map File...”
Lets you add hotspots from an existing map file to the selected image.

“Save Map File”
WebMagic automatically saves the map file along with your document.

“Save Map File As...”
When you start creating hotspots for an image, WebMagic automatically
creates a map file and gives it a unique name. Use the “Save Map File
As...” command if you want to change the name or save an extra copy.

“Remove Map from Image”
Removes all of the hotspots from an image and deletes the reference to
the map file.

The Image Attributes Window

To open the Image Attributes window, select an image, then choose “Image Attributes...”
from the Element menu. You can use its controls resize an image, change its placement
on the page, and more.

• The Image Source field shows the pathname of the selected image. To replace the
selected image, specify a new image name in this field.

• The Alternate Text field displays the text you want to display on systems that can’t
display the image.

• The Width and Height fields let you resize the image. Use the associated menu
buttons to specify whether you want the measurement in pixels or percentages.
Enter a percentage if you want to specify how much of the page the image should
occupy. See also “Resizing Images” in Chapter 1.

• Border, Vertical Space, and Horizontal Space let you create space around an image. Set
a border size to leave a specified amount of white space around the entire image.
Specify horizontal or vertical space to leave a certain amount of blank space
between the image and other items on the page.

• The Default Values button lets you return to the original size and spacing for an
image. Click the Default Values button, then click Apply or OK.

• The Image Alignment choices let you specify how to align the image with the
surrounding text.

• Choose “Top” to align the top of the image with the text.
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• Click “Middle” to align the middle of the image with the text.

• Click “Bottom” to align the bottom of the image with the text.

• Click “Left” to have the image appear on the left side of the page. The text flows
along the right side. WebMagic does not display this; choose “Preview” to view
the change.

• Click “Right” to have the image appear on the right side of the page. The text
flows along the left side. WebMagic does not display this; choose “Preview” to
view the change.

The Background/Text Color Tool

To open the Background/Text Color tool, choose “Background/Text Colors...” from the
Element menu.

The top portion of the window lets you choose an image to place on the page
background. Type an image name in the available text field or click the Browse... button
then use the file browser that appears. The lower portion of the window lets you change
the color of various items.

• Click Background to change the color of the page background.

• Click Text to change the color of all the text in the document.

• Click Link, Visited, or Activated to change the way links appear in the HTML
browser. By default, links appear blue. While you’re in the midst of following a link,
the color changes to red. Once you’ve followed a link, the color changes to purple.

To select a new color, you can use the color wheel or the red, green, and blue sliders. To
make a color lighter or darker, adjust the Value slider. A value setting of 0 produces the
color black; a value setting of 100 results in the brightest shade of that color. To return to
the original color, click Default.
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The Insert Text Dialog Box

The Insert Text dialog box appears when you insert an ASCII text file into your
document. Use it to specify how you want to treat line breaks. Your options are:

• Merge the lines into a paragraph. Only create a new paragraph when you encounter
a blank line.

• Treat each line as a separate paragraph.

• Convert the lines of text into a table. See “Converting Text Files into Tables” in
Chapter 1.

The Insert Table Dialog Box

The Insert Table dialog box lets you format an ASCII text file as a table. It appears when
you insert a text file and choose “Convert to Table...” from the dialog box that appears.
“Converting Text Files into Tables” in Chapter 1 provides step-by-step instructions. This
section provides a brief overview of the dialog box.

You use this dialog box to specify two things:

• how you want WebMagic to interpret line breaks in your text file

If each line in your text file contains one item, you want to treat each line ending as
a cell. In this case, you need to specify how many columns should appear in your
table.

If each line in your text file contains multiple items and you’ve separated them into
columns with tabs, spaces, or some other character, you want to treat each line as a
row.

• the visual characteristics of the table

You can place a border around the table and you can specify how much space
should appear around each item.

The Create Link Window

The topmost item in the window is a menu button labeled Type. This lets you specify how
the link is presented. External means users must click on a particular text string or area of
an image to follow the link. Inline is valid with images only. It means the image appears



78

Chapter 2: WebMagic Reference

on the HTML page, even though the image resides in a separate image file. This menu
button is set based on the way you’ve opened the Create Link window. For instance, if
this window appears while you’re inserting an image, the menu button is set to Inline.

The rest of the window varies depending on the link type. If you’re creating an inline
image link, the window displays controls for specifying the image name, its size, the way
its aligned, and more. See also “The Image Attributes Window.” If you’re creating a link
to another type of file, the window displays controls for specifying the destination of the
link. These controls are discussed in the following sections:

• “Creating a Link to Other HTML Documents” in Chapter 1

• “Creating a Link to Remote HTML Documents” in Chapter 1

• “Creating a Link to Other Types of Files” in Chapter 1

• “Creating a Link to a Specific Location within an HTML Document” in Chapter 1

• “Creating a Link Target” in Chapter 1

The Horizontal Rule Attributes Dialog Box

You can change the appearance of a horizontal line by selecting it, then choosing
“Horizontal Rule Attributes...” from the Element menu.

• To make the line wider or narrower, enter a number in the Width field. Use the menu
button to specify whether you want the measurement to be in pixels or a
percentage.

• To make the line thicker or thinner, enter a number in the Height field. Use the menu
button to specify whether you want the measurement to be in pixels or a
percentage.

• By default, the horizontal rule is shaded. To make the line solid black, click Shaded
Line. The checkmark disappears, indicating it’s not selected.

• To restore the default values, click the Default Values button.

When you’re ready to make the changes, click the Apply button or the OK button. When
you click Apply, the rule is changed and the Attributes window stays open. When you
click OK, the rule is changed and the window is closed.
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Using the WebMagic File Browser

You use the file browser in several situations—when you open or save a file, when you
insert a file, when you choose an image to place on the page background, and more. This
section provides general instructions for using the browser.

The top port of the browser is labeled Files. It shows all files and directories that are
contained in the directory whose full pathname is shown in the middle of the window.

• To open a file listed in this area, double-click its name or click its name, then click
the OK button.

• To look in a subdirectory, double-click the directory name (directory names end in
/) in the Files area.

• To look in a completely different area of the filesystem, type a different pathname in
the type-in field, then press <Enter>.

• To restrict your view of files in a particular directory, click the Filter button.

• In the Filter window that appears, enter a string and wildcard character (for
example, *.html), then click the Apply or OK button. Only those files that fit your
match criteria appear in the Files area.

The Right Mouse Button Pop-up Menu

Place the cursor over the page, then press the right mouse button to display a pop-up
menu of commonly used commands.
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4Dwm

The name of the default Window Manager. See also Window Manager.

account

See login account.

active window

The only window that recognizes input (activity) from the keyboard and mouse; only
one window is active at a time. Make a window active by placing the cursor within its
boundaries.

Administrator

The person who can use the most privileged account, root. This person must have his
own personal login account for daily use, but, when there are serious system problems
to correct, the person logs in to the root account to change system information using the
graphical tools or using the IRIX shell.
The Administrator has all the capabilities of a Privileged User, plus the capability to
change information in the root account (such as the password) and to log in to an IRIX
shell as root. Because there is only one root account, there is only one Administrator per
system. The Information Panel for a particular system includes the name of the system’s
Administrator so other users know who to contact for help.

ASCII text

An ASCII file contains text only. When you save a file as ASCII text, you save only the
characters, not the size, the font, the style, the color, or the format.

autologin user

The user who is automatically logged in to the system each time it is powered up. You
specify an autologin user in the Login Setup tool.
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automount

An NFS utility that lets you share directories with other systems as if the directory
resided on your own disk. When automount is turned on, you can drag a directory icon
from the Shared Resources area of another system’s System Manager window onto your
own desktop.

back up

To copy a certain set of files and directories from your hard disk to a tape or other storage
media.

backup tape

A tape that contains a copy of a set of files and directories that are on your hard disk. A
full backup tape contains a copy of all files and directories, including IRIX, that are on
your hard disk.

baud rate

The speed (calculated as bits per second) at which the system sends information to a
serial device, such as a modem or a terminal.

borderless window

A window with no title bar or borders.

business card

When you double-click a person’s icon in the desktop, you see a business card that
displays public information about the person. The information on the business card is
drawn from the person’s User Information window in the Users and Groups tool.

business card information

Business card information appears in the top portion of a person’s User Information
window in the Users and Groups tool; it includes a picture of the person and contact
information about the person. Usually this information is the same for every account that
belongs to a particular person.

button

On a mouse, a button is a switch that you press with a finger. In a window on your screen,
a button is a labeled rectangle that you click using the cursor and mouse.
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CD-ROM disk (CD)

A flat metallic disk that contains information that you can view and copy onto your own
hard disk; you cannot change or add to its information. CD-ROM is short for
compact-disk: read-only memory.

centralized network

A network where a central server controls services and information; the server is
maintained by one or more individuals called network administrators. On a centralized
network that uses NIS, this server is called the NIS master, and all other systems on the
network are called NIS clients. See also network administrator, NIS, NIS client, NIS domain,
and NIS master.

character tag

To mark a text string in a way that either attaches visual characteristics to the text (such
as boldface type), or categorizes it as an identifiable document element (such as a a
document citation). Tagging text strings in this way allows HTML viewers to identify the
strings and to display them appropriately.

choose

To press the left mouse button to bring up a pop-up menu, move the cursor to highlight
the command that you want to run, then release the button.

click

To hold the mouse still, then press and immediately release a mouse button.

command line option

Options that let you specify how you want to run an IRIX command. See the man page
for a command for a list of the available command line options.

confidence test

A test that you run to make sure a particular device (such as the keyboard, mouse, or a
drive) is set up and working properly.

configuration file

A system file that you change to customize the way your system behaves. Such files are
sometimes referred to as customization files.
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console

The window that appears as a stowed icon each time you log in; IRIX reports
 status and error messages to this window.

CPU

The CPU (Central Processing Unit) is the chip that processes data. Depending on the type
and version of a CPU, the system will run at different speeds.

current working directory

The directory within the file system in which you are currently located when you are
working in a shell window.

cursor

The small red arrow on the screen that echoes the movements of the mouse. It changes
shape depending on its location on the screen.

daisy-chain

A series of SCSI devices that are connected to each other, with one device connected to
the SCSI port on a system.

DAT

A magnetic tape from which you can read and to which you can copy audio and digital
information.

default printer

The printer to which the system directs a print request if you do not specify a printer
when you make the request. You set the default printer using the Printer Manager.

default subsystems

Portions of a product that will be installed automatically if you do not customize a
product installation.

defaults

A set of behaviors that Silicon Graphics, Inc. specifies on every system. You can later
change these specifications, which range from how your screen looks to what type of
drive you want to use to install new software. For example, when you run IRIS
Showcase, the Master gizmo opens by default You can change the default settings using
the Preferences gizmo.
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delete

To permanently remove an object from an IRIS Showcase page. You can’t retrieve objects
you delete by choosing Paste.

desk

The collection of windows and icons that appears on your computer screen. You can
create multiple desks and switch between them. When you switch from one desk to
another, the screen changes, almost as if you had several different monitors.

desktop

The screen background. By default, several icons are placed on the desktop: a folder icon
representing your home directory, a dumpster icon, several application icons, and an
icon for each peripheral you have installed. You can place other icons on the desktop so
that you can access them more easily.

directoryserver

The tool that maintains an accurate list of all network systems, users, and peripherals; it
runs on the network master system. When you search for one of these resources on your
network, your system contacts the directoryserver to find the information.

Directory View window

The window you see when you open a folder (directory) icon. It displays the files,
folders, and applications that the directory contains.

disk directory

A directory that represents an entire disk or a partition of a disk. When you open a disk
directory, you view the contents of the disk.

disk use

The percentage of space on your disk that contains information.

distributed network

A network where there is no automated central control of services or information. Each
system’s administrator must work with the network administrator to keep each system’s
network information up to date.
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distribution directory

A directory that contains software that can be installed using Software Manager or inst.
Typically this directory is copied from a CD into a directory on a server system so users
can install software across the network from a directory rather than from a CD.

domain

A group of hosts on a network whose hostnames have the same suffix. See also NIS
domain.

domain name

The common suffix found in all hostnames that are in the same domain on a network. See
also NIS domain.

double-click

To hold the mouse still, then press and release it twice, very rapidly. When you
double-click an icon it opens into a window; when you double-click the Window menu
button the window closes.

downgrade products

The Software Manager considers a product to be a downgrade when the product is
available for installation, and is an older version of a product that is currently installed
on the system on which Software Manager is running.

drag

To press and hold down a mouse button, then move the mouse. This drags the cursor to
move icons or to highlight menu items.

drive

A hardware device that lets you access information on various forms of media, such as
hard, floppy, and CD-ROM disks, and magnetic tapes.

drive address number

The unique number that identifies each drive (such as hard, floppy, and CD-ROM drives)
to the system. See also SCSI address.

drive controller number

The unique number that identifies each controller (a board that controls the flow of
information from the system to a drive) to the system. See also SCSI controller.
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drop pocket

A drop pocket is the small blue square into which you can drop icons. You can drag a
folder icon and place it into the drop pocket on a Directory View window. The window
displays the contents of that folder.
You can also drag a file or application icon and place it in the drop pocket on a Directory
View window. The window displays the contents of the directory in which that icon is
stored.
As a final example, you can drag an IRIS Showcase icon and drop it into a drop pocket
on the Search Catalog to specify the type of files you want to find—in this case, IRIS
Showcase files.

dumpster

A temporary holding place for icons that you remove using the “Remove” command. To
retrieve files from the dumpster, double-click the dumpster icon; to empty the dumpster,
choose “Empty Dumpster” from the Desktop toolchest.

electronic mail

A utility that lets users on a network send messages from one system to another.

electronic mail address

Your login name plus location information so you can receive electronic mail. The
address is usually assigned by the network administrator.

Ethernet cable

The cable that connects your system to a network that runs TCP/IP.

Ethernet port

The outlet on your system to which you can connect an Ethernet cable. This connection
lets you communicate on a network that runs TCP/IP.

external link

 Lets you go to a different location (target) in the current HTML document or to a specific
location in a different document. The user must explicitly follow the link (usually by
clicking on it) to reach the target location.

field

An area in a window in which you can type text.
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file

A container in which you store information such as text, programs, or images you create
using an application.

file hierarchy

See filesystem.

filesystem

A hierarchy of directories and files. Directories contain other directories and files; files
cannot contain directories. The root (/) directory is at the top of the hierarchy.

form

A window that contains buttons that you must click and/or editable fields that you must
fill in.

FPU

A hardware chip inside the system that speeds up calculations that use floating point
numbers. FPU stand for Floating Point Unit.

full name

A person’s actual name, as the person would like it to appear on a business card.

global desk

The desk to place windows on if you want them to automatically appear on all of your
desks.

group

A collection of login names. Members of a group can make file permissions apply to all
other members of a group. You create and modify groups using the Users and Groups
tool.

handshake

The protocol that controls the flow of information between a system and a printer. A
hardware handshake uses only cable wires and pins to control the flow. A software
handshake (also called xon/xoff flow control) uses a combination of pins, wires, and
software.
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home directory

A directory in which you create and store your work. Usually, the home directory is
named /usr/people/loginname, where loginname is the name of your login account. A folder
icon for your home directory appears on the desktop by default.

home page

An HTML document that is the primary or index document that represents an individual
or a larger entity, such as a company.

host

Any system connected to the network.

hostname

The name that uniquely identifies each host (system) on the network.

HTML

An acronym for Hyper Text Markup Language, the standard markup language in use on
the World Wide Web. When you author a document using HTML, it can be viewed by
any browser or player on the Web.

HTML browser

An application such as Netscape that you use to traverse various links in documents on
the Web.

HTML player

An application that you use to traverse links in documents on the Web in a route that was
pre-determined by the documents’ author(s).

icon

A small picture that represents a stowed or closed file, directory, application, or IRIX
process.

icon finder

The area of a window that contains the drop pocket, the pathname field, the path bar, and
the recycle button. You use these fixtures to move from one directory to another.
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image

A logical grouping of the parts that make up an installable product; see also product, and
subsystem.

incompatible products

One or more software products that cannot be installed on a system at the same time. For
example, a product that runs on version 3 or higher of the operating system is
incompatible with version 2 of the operating system.

inline image link

Displays an image on an HTML page without actually storing the image in the HTML
file. The image resides in a separate image file, and the HTML document stores only the
file’s location in the filesystem. The image is displayed automatically; the user doesn’t
need to explicitly follow a link to view the image. WebMagic can display only JPEG and
GIF images as inline images.

input focus

Only one window at a time recognizes mouse movement and typing. The window that
does is said to have the input focus.

inst

The software tool that you use to install system software, software options, and
maintenance releases that come from Silicon Graphics, Inc. It is the command-line
version of Software Manager.

installation conflicts

The Software Manager and inst report these when you select a combination of software
for installation or removal that cannot be safely installed or removed. The installation
tool gives you choices for resolving the conflicts to complete the installation.

installed products

Products that are currently installed on your system.

IP address

The number that uniquely identifies each system on the network.

IRIS

Any graphics workstation manufactured by Silicon Graphics, Inc.
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IRIX

Silicon Graphics, Inc.’s version of the UNIX operating system. See also system software.

IRIX processes

Tasks that IRIX carries out to keep the system running correctly or to complete an explicit
command. Each process has a unique process ID number.

Kb (Kilobyte)

A standard unit for measuring the information storage capacity of disks and memory
(RAM and ROM); 1000 bytes make one Kilobyte.

launch icon

An arrow-shaped icon that appears in the right margin of the IRIS InSight viewer and the
Help viewer. Double-click this icon to run an application.

linked copy

A pointer to a file or directory that exists in a different location in the file system. When
you make a linked copy of a file, you are not creating another instance of the file; you are
creating another location from which you can access the original file.

local workstation, drive, disk, filesystem, or printer

The physical workstation whose keyboard and mouse you are using, all hardware that is
connected to that workstation, and all software that resides on that hardware or its
removable media.

log in

To give the system your login name so you can start a session on the IRIS.

log out

To end a session on the IRIS.

logical swap space

Actual disk space that the system uses as if it were memory (RAM). By default, your
system allocates 40 MB of your disk in the /dev/swap file.
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login account

A collection of information about a person who can log in to the system. The information
includes the person’s full name, login name, contact information, and the name of a
home directory in which the person can store directories and files.

login name

A short version of your own name or your initials; you type it to log in to the system, and
the system uses it to label files that belong to you. If your system is on a network, the
network administrator usually must approve of the name to make sure it is unique.

login screen

The window that you see after powering on the system, before you can access files and
directories. The window contains one icon for each login account on the system.

lpr

Printing software that lets you access a printer that’s connected to a system that runs the
BSD version of UNIX.

Mb (Megabyte)

A standard unit for measuring the information storage capacity of disks and memory
(RAM and ROM); 1000 Kilobytes make one Megabyte.

man page

Reference information about UNIX commands. You can view man pages by choosing
“Man Pages” from the Help toolchest.

menu

A list of operations or commands that the IRIS can carry out on various objects on the
screen.

menu button

A button that reveals a pop-up menu. Place the cursor over the button; then press the left
mouse button.

mount

To make a file system that is stored on a local or remote disk resource accessible from a
specific directory on your workstation.
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mount point

The directory on your workstation from which you access information that is stored on
a local or remote disk resource.

mouse

A hardware device that you use to communicate with windows and icons. You move the
mouse to move the cursor on the screen, and you press its buttons to initiate operations.
An optical mouse must always be on the mouse pad for the IRIS to interpret its
movements; a mechanical mouse works on any clean, flat surface.

mouse pad

For an optical mouse, this is the rectangular, metallic surface that reads the movements
of the mouse. For a mechanical mouse, this is a clean, soft rectangular surface that makes
the mouse’s trackball roll efficiently.

multi-tasking system

A system that can run several processes (such as running applications, printing files, and
updating files) simultaneously.

multiuser system

A system that several users can work on simultaneously and maintain private files.

netmask

An addressing scheme that creates a logical grouping of a subset of systems on your
network.

network

A group of computers and other devices (such as printers) that can all communicate with
each other electronically to transfer and share information.

Network Access account

A person who has a Network Access account on a system can log in to the system only
when the network and the optional NIS software are running properly. The information
in a Network Access account is entered by the network administrator on the NIS master
system. Privileged Users on other systems on the network cannot change any business
card information about a Network Access account.
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network administrator

The network administrator is the person who maintains a network of systems. If the
network runs the optional NIS software, the network administrator maintains the master
database of login account information.

new products

The Software Manager considers a product to be new when the product is available for
installation, has never been installed on the system on which Software Manager is
running, and has never been available during a previous installation session.

NFS

A networking software option that lets you access files and directories that reside on the
disks of other workstations as if they resided on a local disk in your own workstation.
NFS stands for Network File System.

NIS

A networking software option that lets you control network information and services
from a central server called the NIS master. NIS stands for Network Information Service.
See also centralized network, NIS client, NIS domain, and NIS master.

NIS client

Any system on a centralized network that runs NIS other than the NIS master. The NIS
client receives services and information from the NIS master.

NIS domain name

The unique name of a network (or sub-network) that runs NIS. All hostnames in the NIS
domain have the NIS domain name as their suffix.

NIS master

The server that stores the complete database of information about all the hosts (systems)
and users on a centralized NIS network. The NIS master periodically updates host
information on all other systems on the network (NIS clients); its user information is
always available to every host. The network administrator is responsible for setting up,
maintaining, and troubleshooting the NIS master.

not installed products

The Software Manager considers a product to be ’not installed’ when the product has
been previously available for installation, but has never been installed on the system.
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notifier

A form that appears when the system requires you to confirm an operation that you just
requested, or when an error occurs.

objectserver

The tool that tracks users and peripherals on your system, and sends the information to
the network master system’s directoryserver. The directoryserver maintains an accurate
list of all network systems, users, and peripherals. When you search for one of these
resources on your network, your system contacts the directoryserver to find the
information.

open

To double-click an icon, or to select an icon then choose “Open” from a menu in order to
display a window that contains the information that the icon represents.

owner

The user who created a particular file or directory and can specify which other users of
the system can access the file.

pane

A distinct region within a window. Usually you can choose to display all or some panes.

paragraph markup

To assign structural characteristics to a text paragraph. For example, many documents
include headings (short text strings that introduce a new section) and body text (the
content that appears within a section).

parent directory

A relative term that refers to a directory that contains another directory. If directory A
contains directory B, then A is the parent directory of B.

password

A combination of letters and/or numbers that only you know; it is an optional element
of your login account. If you specify a password for your account, you must type it after
you type your login name before the system lets you access files and directories.

path

A list of directories the system searches when trying to find a file or run a program. You
can add directories to and delete directories from your path.
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pathname

The list of directories that leads you from the root (/) directory to a specific file or
directory in the file system.

peripheral

A hardware device that adds more functionality to the basic workstation, such as a tape
drive.

permissions

The information attached to each directory and file that specifies which users can access
it and to what degree.

permissions mask

A system setting that specifies the default permissions that the system assigns to newly
created files and directories. The owners of those files and directories can later change the
permissions.

pop

Windows on the screen and objects in the IRIS Showcase drawing area can overlap each
other. You can pop a window so it appears on top of other windows; you can pop an
object so it appears on top of other objects.

port

An outlet to which you attach cable connectors.

power cable

The cable that connects the workstation to a grounded electrical outlet.

power down

To turn off the power switches on the workstation chassis and the monitor.

power up

To turn on the power switches on the workstation chassis and the monitor.

prerequisite products

Software products that must be installed in order for other products to work. If product
A must be installed for product B to work, product A is a prerequisite product for
product B.
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primary group

A user can belong to several different groups, but one group must be the person’s
primary group. When a user creates a new file or directory, the system automatically sets
permissions on the file that determine whether other members of a group can view or
change the information. By default, the system labels the file with the user’s primary
group. This means if the user wants members of a different group to which the user
belongs to access the file, the user must explicitly change the group ownership of the file
to the other group.

primary system

The system that you use most frequently. You enter the name of this system in your User
Information window, and it appears on your business card.

Primary User

For environments in which one person uses a particular system much more frequently
than anyone else (where the person is essentially the system’s owner), you can designate
that person as the Primary User. The Primary User does not necessarily have any special
access privileges; the person’s name appears along with the Administrator’s name in the
system’s Information Panel so other users know uses the system regularly. There is only
one Primary User per system.

Printer Manager

A tool that you use to set up printer software and monitor jobs that you send to the
printer. You access it through either the System toolchest or the System Manager, where
it is called the Printer tool.

Privileged User

A person whose standard login account includes administrative privileges. When a
Privileged User logs in, he can change his personal work area, and can use the graphical
administration tools to change or customize the entire system (for example, add a disk,
create a login account, or install system software). There can be more than one Privileged
User on the same system.

product

A product is the largest module of software that Software Manager or inst can install. The
operating system consists of several products that are required for the system to run.
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project root directory

The directory on your own system in which you create and refine HTML documents. To
simplify publishing, this directory should also contain all local files that the HTML
document references via links. When a document is ready to publish on the Web, you
copy the project root directory and all its relevant subdirectories onto the web server.

PROM monitor

The interface that you use to communicate with the system after it is powered up, but
before it is booted up and running IRIX.

prompt

A character or word that the system displays in an IRIX shell that indicates that the
system is ready to accept commands. The default prompt for regular user accounts is %;
the default prompt for the root account is #.

push

Windows on the screen and objects in the IRIS Showcase drawing area can overlap each
other. You can push a window so it hides behind other windows; you can push an object
so it appears below other objects.

queue

A list of print jobs waiting to be printed on a particular printer.

quit

To stop running an application.

remote workstation, drive, disk, file system, or printer

A hardware device or the information or media it contains that you can access across the
network; they are not physically connected to your workstation.

reset button

A physical button on the workstation that you press to cut off then immediately restore
power to the workstation. You should never press this button while IRIX is running,
unless all attempts to shut down the system using software fail. See also shut down.

restore (files)

To copy files that once resided on your hard disk from another disk or a tape back onto
your hard disk.
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root account

The standard IRIX login account reserved for use by the system administrator. This
account’s home directory is the root (/) directory of the filesystem; the user of the root
account has full access to the entire filesystem (that is, can change and delete any file or
directory). The user of this account is sometimes referred to as the superuser.

root (/) directory

The directory at the top of the file system hierarchy.

same products

The Software Manager considers a product to be ’same’ when the product is available for
installation, and is the same version as a product that is currently installed on the system
on which Software Manager is running.

SCSI

An acronym that stands for Small Computer System Interface protocol. SCSI is a
standard protocol for transferring information from a computer to another device.

SCSI address

A number from one to seven that uniquely identifies a SCSI device to a system. No two
SCSI devices that are physically connected to the same SCSI controller on a system can
have the same SCSI address.

SCSI cable

A cable that connects a SCSI device to a SCSI port on a workstation.

SCSI controller

An internal board that sends data to and from SCSI devices. You can have more than one
SCSI controllers.

SCSI device

A hardware device that uses the Small Computer System Interface (SCSI) protocol to
communicate with the system. The system disk, floppy drives, CD-ROM drives, and tape
drives are all SCSI devices.

select

To position the cursor over an icon then click the (left) mouse button. Once an icon is
selected, it is the object of whatever operation you select from a menu.
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serial device

Any hardware device that requires a serial cable connection to communicate with the
workstation.

serial port

An outlet on the workstation to which you connect external serial devices.

server

A system that other systems on the network access to use its disk space, software, or
services.

shelf

The shelf is a place for you to put icons that you need to use frequently while working in
a particular directory. For example, if the directory contains many files, you might want
to place the files you use most frequently on the shelf. Or, if the directory contains many
color Showcase slides, you might want to place the icon for a color printer onto the shelf.

shell

A window into which you type IRIX commands.

shell script

A program that issues and interprets a sequence of IRIX commands.

shuffle

To change the order in which windows are stacked on the screen.

shut down

To safely close all files, log out, and bring the workstation to a state where you can safely
power it down. You choose “System Shutdown” from the System toolchest menu to do
this.

SLIP

Standard system software that lets you connect to a network using a serial cable and a
modem rather than using an Ethernet cable. Once you’re connected, you can use the
network as if you were connected by an Ethernet cable. SLIP stands for Serial Line
Internet Protocol.
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Software Inventory list

The list of available and/or installed software that the Software Manager provides when
you click the Customize Installation or Manage Installed Software button, and when you
have chosen to display the Software Inventory pane using the Panes menu.

software option

Any software product that you buy from Silicon Graphics, Inc. other than the standard
system software that comes on your system disk.

Standalone Access account

An account that you can log in to whether or not the system is connected to the network
or NIS is running. The account information is stored on the local system rather than on
the NIS master system.

standalone system

A system that is not connected to a network.

subnet

A logical subset of all systems on a network. Typically, all systems on a subnet are
physically close to each other, for example, are all located in the same building.

subsystem

A portion of a software product. Each product consists of several subsystems; some are
required and some are optional. See also product and image.

superuser

An alternate name for the user of the root login account. See also system administrator.

swap space

A portion of your disk that the system uses as if it were physical memory.

System toolchest

The toolchest in the upper left portion of the screen from which you can access all system
administration tools.

system

All the hardware and software that makes up the computer.
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system account information

System account information appears in the bottom portion of a person’s User
Information window in the Users and Groups tool. It includes information about the
type of account the person has on this system, whether the person is a Privileged User or
the Primary User of the system, and which area of the system is reserved for the person
(the home directory). Often this information is different on every system on which a person
has an account.

system administration

A collection of tasks and responsibilities carried out by a system’s Administrator to set
up the system and keep it in good running order.

system disk

The disk that contains the IRIX operating system software and Silicon Graphics tools.

system software

The standard IRIX operating system software and Silicon Graphics tools that come on the
system disk and on the tape or CD-ROM that you use in the event of a system crash.

system resources

Directories and peripherals that physically reside on your system.

TCP/IP

The standard networking software that’s included in the system software.

UNIX

A multiuser, multi-tasking operating system from AT&T upon which Silicon Graphics
Inc.’s IRIX operating system is based.

unmount

To make a file system that is accessible from a specific directory on your system
temporarily unavailable.

upgrade products

The Software Manager considers a product to be an upgrade when the product is
available for installation, and is a newer version of a product that is currently installed
on the system on which Software Manager is running.
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URL

An acronym for Universal Resource Locator, the URL is the unique identity of each
document and file that is available on the Web. The URL typically consists of three
components: the protocol used to retrieve the content, the domain name of the web
server, and the pathname of the document or file.

URL translation

The process of stripping the pathname of your project root directory from all local files
to which your HTML document links. This makes all links relative rather than absolute
(none of the links begin with /) so that you can copy the entire project root directory and
all its subdirectories onto a web server and keep all links intact. Once the directory is
copied onto the web server, documents in that directory are considered to be published
on the web.

User

Any person who has a standard login account on the system. When a User logs in, he can
change only his personal work area. A User can run the graphical administration tools,
but the features of the tools that change system information are not available.

user ID

A number that uniquely identifies a user to the system.

User Manager

The tool that you start from the System toolchest which lets you add, change, and delete
user login accounts.

UUCP

Standard system software that lets you connect to a network using a serial cable and a
modem rather than using an Ethernet cable. Once you’re connected, you can log into a
single system through one window; your system essentially behaves like a dumb
terminal.

virtual swap space

A file that the system considers to be a certain size (e.g., 40MB) but actually occupies no
disk space. This is useful because many programs request much more swap space than
they really need in order to run, and tie up the real swap space unnecessarily. When you
add virtual swap space, the system lets you start applications even when they request
more swap space than is actually available. In most cases this is fine, because there is
enough real swap space for them to run. See also logical swap space.
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Web

The shorthand name for the World Wide Web, this refers to the body of information
available on the Internet.

web server

A system on a network that contains HTML pages that people can access using an HTML
browser or player.

wildcard

A character, usually an asterisk (*), that you use alone to specify all files and directories
that are available, or with a few other letters to specify a group of files and directories that
have a common element in their names. For example, to specify all files and directories
that begin with the letters “ch”, you would type: ch*

window

A portion of the screen that you can manipulate that contains text or graphics.

window close box

The small box in the upper left corner of a window that contains a horizontal bar. You
double-click this box to close a window.

window manager

The system program that draws and controls windows. It lets you create and manipulate
windows — move them, resize them, and close them.

World Wide Web

See Web.





Tell Us About This Manual

As a user of Silicon Graphics products, you can help us to better understand your needs
and to improve the quality of our documentation.

Any information that you provide will be useful. Here is a list of suggested topics:

• General impression of the document

• Omission of material that you expected to find

• Technical errors

• Relevance of the material to the job you had to do

• Quality of the printing and binding

Please send the title and part number of the document with your comments. The part
number for this document is 007-2615-004.

Thank you!

Three Ways to Reach Us

• To send your comments by electronic mail, use either of these addresses:

– On the Internet: techpubs@sgi.com

– For UUCP mail (through any backbone site): [your_site]!sgi!techpubs

• To fax your comments (or annotated copies of manual pages), use this
fax number: 415-965-0964

• To send your comments by traditional mail, use this address:

Technical Publications
Silicon Graphics, Inc.
2011 North Shoreline Boulevard, M/S 535
Mountain View, California  94043-1389


