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Installing Applications on a Workstation

To install application software from a CD-ROM drive that is connected to your 
system, follow the instructions in the following section, “Installing 
Applications from a Local CD-ROM Drive.” 

To install application software from a CD-ROM drive that is connected to 
another system on your network, follow the instructions in “Installing 
Applications From a Remote CD-ROM Drive” on page 5.

For more details about software installation, including how to customize your 
installation and troubleshoot, refer to the Software Manager Help menu.

Installing Applications from a Local CD-ROM Drive

1. Insert the CD in the CD-ROM drive.

2. Open Software Manager by double-clicking the CDROM icon on your 
desktop.

3. To install all upgrades and new products, proceed to Step 4; otherwise, 
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products 
you want to install.

■ If a product has release notes, the product name turns blue when you 
click on it. Click again to display Release Notes, or choose Selected > 
Release Notes.
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4. Click the Start button.

5. When the installation is complete, choose File > Quit. 

6. Eject the CD from the drive:

Select the CDROM icon, hold down the right mouse button, and choose 
Eject.

Installing Applications From a Remote CD-ROM Drive

1. Insert the CD in the remote CD-ROM drive.

2. From the Toolchest on your system, choose System > Software Manager.

3. In the Available Software field, enter the remote system’s name, a colon 
(:), and /CDROM/dist. For example, enter:

mars:/CDROM/dist

Troubleshooting: If you see an error similar to Cannot load network 
(0) bootp()<system name>:/CDROM/dist, check that tftp access 
to the CDROM is enabled on the remote system.

4. Click the Lookup button.

5. To install all upgrades and new products, proceed to Step 6; otherwise, 
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products 
you want to install.
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■ If the product has release notes, the product name turns blue when 
you click on it. Click again to display Release Notes, or choose 
Selected > Release Notes.

6. Click the Start button.

7. When the installation is complete, choose File > Quit. 

8. Eject the CD from the drive:

Select the CDROM icon on the remote system’s desktop, hold down the 
right mouse button, and choose Eject CDROM.

Installing Applications on a Server

The installation program used in these instructions is called Inst. Inst has an 
extensive online help feature. To see the list of topics on which help is 
available, enter the command help help at the Inst prompt. For more details 
on using Inst, see the online book IRIX Admin: Software Installation and 
Licensing. You can access this book from the Toolchest on a graphical system 
(choose Help>Online Books), or from http://techpubs.sgi.com/.

1. Open a UNIX shell and enter su to become superuser.

2. Enter inst to start the Inst program.

3. Enter from followed by the distribution directory path—for example, 
if you are installing from a local CD-ROM drive, enter the following:
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from /CDROM/dist

Troubleshooting: If you are installing from a remote CD-ROM drive and 
see an error similar to Cannot load network (0) bootp()<system 
name>:/CDROM/dist, check that tftp access to the CD-ROM is 
enabled on the remote system. Detailed instructions are in the online 
Personal System Administration Guide.

4. Type keep *, install standard, and install prereqs at the 
Inst prompt:

Inst> keep *

Inst> install standard

Inst>  install prereqs

You may see a message saying there were no matches for prereqs 
or for standard—this does not indicate an error.

Note:  These commands select upgrades, and any prerequisites, for the 
products you already have installed.

5. (Optional) If you want to view, or alter, which products are marked for 
installation, enter list:
Inst> list

Each product is marked:

–  N    indicates that the product is new
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– [d] indicates that the product is installed by default unless 
otherwise instructed

–  i   indicates that the product will be installed

–  r  indicates that the product will be removed

– [r] indicates that the product is required

You may change the installation status of any product in the distribution 
listed. Tips for making selections: 

• To select software that is not already selected, use the install 
command. For example: install ViewKit_dev.sw.lib. 

• If there is software you do not wish to install, use the keep command. 
For example: keep ViewKit_dev.sw.lib. 

6. Enter conflicts to see if your installation selections have generated any 
conflicts. If there are no conflicts, proceed to step 7. 

To resolve conflicts, enter conflicts choice choice. For example, enter 
conflicts 1b 2a to indicate that for conflict 1 you choose choice b and 
for conflict 2 you choose choice a. 

Tips for Resolving Conflicts:

• If the list of conflicts is long, you can enter q to stop viewing the list 
and resolve the conflicts currently visible on the screen. Once you’ve 
resolved the visible conflicts, enter conflicts again to view the 
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remaining conflicts. The other option is to write down all of your 
choices before you enter them.

• Do not decline to install products with “eoe” or “Execution 
Environment” in the product name. The operating system needs these 
products in order to function properly.

7. Enter go at the prompt to begin the installation.

8. Enter quit when Inst indicates that the installation is complete. 
Postinstallation processes begin. When they are complete, you see:

Ready to restart the system. Restart?

Enter y to restart the system.

Installing Software Keys

SGI uses FLEXlm to license its products. The sections that follow describe how 
FLEXlm node-locked and floating or concurrent keys are installed using 
License Manager. (The terms “floating key” and “concurrent key” are 
interchangeable.) 

Additional licensing information regarding software keys can be found at 
http://www.sgi.com/support/licensing/.

For products that require a software key, you should have received an 
Entitlement ID number from SGI. The Entitlement ID is a unique, randomly 
generated, numeric, 16-digit identifier that is used by SGI to verify proof of 
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purchase for keyed software products. This number is required by SGI when 
customers request their permanent keys from 
http://www.sgi.com/support/licensing/. If you do not have this number, 
contact SGI or your local support provider.

Installing a FLEXlm Node-locked Key

To install FLEXlm Nodelocked licenses you must (1) invoke License Manager. 
If you are installing a key for XFS Volume Plexing or any other product that 
must be installed in a directory other than /var/flexlm, then refer to the 
products release notes for key installation instructions. 

To install the key, follow this procedure:

1. Choose System > License Manager from the Toolchest to open License 
Manager.

2. Click the Install button.

3. Select FLEXlm Nodelock.

4. Click the OK button.

5. Copy the entire key into the window labeled License Manager: Install 
FLEXlm Nodelock License.

6. Click the OK button.

7. Repeat steps 2 through 6 until all licenses are installed.

8. Click the Close button on the main License Manager window. 
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You are finished installing the key(s). Save the entitlement ID and a copy of the 
software key; you may need them again later to reinstall your key(s).

Note:  You may also use the Manual Installation Instructions to add 
software keys directly to /var/flexlm/license.dat. These 
instructions accompany the software keys that are issued from SGI. 

Installing a FLEXlm Floating (Concurrent) Key 

Note: The information in this section should be used only by the system 
administrator of the license server system. If you are an end-user of client 
software with a floating license that is not functioning, contact your system 
administrator.

If you are installing a key for a product that must be installed in a directory 
other than /var/flexlm, refer to the specific product’s release notes for 
license installation instructions. 

Floating keys require a network license server. The subsystem 
license_eoe.sw.flexlm_server must be installed on that system. 
Verify that it is installed by opening a UNIX shell and entering:
showprods -s3 license_eoe.sw.flexlm_server

If the result is license_eoe.sw.flexlm_server, the subsystem is 
installed; if the result is nothing, you must install 
license_eoe.sw.flexlm_server.
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With FLEXlm, a floating key must be installed on the license server and the 
license file copied to every client system. The license manager daemon, 
lmgrd, should then be started on the license server. You do not need to start 
license daemons on client systems

To install the key on the license server system using License Manager, follow 
this procedure:

1. Choose System > License Manager from the Toolchest to open License 
Manager.

2. Click the Install button.

3. Click FLEXlm Floating.

4. Click the OK button.

5. If necessary, enter the Server Host Name in the corresponding field. (To 
find the name, enter the UNIX shell command uname -n on the server.)

6. Copy the entire key into the License Manager-Install FLEXlm Floating 
License window.

7. Click the OK button.

8. Repeat steps 2 through 7 until all licenses for the server are installed.

9. Click the Close button on the main License Manager window. 

Note:  You may also use the Manual Installation instructions to add 
software keys directly to /var/flexlm/license.dat. These 
instructions accompany the software keys that are issued from SGI.
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To configure and start the FLEXlm license daemon (only on the license server 
system), follow this procedure:

1. Open a UNIX shell and enter su to Become superuser.

2. Enter chkconfig flexlm on.

3. Stop the lmgrd daemon by entering /etc/init.d/flexlm stop.

4. Edit /etc/config/lmgrd.options and 
/etc/config/lmdown.options to reference 
/var/flexlm/license_server_name.dat instead of the default 
/var/flexlm/license.dat.
Note: /etc/config/lmdown.options appears only in IRIX 6.5.16 and 
later.

5. Start the lmgrd daemon by entering /etc/init.d/flexlm start.

6. Exit the root account by entering exit.

On any system you wish to access this license from, you must copy (or mount) 
the license file (/var/flexlm/license_server_name.dat) from the server 
system into the /var/flexlm/license_server_name.dat file (on all client 
systems).

You are finished installing the key. Save the Entitlement ID and a copy of the 
software key; you may need them again later to reinstall your key(s).
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Troubleshooting FLEXlm Software Keys

Use the methods described in this section for basic troubleshooting. 

• To analyze the keys in the license files, enter either of the following UNIX 
commands:

 /usr/sbin/lmdiag -c /var/flexlm/license.dat 

/usr/sbin/lmdiag -c /var/flexlm/license_serverhost.dat

If you see an error message that says the HOSTID is incorrect, do the 
following:

– For a node-locked key, enter the UNIX command 
/usr/sbin/lmhostid. If the result does not match one of the entries 
in the HOSTID string for that product in the license file, this is the 
problem.

– For a floating key, on the server system, enter the UNIX command 
/usr/sbin/lmhostid. Compare the results with the second 
argument on the SERVER line, which corresponds to the product in 
question. If the two numbers are not identical, this is the problem.

Conditions that might cause the /usr/sbin/lmhostid results and the 
HOSTID to be different include:

– The key may be for a system different from the one it is installed 
on.

– The HOSTID may have been entered incorrectly.
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– The HOSTID on the system may have changed (replacing the 
system board or I/O board can change the HOSTID).

– The system may have been partitioned, or the license may be for a 
different partition.

• Note: The following troubleshooting procedure works only for IRIX 6.5.16 
and higher. Prior to IRIX 6.5.16, lmdown and lmgrd shared the same 
configuration file. In pre-6.5.16 systems, adding -l logfile to the 
lmgrd.options file (as described in this procedure) causes lmdown to 
fail and breaks the /etc/init.d/flexlm stop command.

For trouble with a floating FLEXlm key in IRIX 6.5.16 and higher, 
configure the lmgrd daemon on the server to send its output to a log file 
by adding the following to the /etc/config/lmgrd.options file 
(note that -l is the lowercase letter l, not the number one):
-l /var/tmp/flexlm.log

Do not update the /etc/config/lmdown.options file. Also, 
double-check the path of the license file named in the -c option in both 
lmgrd.options and lmdown.options; the path should specify the 
/var/flexlm/license_server_name.dat file. 

In a UNIX shell, enter

/etc/init.d/flexlm stop; /etc/init.d/flexlm start
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Note:   If the lmdown.options file is not configured correctly, the 
flexlm stop command fails. The flexlm start command also 
fails and logs messages that lmgrd is already running. The only way to 
fix this problem is to kill all the lmgrd and sgifd processes manually 
(killall -v lmgrd sgifd).

In systems running IRIX 6.5.18 and earlier, the stop command fails 
silently. Systems running IRIX 6.5.19 and later display an error in the 
/etc/init.d/flexlm stop process alerting users to the problem. 

Look at the log file for error messages.

If the application program (or lmstat) cannot connect to the license 
server, one of several things may be wrong:

– The license server may be down, or there may be a network 
problem. Verify that the client system can communicate with the 
server. In a UNIX shell on the server, enter this command:
setenv LM_LICENSE_FILE /var/flexlm/license_server_name.dat 

Then, enter /usr/sbin/lmstat -a to verify that the vendor 
daemon is running. 

In a UNIX shell on the client system, enter lmstat -a to check if the 
system can contact the vendor daemon on the server. Then, from the 
client system, enter the command telnet hostname portnumber, where 
hostname and portnumber match the SERVER line in the license file.
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– The SGI vendor daemon may not be running. On the server, verify 
that it is running by entering the UNIX command ps -ef | grep 
’[s]gifd’. If nothing is returned, then the vendor daemon is not 
running.

– The application may not be looking at the expected license file. The 
default license file for SGI products is 
/var/flexlm/license.dat. Verify the contents of 
/var/flexlm/licensefile.db to see what files are being 
looked at. To view contents lists of all expected license files, enter:

more /var/flexlm/licensefile.db

• If a warning message appears stating that the license expires in an 
incorrect number of days, remove or comment out temporary or 
evaluation key(s) in the /var/flexlm/license.dat file for this 
product.

• The License Password may have been entered incorrectly. Check that the 
letters l and O were not typed in place of numerals 1 (one) and 0 (zero).

• Run the date command by entering date. Make sure the date is not 
earlier than the Start Date (the date you received the key) or later than the 
Expiration Date (the date listed in the key). 

• Scan all license files, those named in the directory and those in the 
directories named, for matching features. Older duplicate entries might 
cause problems.
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• Run env|grep LM and see if it returns a LM_LICENSE_FILE variable. 
This environment variable overrides any defaults. This variable may 
point to a third party license file.

For more information on troubleshooting, refer to the FLEXlm End User 
Manual.
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