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Overview
Welcome to ShotMaker, an integrated set of utilities that provides frame-accurate, synchronized,
realtime playback and capture of professional quality video and audio.  ShotMaker stores all on-disk
video in industry standard QuickTime movie files.  ShotMaker’s main features include: 
  

Capture from video input to disk, with optional monitoring of  video input on a workstation
graphics screen. 
Capture from a workstation graphics screen to disk. 
Playback from disk to a workstation graphics screen, a video output device, or both. 
Assembly of on-disk video clips (QuickTime movie files) from image file sequences and audio
files. 
Disk set-up utilties and diagnostics. 
Optional frame-accurate tape deck control for captures from tape to disk or laydown from disk to
tape. 

ShotMaker has support for arbitrary resolution video, including high-definition (HD) sizes. Playback is
fully random-access, variable-speed, and supports playlists of sequences of clips with in/out points. 
ShotMaker also includes support for external playback control via MIDI Machine Control (MMC). 
  
  

The ShotMaker User Interface

ShotMaker utilites include: 

shotmaker(1) - graphical user interface video IO tool that supports both mouse and keyboard
accelerators 



shotmaker   -noGui- command line driven video IO tool 
smconvert(1)- command line driven video conversion utility 
smsetup(1) - disk setup script 
smbandwidth(1) - disk diagnostic 
sminfo(1) - command line QuickTime file diagnostics 
sminv(1) - ShotMaker software and hardware inventory 



System Requirements
System Requirements

ShotMaker is supported on SGI Onyx2, Origin2100, Origin2000, and Origin200 w/ GIGAchannel
systems, running IRIX 6.5.4 or later.  Configuring a ShotMaker system depends on the desired
ShotMaker functionality as well as the video formats you need to use.  Configuration details are
described below.  (Note that certain formats and functionality cannot be supported on the Origin200. 
See the section on memory bandwidth for details). 
  

Memory

ShotMaker requires at least 512 MBytes of memory to support HD video formats. 

Disk Bandwidth Requirements

Disk bandwidth requiments are significant for HD formats.   Disk bandwidth is a function of the video
standard (size and rate) as well as the memory packing.  Tables 1 and 2 can be used to determine the
required bandwidth for a specific format stored on disk. 
  
  
  

Video Standard Bytes Per
Pixel

MegaBytes/sec of Bandwidth
Per Video Stream

1080i/59.94Hz 2 124 MB/sec

 3 186 MB/sec

 4 248 MB/sec

1035i/59.94Hz 2 120 MB/sec

 3 180 MB/sec

 4 240 MB/sec

1080i/50Hz 2 104 MB/sec

 3 156 MB/sec

 4 208 MB/sec

1080p/24Hz 2 100 MB/sec

 3 150 MB/sec

 4 200 MB/sec

720p/59.94Hz 2 110 MB/sec

 3 165 MB/sec

 4 220 MB/sec

  



Table 1: Bandwidth Per Video Stream

Note:  In this table, a MegaByte (MB) is 1,000,000 bytes. 
Also, 1080p/25Hz requires identical bandwidth as 1080i/50Hz.

  

Video Packing Stored on Disk Bytes Per Pixel

8-bit YCrCb 4:2:2 2

8-bit RGB 3

8-bit RGBA 4

10-bit RGB, 2-bit A 4

  
Table 2: Bytes Per Pixel For Video Packings

For example, 1080i 59.94Hz video stored in 8-bit RGB requires 186 MBytes/second of disk bandwidth. 
As a rule of thumb, a good Fibre Channel disk array provides somewhere between 70-80 MBytes/second
of bandwidth per array.  So, 1080i 59.94Hz video stored in 8-bit RGB would typically require at least 3
disk arrays, striped in parallel as one logical volume. 

ShotMaker includes the smsetup utility for properly configuring RAID (redundant array of independent
disks) and JBOD (just a bunch of disks) systems for HD content as well as the smbandwidth utility for
testing the bandwidth of these disk systems.  For more information about RAID  and JBOD, see the SGI
Storage website. For more information about logical volumes, see the xlv(7M) man page. 

(Note:  ShotMaker’s disk setup tools and disk IO engine are optimized for forward, nominal speed
playback and recording.  Reverse and high-speed playback features will typically requires more disk
bandwidth than is stated here for optimal performance.) 

Memory Bandwidth and Node Cards

Memory bandwidth is a function of both the memory packing of the video as well as the number of
simultaneous streams of concurrent video in/out of memory.  Below is a table that lists functions in
ShotMaker along with the number of streams of video they require. 
  
  
  



ID Function Number of Streams
To/From Memory

1 Playback to video and
graphics

3

2 Playback to graphics only 2

3 Playback to video only 2

4 Capture to disk with graphics
monitoring

3

5 Capture to disk without
graphics monitoring

2

  
Table 3: ShotMaker functions and number of video

streams

For example, a system for recording 1080i/59.94Hz YCrCb 4:2:2 video to disk (without monitoring)
will require, at a minimum, 248 MBytes/second of memory bandwidth.  ShotMaker stripes memory
accross multiple node cards in the Origin and Onyx2 to provide maximum bandwidth.  The following is
a list of supported configurations and the specific features/formats.  (Note that those configurations
requiring more than one node card will not work on Origin200 systems, because Origin200 systesm are
limited to one node card). 
  
  
  

Video Standard Video
Packing

Minimum
Number of
Node Cards

Function
IDs

1080i/59.94Hz 8-bitYCrCb
4:2:2

1 3,5

 8-bit RGB 2 1-5

 
8-bit RGBA

or 
10-bit RGB

2 2,3,5

1080p/24Hz 8-bit YCrCb
4:2:2

1 3,5

 8-bit RGB 1 1-5

 
8-bit RGBA

or 
10-bit RGB

2 2,3,5

  
Table 4: Minimum Node Card Requirements for Selected

Video Standard, Packings, and Functions



  

Video Hardware

ShotMaker supports the HD I/O video board (XT-HD). See the HD I/O Option Board Owner’s Guide.
Please send questions and requests for support of other video hardware products to
shotmaker@postofc.corp.sgi.com. 

Audio Hardware

ShotMaker requires at least one audio subsystem.  In Onyx2 and Origin2000 systems, an audio
subsystem can be obtained by installing one of the following: 

1. A base IO module that includes audio (XT-BASEIO-G). This part is standard in Onyx2 systems. 
2. A crosstalk PCI expansion cage or shoebox (XT-INT-PCI) and a PCI RAD audio card

(PCI-AUD-8C-ALL). 

Graphics Hardware

ShotMaker supports all graphics options on the Onyx2 including Reality, Infinite Reality, and Infinite
Reality 2 (IR, IR2, or IR2E). The ShotMaker user interface will work on either a local or remote X
display, but ShotMaker will only display images on a local Onyx2 X display. 

(Note: ShotMaker supports dynamic resizing of video on the graphics screen in some graphics
configurations.  To maintain full pixel quality for this feature, two (2) raster manager (RM) boards are
required for 1080i size video.  And four (4) are required 59.94 fps video [e.g., 720p video]). 
  

Deck Control

For controlling a tape deck and providing frame-accurate captures and laydowns with ShotMaker, 
a deck control software module from Diaquest is required. This module, which supports most known
tape decks, is licensed by Diaquest, not SGI. See http://www.diaquest.com/ for details.  The Diaquest
software includes a special serial 422 cable and dongle.  Use of the software requires one serial port. 

SGI has tested ShotMaker deck control with the following HD tape decks: 

Panasonic AJ-HD2700 
Panasonic AJ-D580 
Sony HDW-500 HDCAM 

MIDI Playback Control

ShotMaker playback can be controlled with any device that supports MIDI machine control (MMC),
such as JLCooper’s Media Control Station 2.   See http://www.jlcooper.com/ for details. 



In order to connect MIDI equipment to SGI systems, one needs to convert the MIDI signal to a 422
serial signal.  At this time, third party hardware is required for this conversion.  We recommend the
Unwinder MIDI from Technology Playgroup. See http://this.is/tpg/products/unwinder/ for details.  MIDI
control requires one serial port. 
  

Media Formats

ShotMaker stores interleaved video and audio in standard QuickTime movie files.   ShotMaker
recognizes a large subset of QuickTime files, but has strict requirements on these files for real-time
playback. 

The smconvert utility provides means for creating, copying, and converting QuickTime files for
real-time use by ShotMaker.  This utility can create a QuickTime file from a sequence of images and
vice-versa.  It can read audio from a separate file and it can also strip out the audio from an exisiting
QuickTime file.  It can also create a single QuickTime file from a playlist. 

ShotMaker supports most image file formats that are supported by IFL(3).  See man imgformats(3) for
details. 

ShotMaker supports all audio file formats that can be read by the SGI Audio File Library, including: 

Extended AIFF-C standard 
AIFF (older version) 
NeXT/Sun SND/AU 
WAVE (RIFF) 
MPEG1 audio bitstream 
Sound Designer II 



Getting Started
This chapter discusses installation, and briefly introduces use of the ShotMaker application. For more
information about the setup and configuration of the HD I/O board, see the HD I/O Option Board
Owner’s Guide, part number 007-3968-001. Please read the configuration sections carefully. There
several important details there. 

Installing Software

Install the shotmaker.* product images. If you are reading this, you have probably already done so. 

After installing ShotMaker, you should run smsetup, a shell script, to configure disks arrays optimized
for the type of video you will be capturing and playing back. 

ShotMaker requires a (free) license. A temporary license is provided with the product, along with an
entitlement ID for a nodelocked license. Permanent licenses can be obtained from the Key-o-Matic
website, http://www.sgi.com/Support/Licensing. After you enter the entitlement ID, Key-o-Matic
generates a license key immediately. Copy this license key into the /var/flexlm/license.dat file to enable
ShotMaker. 

If you have the Diaquest deck control software, install it by following directions provided with the
product. The Diaquest module is enabled with a separate software license. Please follow Diaquest’s
license installation instructions. 

Configuring Disk Arrays

The smsetup script asks for your preferred video file format, and uses this to lay out disk arrays for the
best possible bandwidth. Before running smsetup, please ensure that your storage subsystem has been
cabled for the optimum bandwidth. The following disk arrays have been tested: 

Ciprico 7000 RAID-3 
SGI FibreVault JBOD 

To optimize disk write bandwidth for captures with RAID-3 disk systems, RAID-3 write buffering must
be enabled. Optimal RAID-3 performance typically occurs with 4+1 LUNs (4 data and 1 parity disk per
logical unit number, without hot spare). The Ciprico 7000 comes pre-bound this way. You must ensure
that other FibreChannel RAID-3 units are similarly configured. Note that smsetup does not bind
RAID-3 LUNs for you, or enable RAID-3 write buffering. Unless LUNs are pre-bound, binding is
required after hardware installation. 

To optimize disk write bandwidth for realtime capture with JBODs, write buffering must be enabled on
each disk, and command tag queueing must be disabled. The smsetup script takes care of this for the
SGI FibreVault JBOD. For unsupported JBODs, you must run fx yourself: for each disk in the array, run
/label/set/parameters to disable command tag queuing and enable write buffering. See the fx(1M) man
page for details. (Note: Setting these disk parameters typically increases read and write bandwidth.
Should the smbandwidth test run during smsetup’s completion succeed without your setting these



parameters, you need not set them. Ultimately what matters is whether or not the disk system meets your
bandwidth needs). 

Realistic sustained bandwidth across a single FibreChannel controller is about 70 to 75 MB/sec, so the
number of controllers required can be conservatively calculated with the following formula, where pixel
depth for YUV=2, RGB=3, RGBA=4 (always round up): 

  
width × height × pixel depth × frame rate ÷ (1000 × 1000) ÷ 70 
= numberOfControllers

This table shows how many FibreChannel controllers you need to stripe across, for different video
formats. 
  
  

Video Format Bandwidth 
in MB/sec

FibreChannel  
Controllers

29.97 frames/sec:   

 1080i YCrCb 4:2:2 122   2

 1080i RGB  186   3

 1080i RGBA  248   4

59.94 frames/sec:     

 720p YCrCb 4:2:2  110   2

 720p RGB  165   3

 720p RGBA  220   4, marginally 3

24 frames/sec:   

 1080p YCrCb 4:2:2100 2

 1080p RGB 150 3, marginally 2

 1080p RGBA 200 4, marginally 3

  
  

Configuring the Graphics Screen

When playing to the graphics screen, shotmaker supports two types of drawing: double-buffered and
single-buffered.  You can use the miscellaneous section of the Settings window (or the -doubleBuffer or
-noDoubleBuffer command line options) to choose single or double-buffered playback.  Single-buffered
playback will work regardless of the current graphics screen refresh and swap rates.  But the playback
rate will not be locked and you will see "video-tearing" and jitter.  Double-buffered playback will
eliminate the video tearing and jitter, but will require you to match the graphics screen retrace and swap
rates with the image rate of your material.  It will also require a video format that is capable of hardware



double buffering. 

You can use ircombine (or xsetmon) to alter the current video combination and/or retrace and swap
rates. On the Onyx2, the only method for ensuring that these  rates are locked to 29.97 NTSC video, is to
genlock the screen to an external NTSC sync.  ShotMaker provides several combination files for easy
setup. These files are located in /usr/gfx/ucode/KONA/dg4/cmb.  

ShotMaker_60.cmb  - Sets channel zero to 1920x1200_60Hz and channel one to
1920x1080_30iHz 
ShotMaker_59.cmb -  Sets channel zero to 1920x1200_59Hz and channel zero to
1920x1080_30iHz 
ShotMaker_59_ext.cmb  - Same as ShotMaker_59.cmb  with the addition that screen is genlocked
to an external NTSC sync 
ShotMaker_59_ext_sr.cmb  - Sets channel zero to 1920x1200_59 Hz and channel one to
1920x1080_29.97i Hz with the addition that the screen is genlocked to an external HD 1920x1080
sync. 

Be careful to only set Onyx2 graphics to external genlock of there is actually a valid signal coming in
the genlock jack on the board.  ShotMaker also includes special video format for running at
1920x1200_59Hz and 1920x1080_29Hz.  These files are located at
/usr/gfx/ucode/KONA/dg4/vfo/ShotMaker_1920x1200_59.vfo  
/usr/gfx/ucode/KONA/dg4/vfo/ShotMaker_1920x1080_29i.vfo  

Configuring the Graphics Screen for Realtime Graphics Screen Recording

With some additional hardware, ShotMaker can be in conjuction with the HD I/O board to record
1080i/59.94Hz images in realtime from the Onyx2 Infinite Reality graphics screen. What is needed is an
HD 1080i/59.94 capable analog to digital signal converter (ADC) to take the analog RGB signal from
one of the IR channels into the digital input of HD I/O (You will likely need a cable that breaks out
analog sync from the output of IR, like part number SGI part number 018-0634-002, as input to the
ADC). Follow the ircombine setup above and select the ShotMaker_59_ext_sr.cmb combination. This
will configure channel 1 as an analog HD 1080i/59.94 signal. Take the output of that channel into the
ADC, and the digital output of the ADC into the input of your Serial/Parallel converter for HD I/O. You
will also need to provide an external analog HD 1920x1080 sync signal to both IR and HD I/O.  For HD
I/O, you will need to use vcp to set the sync to be genlocked and the sync source to be 1920x1080,
external.  You may also need to make adjustments to the video format to match your ADC. You can
then record the output of the graphics screen as if it were any other video signal.; The instructions below
for recording from an external video device should be followed. (Note that the settings for screen
recording in ShotMaker GUI should be ignored; they are for non-realtime screen recording). 
  

Configuring Video Hardware

For HD I/O, before using shotmaker, it is important that you perform the following steps using the
video control panel, vcp: 

1. Select the HD I/O device you will use 
2. Determine your video input and output device colorspace standard (ITU Rec 709, SMPTE 240M,



or ITU Rec601.  See manufacturer documentation as needed; typical standards compliant HD
equipment will be ITU Rec 709).  Then select the correct YCrCb colorspace in vcp. 

3. Determine the interface precision (8-bit or 10-bit) for your video input and output  (See
manufacturer documentation as needed).  Then select the correct precision using the Pro->Digital
Video Drain and Pro->Digital Video Source menus.  Note that the interface precision of video
input and output is independent of the precision of the in-memory (and on-disk) video. 

4. Select the appropriate genlock/reference setting for your configuration.  SGI recommends locking
all video and audio gear to an external NTSC 525 sync reference.  This is the only method
currently available for locking both video and audio output devices to the same clock.  It is also
the only method that does not involve changing genlock settings when switching between
recording and playback. (If sample-accurate audio/video synchronization is not critical, for
playback you can use the internal sync source on the HD I/O board.  For recording, you can lock
to the incoming signal). 

Configuring Audio Hardware

In order to guarantee clock-accurate synchronization for playback, ShotMaker requires that audio and
video devices be genlocked to the same source. SGI audio hardware supports external genlock to an
external NTSC 525 sync signal.  To enable this, 

1. Ensure a valid NTSC sync signal is coming into the audio system’s genlock jack. 
2. Use the apanel device ’preferences’ menu to set the audio output device’s sync source to ’Video’. 

You may also want to use apanel to enable/disable monitoring on the audio input device you are using
for recording. 

Configuring Deck Control

Once installed, configuration the deck control software in ShotMaker amounts to little more than
selecting the correct serial port in the SettingsWindow (or using the -deckControlPort command line
option for the -noGui mode). 

It is also possible that a constant fudge factor or calibration may need to be set. SGI has yet to test a
deck that required these calibrations. See Diaquest software documentation for details. 

Diaquest also requires careful set up of the reference signal for both the tape deck (VTR) and the video
IO board. SGI recommends locking both the tape deck and the video board to an external NTSC 525
video sync source. (Alternatively, you can lock the deck to its input and run lock the video IO board to
its internal signal for laydowns, and you can lock the video IO board to its input and lock the deck to its
internal signal during captures.) 

Diaquest software assumes that: 

The video deck and the host video board are clocked by a common video sync signal as described
above. 
The deck can play, stop, standby off, pause, fast forward, and rewind. 
A deck that can record can also: 

Crash record 



Perform field-accurate edits (edit in/out) 
The tape contains a sufficiently error-free control track and signal so that the deck can maintain
servolock across the entire tape region used. 
All tapes must have contiguous timecode over the tape region used. (A number of unexpected,
hard-to-diagnose behaviors may result when timecode is not contiguous.) 

Note that Diaquest provides the following caveat: 

Please note that VTR location may not be totally accurate when the VTR has moved very
slowly. This is because the VTR’s time code reader can not read very slow data. Therefore
there may be accumulated error if the tape is jogged, especially forward and backward. This
will correct itself when the tape is played fast enough to read valid time code.

Configuring a MIDI Control Device

Attach the MIDI device to one of the ShotMaker system’s serial port and configure that port for MIDI
using the SerialDeviceManager(1M).  By default, ShotMaker will look for the first MIDI device NOT
named Software Synth.  You can start ShotMaker using the shotmaker -midiDevName command-line
argument to specify a specific MIDI device. The application listens to the following MMC (MIDI
Machine Control) commands from the current MIDI device: 

Play 
Stop 
Fast Forward 
Fast Backward 
Shuttle 

The ShotMaker GUI responds to MMC commands in the same way it would to mouse clicks. For
example, the playback shuttle’s on-screen movements correspond to movements of MIDI controller’s
shuttle as the user turns it. 

Running ShotMaker

ShotMaker may be run either by typing shotmaker on the command line, or by double-clicking its
desktop icon in the Media Tools folder. For easier access, you can click and drag the ShotMaker desktop
icon to the background area of your desktop, for future double-clicking. 

Playing, Recording, and Basic Editing

This section briefly describes several elementary operations in ShotMaker. 

Playing a Clip from Disk

You must start with a movie file.  Copy it (via smconvert) onto a disk volume that is fast enough to
sustain the data rate that your clip requires. In the ShotMaker main window, choose Open Playlist or
Clip from the File menu. Using the file selection dialog, navigate your system to find the clip.
Double-click on it, or select it and click OK. If you do not have an uncompressed QuickTime movie,



you can produce one using smconvert; see the smconvert(1) man page for details. 

The clip appears in the playlist. To view it on your graphics monitor, choose Play from the Control
menu, or click the triangular Play button at bottom right of the main window. Note that YCrCb material
will not display on the graphics monitor on the Onyx2, but it will output to video. 

ShotMaker provides a -theater option for showing video to the graphics screen without the distraction
of the user interface; see the shotmaker(1) man page for details. (This is the equivalent of individually
turning off the menus, dashboard, playlist table, window borders, and the mouse cursor.) 

Dropped frames can be an indication of realtime problems. To help pinpoint the bottleneck from
ShotMaker, choose Test Disk Bandwidth from the File menu. This runs smbandwidth to test the disk
I/O subsystem. This utility can restrict testing to the clip segment where problems occur; see the
smbandwidth(1) man page for details. 

Recording from Tape to Disk

Make sure the tape deck is cabled correctly, with video in/out, audio in/out, and so forth. 

In the ShotMaker main window, switch Mode from Play to Record. Queue up the tape near the desired
starting point, and press the play button on the deck. In the ShotMaker main window, quickly press the
red-dot Record button. 

When you are done recording, press the blue-rectangle Stop button. Soon your clip appears in the
ShotMaker main window. This clip already exists on disk; its filename shows in the playlist. 

If you have problems with dropped frames, choose Settings from the File menu, and in the Video
Device Recording tab, change the Dropped Frames policy to "Report after recording" instead of "Abort
on dropped frame" (the default). 

Again, it is possible to record from tape to disk using -noGui mode of ShotMaker. You will be
prompted to begin recording by pressing the Enter key. Pressing Enter again will finish recording the
clip. See the shotmaker(1) man page for details. 

Laying Down a Clip on Tape

To lay down a clip, multiple clips in a playlist, or a selected region of the playlist, choose Tape Deck
Control from the Control menu. There are two ways to approach laydowns in ShotMaker. The first way
is to select a region of the playlist - or the entire playlist - using the timeline (the large stripe across the
dashboard), and then enable the ’Use Timeline Selection’ toggle button. This will force the laydown’s
duration to be the same as the selected region’s, and the first frame of the laydown will be the first frame
of the selection. The second approach is to do a "free-form" laydown, which allows the laydown’s
duration as well as the strarting frame in the playlist to be arbitrary. This approach allows you to select a
small region of the playlist and loop it for the duration of the laydown, for example. However, most of
the time you will probably want to use the first approach. 

In the Tape Deck Control window, specify timecode for the in point on the tape (and the out point or
duration if you are doing a "free-form" laydown). Next, select the audio channels on the tape that will be



overridden with the playlist’s audio, or accept the default channels 1 and 2. 

Click the Laydown button near the bottom to begin recording. Laydown ends when the out point
timecode is reached. Finally, rewind the tape and press Play on the tape deck to make certain laydown
was successful. 

On ShotMaker systems without graphics, such as the Origin2000, it is possible to lay down a clip onto
tape using -noGui mode, the command-line equivalent of the X11 ShotMaker application. Use the
-tapeIn and -tapeOut arguments to specify starting and ending timecodes. In this mode, the first frame
of the laydown on tape will always be the first frame of the clip or playlist specified at the command
line. An external video monitor comes in handy for monitoring the video. See the shotmaker(1) man
page for details. 

Frame-Accurate Capturing of From Tape to Disk

You must first install the Diaquest deck control software and license. Diaquest provides a special cable
and converter with their software. Make sure your tape deck is cabled correctly, with video in/out, audio
in/out, and special RS422 serial cable plus RS232 converter hooked to a serial port on your ShotMaker
system. Note which serial port, and check that the ShotMaker Settings window contains the correct tty*
name for this serial port. 

While you are in the Settings window, set the working directory (for writing clips) to the proper system
location, for example the /HD_720p-rgb/ or /HD_1080i-rgb/ directory created when you ran smsetup. 

In the ShotMaker main window, switch Mode from Play to Record, then choose Tape Deck Control
from the Control menu. In the Tape Deck Control window, specify timecode for in and out points of the
region on tape that you want to record. All the timecode fields are editable. If speakers are hooked up
and you want to hear the audio track, choose Audio Panel from the Tools menu, and click the Monitor
toggle button for the audio device. 

Click the Capture button in the lower left corner to begin recording. Capture ends when the out point
timecode is reached. 

If you have problems with dropped frames, choose Settings from the File menu, and in the Video
Device Recording tab, change the Dropped Frames policy to "Report after recording" instead of "Abort
on dropped frame" (the default). 

If ShotMaker system capacity is exceeded, the graphics display is sacrificed for realtime disk
performance. During capture you might see some skipped frames on the graphics console, but unless
ShotMaker reports dropped frames, nothing is wrong. 

After recording, your clip appears in the ShotMaker main window. This clip already exists on disk; its
filename shows in the playlist. 

On ShotMaker systems without graphics, such as the Origin2000, it is possible to record from tape to
disk frame-accurately using -noGui mode, the command-line equivalent of the X11 ShotMaker
application. Use the -tapeIn and -tapeOut arguments to specify starting and ending timecodes. See the
shotmaker(1) man page for details. 



  

Creating a Sequence of Image Files

You can deconstruct a clip into separate image files (one for each frame) in order to do image processing
on individual frames. You do this with the smconvert utility, not from inside the ShotMaker main
window. For details, see the smconvert(1) man page. 

To construct a new clip from separate files (one per frame), use the smconvert utility again. This utility
also enables video conversions, with or without the FilePerFrame feature. 

Creating a Video Tape from a Series of Image Files

1. Put your image files (or links to them) in a single directory and number your image files (or links)
starting at 1.  (See man smconvert for details). 

2. Configure a striped volume for the video format you wish to use via smsetup. 
3. Use the smconvert utility to construct a clip from your image files. 
4. Preview the clip inside shotmaker to either video output or the graphics monitor. 
5. Disable the graphics display by toggling the ’Show Image on Graphics Screen’ menu item in the

View menu. 
6. Acquire a video tape and insert it into the tape deck. 

  

  

Then, if you have deck control... 
  

7. Follow the tape deck manufacturer’s instructions for laying down a control track and timecode on
the entire tape. 

8. Bring up the deck control window in the application, toggle the ’Monitor Deck’ option on, shuttle
the deck to the point where you wish to lay down your images and select the in point from the
deck. 

9. Toggle the ’Monitor Deck’ option off. Select the region of the clip in the timeline that you wish to
lay down. 

10. In the deck control window, select ’Use Timeline Selection’. 
11. Then push the ’Laydown’ button. 

  

  

If you do not have deck control... 
  

12. Shuttle the deck near the position at which you would like to laydown your content. 
13. Push record/play on the tape deck (follow manufacturer’s instructions for a crash record; note this

will destroy any continuous control track and timecode information on the tape). 
14. Press ’Play’ in the ShotMaker dashboard and press ’Stop’ when you are done. 
15. Push the stop button on the tape deck. 



Recording from the Graphics Screen

Here are two scenarios for graphics capture and playback. 

Scenario 1 - Continuous capture from graphics screen to disk. Suppose you have an existing application
that generates realtime images on the graphics monitor. You want to capture the images to disk for
editing and playback. 

1. Bring up ShotMaker and switch to Record mode. 
2. Choose File > Settings and click on the Graphics Screen Recording tab. 
3. Choose the graphics device, capture size, frame rate, and packing. If you select non-standard video

under Size, ShotMaker can record specific windows or portions of a window. Optionally, change
the directory where the capture will be recorded. 

4. For recording realtime applications, you probably want an automatic trigger, specified either in
seconds per trigger, or triggers per second. 

5. Start your application. In the ShotMaker main window, click the Record button. 
6. When finished, stop your application, and in Shotmaker, click the Stop button. 
7. In ShotMaker, switch to Play mode. Your recording now appears in the playlist. You can edit the

in and out points of the recorded clip. You could then lay down the edited clip onto a tape deck. 

Scenario 2 - Triggered snaps from graphics screen to disk. Suppose you have an existing application that
generates non-realtime images, perhaps involving long computation or interactive editing. You want to
capture the images to disk for editing and playback. 

1. Bring up ShotMaker and switch to Record mode. 
2. Choose File > Settings and click on the Graphics Screen Recording tab. 
3. Choose the graphics device, capture size, frame rate, and packing. If you select non-standard video

under Size, ShotMaker can record specific windows or portions of a window. Optionally, change
the directory where the capture will be recorded. 

4. For recording slow applications, you probably want to select manual trigger. In the ShotMaker
main window, a Trigger button appears, which you can click with the mouse whenever you want.
It might be more convenient to use the shotmaker -trigger command in a shell window. This
sends a trigger IPC to the existing ShotMaker process. 

5. Start your application. In the ShotMaker main window, click the Record button. 
6. When your application has a frame ready, click the Trigger button, or (re)issue the shotmaker

-trigger  command. 
In ShotMaker, switch to Play mode. Your recording now appears in the playlist. You can edit the
in and out points of the recorded clip. You could then lay down the edited clip onto a tape deck.

Editing A Playlist

In addition to supporting multiple clips in a playlist, ShotMaker allows you to perform basic playlist
editing. Each clip in the playlist has an in point and out point relative to the first frame in the clip. The
ShotMaker user interface allows these to be changed either by typing directly into the fields in the
Playlist Table, or by using the Trim To Selection button in the Edit menu. Here are some examples of
how to edit the playlist: 

You have recorded several clips from a tape deck without using deck control, so you have material



at the beginning and end of each clip that you do not want. For each clip, select the region of the
clip that you want to keep, and then select Trim To Selection. This will not actually remove any
frames from the clips on disk - it simply changes the in and out points of the clips in the playlist. If
you are unhappy with a trimmed clip, then select Reset Clip In/Out Points from the Edit menu to
return the current clip’s in and out points to their default values. 
You have a clip that has a section in the middle of it that you do not want to use. You can use the
playlist editing features to remove that section from the playlist. First insert the same clip into the
playlist twice and make sure that they are adjacent. For the first copy of the clip, select the region
from the beginning of the clip to the point in the clip where the unwanted section starts, and then
trim the clip to the current selection. For the second copy, select the region from the end of the
unwanted section to the end of the clip, and trim to that selection. Each clip is now individually
trimmed, and by having them back to back in the playlist, the result is as if you had cut the
unwanted section out of the original clip. 

Playlist File Format

ShotMaker can read a special playlist file specifying which clips to play. You create a playlist by
opening clips in the ShotMaker window. To save the playlist by generating a playlist file, choose Save
Playlist from the File menu. To read in a playlist, choose Open Playlist or Clip from the File menu. The
first line of a playlist file reads as follows: 

# ShotMaker Playlist Format v1.0

The syntax of each line of the playlist file is as follows: 

local filename [in out] ["Clip Name"]

where local  specifies that the file lives locally, filename  is the fully specified movie file, in  is the
starting point in frames and out  is the stopping point in frames. Both in  and out  are optional but must
be used together. If present, ShotMaker displays Clip Name  in the playlist, instead of a clip’s filename.
However, the ShotMaker user interface does not provide a way to set clip name - you must specify it by
directly editing the playlist file. Any line after the header that starts with a # will be ignored. 

All clips in a playlist must have the same video resolution and audio sampling rate. A playlist cannot
contain a mix of clip formats, including differing video or audio attributes. 

The playlist can be passed to ShotMaker in one of two ways. The first is with the graphical user
interface; see The ShotMaker User Interface for details. The second way is with command-line
arguments, described by the shotmaker(1) man page. Here is an example playlist: 

# ShotMaker Playlist Format v1.0  

local /hdtv_1080_rgb/clip1.qt 5 50 "Take 1"  
local /hdtv_1080_rgb/clip2.qt 10 80 "Take 2"



The ShotMaker User Interface
The ShotMaker user interface is a logical extension of other SGI media tools, for example MediaPlayer
or MediaRecorder.  The main thing to keep in mind is that ShotMaker has two main modes, one for
playback and one for recording.  Playback mode is much like MediaPlayer and recording mode is much
like MediaRecorder.  Playback mode provides full random access of clips in a playlist.  Record mode
allows one to record and preview recorded clips.  Recorded clips are automatically added to the current
playlist and may be viewed more interactively in playback mode. 

Main Window

The main window offers six pulldown menus, and is divided into three panels: the Playlist Table, the
Video Area, and the Dashboard. By and large, buttons in the Dashboard are shortcuts for menu choices. 

Pulldown Menus

The File menu contains the following items: 

Open Playlist or Clip... - Opens movie clip or playlist, which is a text file containing the names of
clips to play in sequence. If a clip or playlist is already open, this replaces the former one. 
Open Audio File... - Opens a local audio file that replaces the soundtrack of the current clip or
playlist. To make playback use the original soundtrack of the clip or playlist, unclick the "Enable
audio override" button in the Playback tab of the Settings Dialog. 
Insert Clip... - Adds a clip to the end of the playlist. The clip can be added only if it has the same
attributes as other clips in the playlist. 
Save Playlist - Saves the current playlist in a file you specify, for example movies.ply. If you had
opened a existing playlist, or have already saved the playlist, no further dialog occurs. Otherwise
you are asked to supply a filename for the playlist. 
Save Playlist As... - Saves the current playlist in a file you specify, for example movies.ply. This
allows you to modify an existing playlist and save your changes using a new name. 
Test Disk Bandwidth... - Brings up the ShotMaker Disk Bandwidth Availability window for
testing I/O, which tests disk I/O performance for the current clip in the playlist. You can select the
range of frames, or change the current clip with this window still open. The test reports average
and maximum read times per frame. 
Settings... - Brings up the ShotMaker Settings Dialog, with tabs for Video Device Recording,
Graphics Screen Recording, Playback, and Miscellaneous application attributes. See Settings
Dialog for details. 
Exit - Relinquishes system resources and exits ShotMaker. 

The Edit menu contains the following items: 

Move Clip Up - Swaps the currently selected clip with the one the precedes it in the playlist. Has
no effect if the currently selected clip is at the beginning of the playlist or if more than one clip is
selected. 
Move Clip Down - Swaps the currently selected clip with the one that follows it in the playlist.
Has no effect if the currently selected clip is at the end of the playlist or if more than one clip is



selected. 
Delete Clip from Playlist - Removes the currently selected clip from the playlist. 
Clear Playlist - Removes all clips from the playlist. 
Mark In  - Activates the current shuttle point as the start of the gray highlighted area. 
Mark Out - Activates the current shuttle point as the end of the gray highlighted area. 
Trim to Selection - Eliminates frames outside the selected sequence of the current clip(s), shown
by a gray highlight in the timeline below the playlist and graphic display panels. 
Reset Clip In/Out Points - Changes the current clip’s in point to 0 (zero), and out point to the
clip’s length. 
Add Clip to Playlist - In Record mode only, appends recorded clip to the playlist. 
Delete Clip - In Record mode only, removes the current clip from the playlist. 
Preview Clip - In Record mode only, shows the current clip in the video display area. 
Get Info - Brings up a window showing video attributes of the current clip; see the sminfo(1) man
page. 

The View menu contains the following items: 

Show Menu Bar - Toggles the display of ShotMaker menus. 
Show Borders and Title Bar - Toggles the display of components managed by the window system
(the outside of ShotMaker). 
Show Playlist - Toggles display of the playlist panel inside the main window. 
Show Dashboard - Toggles display of the dashboard at the bottom of the main window. 
Show Image on Graphics Screen - Toggles display of the video area inside the main window. 
Show Image on Video Output - Toggles display of the video signal to an external video monitor
connected to the video I/O board.  When off, video I/O resources are released. 
Time Units > - A submenu contains these radio buttons: 

Playlist Timecode - Displays SMPTE timecode, where 00:00:00:00 maps to the beginning of
the playlist. This is the default.  See also the Settings Dialog for adjusting the initial offset
and the timecode type for the playlist. 
Clip Timecode - Displays SMPTE timecode, where 00:00:00:00 maps to the beginning of
the currently active clip. Uses clip’s timecode offset. 
Playlist Frames - Displays the number of frames since the beginning of the playlist.  See the
Settings Dialog for adjusting the initial offset. 
Clip Frames - Displays the number of frames since the beginning of the currently active
clip. 

Aspect Ratio > - A submenu contains these radio buttons: 
Native - Preserves the aspect ratio of the current clip. 
4 : 3 - Changes the aspect ratio on the graphics screen to 4:3 
16 : 9 - Changes the aspect ratio on the graphics screen to 16:9 

Pixel Aspect Ratio > - A submenu contains these buttons: 
Native pixels - Preserves pixel aspect ratio of the clip. 
Square pixels - Changes pixels aspect ratio to 1:1. 
Rec601 525 - Changes pixels aspect ratio to be 11:10. 
Rec601 625 - Changes pixels aspect ratio to be 54:59. 

Letterbox - Toggles letterbox format for video display area. 
Zoom Up - Makes picture larger in the video display area. 
Zoom Down - Makes picture smaller in the video display area. 



Zoom > - A submenu allows you to set the zoom value to 25%, 50%, 100%, or 200%. 
Image Height > - A submenu allows you to set the image height to 480, 720, 1080, or resort to
Native video height. 

The Control menu contains the following items, which are mostly duplicated by Dashboard buttons: 

Tape Deck Control - Brings up the Diaquest module for controlling an external video tape deck.
See below for details. 
Mode - A submenu contains two check boxes for choosing either Playback or Record mode. 
Play - Begins playing the clip in the playlist, or the current selection. 
Record - Begins recording, if Record mode is active. 
Stop - Suspends playback (in Play mode) or recording (in Record mode). 
Play Reverse - Plays the clip or current selection backwards. 
Fast Forward - Begins playback at an accelerated rate. 
Fast Backward - Reverses playback at an accelerated rate. 
Forward One Frame - Advances the display one frame. 
Back One Frame - Moves the display back one frame. 
Go to Beginning - Moves the display to the beginning of the playlist. 
Go to End - Moves the display to the end of the playlist. 
Next Clip - Moves the display to the beginning of the next clip in the playlist. 
Previous Clip - Moves the display to the beginning of the previous clip in the playlist. 
Loop Mode - A submenu contains these radio buttons: 

Stop at End - Plays the contents of the playlist or the currently selected range all the way
through and then stops. 
Loop - Starts playing at the beginning of the playlist or the current selection once the end is
reached. Playback continues until you explicitly stop it. 
Swing - When a boundary of the playlist or the current selection is reached, playback
reverses direction and continues playing. Playback continues until you explicitly stop it. 

Mute Audio - Toggles audio muting during playback and shuttle operations. 
Enable Audio File - Toggles use of audio file instead of the clip soundtrack. 

The Tools menu contains the following items: 

Audio Panel - Brings up the audiopanel(1) program to control system audio settings. 
Video Panel - Brings up the videopanel(1) program to control system video settings. 
IRcombine - Brings up the ircombine(1) program to control the video output format (VOF). This
includes the monitor refresh rate, which should be approximately an even multiple of your
playlist’s frame rate. 

The Help menu contains the following items: 

User’s Guide - Starts HTML help showing an outline of available writeups about ShotMaker. 
About ShotMaker - Brings up a dialog containing program version number, copyright, and
authorship. 

Keyboard accelerators are assigned to items in these pulldown menus where appropriate. Menu items
are grayed out when not applicable. 



Playlist Table

The playlist contains an ordered list of clips. Rearranging the order of clips in the playlist affects the
ordering of clips during playback, and their graphical representation in the timeline. Each clip in the
playlist displays attributes as follows: 

Icon - A thumbnail representation of the first frame in a clip. 
Clip - Name of the clip. 
In  - The in point relative to the beginning of the clip. This field is editable, and defaults to
00:00:00:00. It cannot be set to a value less than 00:00:00:00 or greater than the out point. 
Out - The out point relative to the beginning of the clip. This field is editable and defaults to the
duration of the clip. It cannot be set longer than the clip duration or less than the in point. 

The width of the columns can be adjusted by clicking and dragging on the column label separators at the
top of the panel. When the Icon column is resized, all the icons or thumbnails are scaled appropriately.
This allows thumbnails to be any size because they are always scaled to fit the column. 

A clip is selected by left-clicking on it. Once it is selected, it can be moved up or down in the playlist, or
deleted from the playlist.  Right clicking on a clip brings up the edit menu for that clip. 

Video Display

This area displays a video clip during playback. The graphics display area resizes itself to the current
clip size as necessary.  This area is also resized based on the current options in the View menu.  A right
mouse button click in the video display area will bring up a popup menu that mimics much of the
behavior of the main pulldown menu. 

Dashboard Buttons

This panel displays the following information: 

Current timecode or frame (depending on selected Time Units) in big numbers on the left. This
field may be edited for non-linear access. The buttons immediately to the right move backward
and forward one frame at a time. 
Range in timecode or frame (depending on selected Time Units) underneath. These fields may be
edited, to allow specification of arbitrary ranges. The range start cannot be set to a value after the
range end. The buttons underneath the range also permit precise setting of start and end times. 
Current frame rate in frames per second, on the far right. 

The Dashboard panel also contains control buttons, all with corresponding menu items (except the
playback shuttle and the volume control). From left to right they are as follows: 

Playback Shuttle - A slider on a narrow gray bar that acts as both a display and a control for the
current playback speed. The shuttle changes position when playback starts, stops, reverses, and so
forth. The hatch marks from left to right indicate: ultrafast reverse play, fast reverse play, reverse,
stop, play, fast play, and ultrafast play. When you move the shuttle with the left mouse button, it
puts one of these modes into effect until you release the mouse button, at which time the shuttle
returns to its center position, and the frame counter remains set where the shuttle left it. When you



move the shuttle with the middle mouse button, the shuttle remains in the mode where you left it,
and the selected reverse or forward mode remains in effect until stopped. 
Loop Mode Selection Menu - Provides a convenient alternate method for selecting the playback
loop mode (one-way, loop, or two-way). 
Mode ratio buttons - selects Record or Play. 
Go to Beginning 
Fast Backward 
Reverse 
Stop 
Play 
Fast Forward 
Go to End 
Record (disabled in Play mode) 
Volume Control - A slider that controls the audio volume for playback. The range is from mute to
full. 

Above the dashboard buttons, a timeline graphically shows the ordering and relative duration of clips in
the playlist. Just above the timeline, in red, is the current-display-frame indicator, which shows where in
the playlist the active frame is located. The indicator can be dragged around to randomly access any
frame in the playlist. If you click with the left mouse button and drag out a region on the timeline, that
region becomes the currently selected range, and is shaded gray to indicate its extent. The beginning and
ending times of this segment are displayed as a range at the bottom left corner of the Dashboard. To
clear the currently selected range, click once anywhere on the timeline. 

Settings Dialog

The ShotMaker Settings dialog, available from the File > Settings menu, allows you to change various
recording and playback attributes. There are four tabs at the bottom of the ShotMaker Settings dialog: 

Video Device Recording - 
video format - format of video to be recorded to disk. 

Standard - the video standard you are recording 
Packing - the in-memory colorspace and precision of the video you will record to disk. 
Note that ShotMaker may not be able to monitor YCrCb on the graphics screen of
some platforms.   In general, packings that do not specify precision are 8-bit per
component. 
Layout - for interlaced video standards, whether video video frames are stored as two
separate fields, or one frame. 
Dominance - for interlaced video, the field dominance 

Note that the video format has an affect on the available duration of recording disk space. 
  
audio format - format of audio to be recorded to disk 

sample rate - sample rate of the audio 
channels - number of channels of audio 
disable audio - you can disable the recording of audio by selecting this toggle 

video device  - video device to use for recording.  Note that selecting the video device may



alter the available standards and packings. 
audio devices - audio device to use for recording.  Note that selecting a new audio device
may alter the available sample rates 
dropped frame policy - specify what to do if a frame is dropped during recording 
recording directory - the directory into which recorded clips are placed 

Graphics Screen Recording 
size - size of screen region to be recorded.  Note that non-standard  sizes may be selected by
choosing the Non standard video option along with the selector described below 
rate - this is the image rate that the recorded clip will be labelled with.  This is not to be
confused with the rate at which images are recorded from the screen. 
packing - the colorspace and/or precision of the video you will record to disk.   In general,
packings that do not specify precision are 8-bit per component. 
selector - 

fixed area - highlighted rectangle may be moved but width and height remain fixed 
variable area - rectangle may be selected by clicking down, moving the mouse, and
releasing. 
window, no borders - area is selected by clicking on a window.  This specifies the
region of the screen, not the window.  That is, if the window is moved, the region to be
recorded will not change. 
window, with borders - as above, but the region will include the window manager
borders 
full screen - entire screen area will be recorded 

trigger - 
trigger button (or -trigger) : user must press the Trigger button in the dashboard for
each frame to be captured.  Alternatively, running ShotMaker -trigger will cause the
same thing. 
automatic:  ShotMaker will  capture the requested number of frames a second. 

dropped frames - 
abort - abort the capture if a frame is dropped 
report - report the number of dropped frames when the capture is completed 
ignore - ignore dropped frames 

recording directory - this is the directory into which recorded clips will be placed 
 

Playback - 
video and audio devices - Note that ShotMaker will auto-select the video-output device
based on the currently loaded playlist unless there are multiple video boards of the same
type.  Then, the user may choose among the available devices.  ShotMaker will also gray out
the devices that can’t play the currently loaded playlist. 
dropped-frame policies - 

abort - halt playback if a frame is dropped 
report - report the number of dropped frames when playback stops 
ignore - ignore dropped frames 

Note that when ShotMaker is playing simultaneously to graphics and video-output, it will
watch for dropped frames on video. 
  
graphics synchornization policy - this setting only has an effect when graphics display is



double-buffered 
drop frames - ShotMaker will drop video frames as necessary to maintain accurate
synchronization 
play all frames - ShotMaker will play all video frames; this may result in drift between
audio and graphics 

Miscellaneous - 
deck control configuration - time-stamped serial line device and calibration offsets 
system memory cache size 
graphics screen configuration - double-buffered display setting.  Some configurations may
not support double-buffered display. 
error reporting - two orthogonal settings, you may have one neither, one, or both 

terminal - whether or not to display errors to the terminal 
dialogs - whether or not to display errors to a dialog box 

automatic insertion of recorded clips into the playlist 

All settings in this dialog are "sticky" and once applied will remain from session to session. 

Deck Control Dialog

With optional Diaquest software installed, the Tape Deck Control menu item brings up this dialog: 



Figure 2: Deck Control Dialog

The transport buttons in this dialog work precisely like the ones in the Main Window except that rather
than controlling the disk system, they control the tape deck.    Like the rest of ShotMaker, this dialog
provides different functionality depending on whether the application is in playback or record mode.  In
record mode, the dialog enables frame accurate captures.  When ShotMaker is in playback mode, the
dialog enables frame accurate laydowns. 

You can shuttle the deck to a specific timecode by typing it into the current timecode display and hitting
return. 

When in playback (laydown) mode, the ’Monitor Deck’ button can be used to toggle on/off monitoring
of the tape deck.  When the monitor is on, ShotMaker displays the contents of the tape.  When it is off,
ShotMaker displays the contents of the playlist/clip. 
  
  



Appendix
This appendix describes miscellaneous topics. 

Troubleshooting Solutions

This section lists several potential problems, along with known diagnostics, solutions, and
work-arounds. 

Dropped Frames:  There are two kinds of dropped frames: frames dropped from video and
frames dropped from graphics.  When ShotMaker is playing to both graphics and video, it
only reports on frames dropped to video.  When ShotMaker is recording, it only reports
frames dropped from video. It will also sacrifice graphics monitoring to avoid dropping
video frames during recording.  Dropped frames to/from video can be caused by

1. Your file or recording directory is not located on the proper XLV volume. 
2. There is not enough disk bandwidth (try running the bandwidth test in the application or

smbandwidth).  If this is a problem, check the disk fragmentation section below as well as
the recommendations for the video format you are running. 

3. There is not enough memory bandwidth.  Make sure you have the proper configuration for
the number of streams of video you are using. 
 

ShotMaker assumes a relatively quiescent system. 
  

1. Make sure that there are no other applications making heavy use of the system. 
2. Make sure there are no other processes reading or writing to the XLV volume currently in

use. 
 

Dropped frames to graphics are typically the result of other programs on the system disrupting
ShotMaker’s graphics process.  Follow the following procedure to minimize dropped frames to
graphics: 
  

1. Stop programs that make updates to the graphics screen like netscape and clock.  Any event
which causes the graphics system to change contexts can result in dropped frames to the
graphics screen. 

2. Make sure that the cursor is still during playback. 
3. If perfect graphics playback is required, disable output to video and isolate the processor

ShotMaker is using for drawing to the graphics screen.  Here are details on processor
isolation: 

  
To ensure real-time graphics playback on multiprocessor systems, it may be desirable
to isolate the processor ShotMaker uses for graphics, which by default is processor 1.
The superuser can isolate processor 1 for graphics playback using the mpadmin
command as follows: 

# mpadmin -I1



The mpadmin command with just the -I option lists the currently isolated processors.
To unisolate that processor, use the -I option as follows: 

# mpadmin -U1

See man mpadmin(1) for more details on processor isolation. 
 

If you are still seeing dropped frames 
  

1. Hide the deck control dialog and dashboard. 
2. Start shotmaker from the command line and redirect standard error and output 

% shotmaker >& /tmp/shotmaker.output

If shotmaker continues to drop frames after all of these steps have been taken, or you are seeing
other strange and unexplainable behavior with HD I/O, then it may be a problem with the videod
daemon. As a last-ditch effort, try: 

% su
# killall videod

This will shutdown the daemon. The next time you launch ShotMaker, videod will automatically
restart itself. 

Dropped Frames During Capture: If you encounter dropped frames during capture, make sure the
recording directory is set to an XLV volume that was created by smsetup.  Turning off the
graphics monitoring may also improve performance here.  You may also be running into problems
stemming from a fragmented or nearly full filesystem.  Yet another cause of apparant dropped
frames can be the audio device.  If a digital audio device has no input source clock or clock,
ShotMaker may appear to drop frames.  Simply connect a valid audio signal to the input jack or
select an audio input source that does not require a valid signal (e.g., analog output). 

Dropped Frames During Laydown: If you encounter dropped frames during laydown to tape, you
should turn off the graphics display. Do this by (temporarily) unchecking Show Image on
Graphics Screen in the View menu.  See also the section above on dropped frames. 

Video Tearing and Jitter on the Graphics Screen: Make sure to use double-buffered playback. 
See the Miscellaneous section of the Settings Window or use the -doubleBuffer command line
option. 

Interlacing Artifacts on the Graphics Screen:   The graphics screen is typically configured for
progressive (non-interlaced) video.  Any attempt to show interlaced video on the graphics monitor
will thus result in temporal artifacts.  To avoid these artifacts, use ircombine to select a video
format that is interlaced.  For example, 1920x1080_30i. 

Video Sync Drift: For both playing and recording, the HD I/O board currently assumes a frame
rate of 29.97 (not 30) fps, or 59.94 (not 60) fps. InfiniteReality (IR) graphics allow playing of
content at either 29.97 or 30 fps, or at 59.94 or 60 fps. You can avoid sync drift only with 29.97 or
59.94 fps content, if you genlock IR to an external fixed 525 NTSC source, and genlock your



audio device to the same external NTSC video  source. 

Deck Control Problems:  Here are a series of troubleshooting steps for deck control problems. 
1. Ensure that no other process is using the serial port that ShotMaker is trying to use for deck

control. 
2. Make sure that the deck and video IO board are locked to the same reference signal. 
3. Make sure that the tape has a clean control track and contiguous timecode over the section

you are attempting to use. This applies to both captures and laydowns. Otherwise, you will
likely see errors such as failures during laydowns and captures, failures during gotos, and
inconsistent timecode readings. 

4. Avoid the first and last 5 seconds of the tape during laydowns and captures. Having at least
30 seconds of leader at the beginning of the tape is recommended. 
 

Disk Fragmentation: Do not run smconvert when other disk write activity is occurring. For
instance, running two or more smconvert processes simultaneously will almost certainly result in
XFS filesystem fragmentation. 

One work-around for fragmentation is to increase the number of buffers in the ShotMaker frame
cache. You can do this inside the ShotMaker Settings window, or using the -numCacheFrames
command-line option for the -noGui mode.  This may enable ShotMaker to work over a few
highly fragmented sections.  But if the file is too fragmented, increasing the buffer cache will not
help. 

One possible reason for non-realtime playback is file fragmentation. The XFS filesystem attempts
to lay out a file with large continuous data blocks. Each such block is called an XFS extent. Under
some conditions, especially a nearly full filesystem, contiguity may be impossible. Rather than a
having a few very large extents, the file may contain many smaller extents. Since a disk seek
occurs between each extent, fragmentation can severely impact realtime playback. 

Here are some tools for detecting and possibly correcting fragmentation: 
  

1. smbandwidth and the ShotMaker disk bandwidth test 

The bandwidth test reports the approximate frame number at which significant fragmentation
was detected. If no significant fragmentation was detected, this is also reported. 

The bandwidth test uses a fairly pessimistic heuristic to define "significant" fragmentation,
so the test might report fragmentation even if a file can be played reliably in realtime. If this
is the case, no further action is needed. 
  

2. xfs_bmap 

The xfs_bmap command prints the disk block mapping for an XFS file. An example of how
to interpret its results appears below. For more information, see the xfs_bmap(1M) man
page. 



Suppose that the 1080i rgb clip test.qt is not reliably playing in realtime. By running
xfs_bmap -l, we see the file’s block mapping: 

% xfs_bmap -l test.qt
test.qt:
  0: [0..31]: 2063040..2063071 32 blocks
  1: [32..12191]: 9017472..9029631 12160 blocks
  2: [12192..24351]: 37682688..37694847 12160 blocks
  3: [24352..36511]: 39871872..39884031 12160 blocks
  4: [36512..48671]: 52248192..52260351 12160 blocks

(similar entries deleted for brevity...) 

  103: [1240352..1252511]: 424586112..424598271 12160 blocks
  104: [1252512..1264671]: 426676224..426688383 12160 blocks
  105: [1264672..1276831]: 428764032..428776191 12160 blocks
  106: [1276832..2030751]: 434297088..435051007 753920 blocks
  107: [2030752..4110111]: 435063168..437142527 2079360 blocks
  108: [4110112..5812511]: 437154816..438857215 1702400 blocks

The information of interest from each entry is the "n blocks" appearing at the end of each
entry. This is the extent size in blocks. An XFS block consists of 512 bytes. 

To map these XFS blocks to video frames, a single frame of video from test.qt contains
1920*1080*3 bytes, or 12150 blocks. Each frame in the file will be aligned to a 16K
boundary, yielding an aligned size of 12160 blocks per frame. 

Armed with the knowledge that a frame from test.qt is 12160 blocks, we see that extents
1-105 each contain a single frame of video. Clearly, this file is badly fragmented. 
  

3. fsr_xfs 

IRIX 6.5.4 and later include an XFS filesystem reorganizer, fsr_xfs, which attempts to
reorganize an XFS file or filesystem in order to reduce the number of extents. For more
information, see the fsr_xfs(1M) man page.
  
Continuing with the above example, you could try to defragment test.qt by running the
command: 

# fsr_xfs -v test.qt

With the -v option, fsr_xfs would say "No improvement made" if it was unable to
defragment the file. Assuming it was able to defragment, you can reexamine the
fragmentation of test.qt: 

% xfs_bmap -l test.qt
  0: [0..5812511]: 1658752..7471263 5812511 blocks

Ideally, the file would be completely defragmented, as shown in the message above.
However, any significant reduction in the number of extents is likely to improve playback
performance.



If none of these tools help minimize fragmentation, as a last resort, you will need to make a new
clean XFS filesystem on your XLV.  You can remove the current filesystem and XLV and re-run
smsetup, or, if you have saved the output from your first smsetup, you can simply remake the
filesystem.  Alternatively, a clean xfsdump/xfsrestore of you filesystem should minimize
fragmentation. 
  

GLwMDrawingArea Errors: On systems with 24-bit visuals, but no alpha channel, for example
"NG1" graphics as reported by/usr/gfx/gfxinfo , ShotMaker quickly exits with this error: 

Error: GLwMDrawingArea: requested visual not supported

A workaround is to run ShotMaker with the following option: 

% shotmaker -xrm "ShotMaker*alphaSize: 0" ...

Another solution is to copy /usr/lib/X11/app-defaults/ShotMaker into your home directory,
and add this line to that file: 

ShotMaker*alphaSize: 0

Performance Problems with More than 4 FibreChannel Adapters: If ShotMaker video content is
stored on an XLV striped volume spanning more that 4 FibreChannel adapters, I/O throughput
may not be as great as would be expected. In order to optimize for common configurations,
ShotMaker restricts I/O for 1080 content to one frame at a time, and 720 content to 2 frames at a
time. This provides optimal disk usage when 1-4 FibreChannel adapters are used. For
configurations with more adapters, use the environment variable NP_MAXFRAMES_PER_IO can
be used to override this I/O restriction. 

To calculate the correct value for NP_MAXFRAMES_PER_IO, use the following rough guide:
Realtime I/O of a single frame of 1080 content requires one FibreChannel adapter for each byte of
pixel depth; 720 bandwidth is half that of 1080. 

For example, in a configuration that stripes 1080 RGBA content across 8 FibreChannels adapters,
this setting would yield better disk bandwidth. 

setenv NP_MAXFRAMES_PER_IO 2

If the content were 720, a value of 4 would be optimal.

Launching ShotMaker from HTTP

This describes how to configure the system’s browser to launch a ShotMaker session
whenever a playlist file in a web page is clicked on. It also describes what changes are
needed on the HTTP server to get this to happen. The same procedure holds for launching
playlists -- the only thing that is different is the name of the MIME type and its associated
file suffix. 



In Netscape, add create a new helper application type under the Preferences menu. The new
application helper description should be called ShotMaker , the MIME type should be
application/shotmaker  and the suffix should be whatever playlist suffix is decided upon.
(For example, .ply .) The application that should be launched is: 

/usr/sbin/shotmaker %s >/dev/null 2>&1

(The output redirection is not required but will keep any messages sent to standard out or
standard error from being displayed in a pop-up window by Netscape.) Any other desired
command line arguments can be added to this line as well. 

To get the HTTP server to understand session files, you must edit the HTTP server’s
mime.types  file in the config  directory. Add the following line to the mime.types  file: 

type=application/shotmaker exts=ply

Again the extension is arbitrary, but it must match the suffix of the playlist files.

Environment Variables

The following is a list of environment variables that may be of some use.  Buyer beware. 

NP_MAXDMA : maximum DMA for file IO
NP_MAXFRAMES_PER_IO : maximum frames per IO for all clips
NP_MAX_FRAMES_OFF : maximum number of frames of a/v sync error before a correct i
NP_MAX_OPEN_CLIPS : maximum number of open clips in the cache
NP_MAX_SPEED : maximum playback speed
NP_MAX_SPEED_FOR_AUDIO : maximum speed for audio interpolation code
NP_MIN_SPEED : mininum playback speed
NP_MIN_UNC_RECOMMENDED_CACHE_FRAMES : default number of cache frames for an unc o
NP_NO_IMAGE_PLAYBACK : disable graphics and video playback
NP_NO_MUSTRUN : disable processor assignments for internal threads
NP_NUM_CACHE_FRAMES : size of shotmaker engine cache
NP_SECS_PER_FRAME_RATE_UPDATE : seconds per update of the achieved frame rate
NP_SECS_PER_SPACE_UPDATE : seconds per update of the available disk space
NP_SWGFXIN_NO_POINTER : remove the pointer from graphics screen captures
NP_XTHD_POOL_MASK : override mask used for allocating DMbufferpool accross node s
NP_UNC_STRIPE_ALIGN : make sure uncompressed clips are aligned to the end of th e


